Qué es WinRAR

WinRAR es una versión del compresor RAR para Windows, una herramienta potente que le permite crear, manejar y controlar los ficheros de archivo. En la actualidad, existen varias versiones de RAR para varios sistemas operativos:Windows, Linux, FreeBSD, y Mac OS X.

Existen dos versiones de RAR para Windows:

  • Versión con interfaz gráfica de usuario: WinRAR.exe;

  • Versión para consola (modo texto) de línea de órdenes: Rar.exe.

WinRAR y los módulos autoextraíbles de WinRAR requieren Windows XP o posterior.

Características de WinRAR

  • Permite el uso de archivos RAR y ZIP 2.0 sin ningún problema;
  • Algoritmo original de compresión sumamente sofisticado;
  • Algoritmos optimizados para texto, sonido, gráficos y para ejecutables Intel de 32 y 64 bits;
  • Interfaz de intérprete de órdenes con la función Arrastrar y soltar y un asistente;
  • Interfaz de línea de órdenes ;
  • Manejo de archivos que no son RAR (7Z, ACE, ARJ, BZ2, CAB, GZ, ISO, JAR, LZH, TAR, UUE, XZ, Z);
  • Compresión sólida, que puede aumentar la razón de compresión entre un 10% y un 50% respecto a los métodos más comunes, en especial, al comprimir un gran número de ficheros pequeños y similares;
  • Archivos multivolumen ;
  • Creación de archivos auto extraíbles (también multivolumen) utilizando los módulos auto extraíbles predeterminados u opcionales;
  • Recuperación de los archivos dañados físicamente;
  • Volúmenes de recuperación que permiten la recuperación de partes dañadas de archivos multivolumen.
  • Permite el uso de caracteres Unicode en los nombres de fichero;
  • Otras funciones como codificación , comentarios de archivo, registro de errores, etc.


Limitaciones de WinRAR

El número de ficheros que se puede agregar a un archivo depende de la cantidad de memoria disponible y de la extensión de los nombres del fichero. Se necesitan aproximadamente 128 bytes de memoria por fichero comprimido para un archivo RAR. Por ejemplo, si desea comprimir un millón de ficheros WinRAR puede usar hasta 128 MB para almacenar información de los ficheros además de la memória requerida por el algoritmo de compresión. WinRAR ha sido puesto a prueba para manejar cerca de un millón de ficheros.

El tamaño de un archivo RAR o ZIP, al igual que el de cualquier fichero contenido en un archivo RAR o ZIP, está limitado a 8.589.934.591 GB (9.223.372.036.854.775.807 bytes). Tenga en cuenta que para crear archivos mayores de 4 GB necesita utilizar un sistema de ficheros que soporte estos tamaños, como por ejemplo el sistema NTFS.


Versión RAR para consola

En el programa de distribución, además de WinRAR, encontrará el fichero rar.exe. También es una versión RAR para Windows, pero sólo es compatible con la interfaz de línea de órdenes en modo texto. Es útil para llamar a la consola RAR desde archivos BAT y CMD, para utilizarlo en el simbolo del sistema, etc. Comparándolo con WinRAR, admite un número mayor de órdenes y también de parámetros en la línea de órdenes. Aunque ciertos aspectos generales de la sintaxis de WinRAR para la línea de órdenes tratados en el capítulo Interfaz de línea de órdenes también son aplicables al RAR para consola, este fichero de ayuda no contiene descripciones de los parámetros y órdenes compatibles únicamente con la versión para consola. Deberá consultar el fichero rar.txt para una descripción detallada de todas las características de la consola RAR.


Reconocimientos

Queremos dar las gracias a Ron Dwight, quien hizo tanto por RAR y sus usuarios y que lamentablemente no podrá ver nunca más las nuevas versiones del WinRAR.

WinRAR incorpora el código del grupo Info-ZIP que usa para manejar archivos ZIP.

El algoritmo de compresión de texto está basado en el código fuente de dominio público PPMII de Dmitry Shkarin y el código fuente de dominio publico carryless rangecode de Dmitry Subbotin. que puede encontrar en ftp.elf.stuba.sk/pub/pc/pack.

La codificación de WinRAR incluye partes de código de la implementación AES de Szymon Stefanek y Brian Gladman y del código SHA-1 de Steve Reid.

WinRAR utiliza la función CRC32 basada en el algoritmo Intel Slicing-by-8.

Los archivos RAR pueden incluir opcionalmente sumas de control BLAKE2sp, desarrollado por Jean-Philippe Aumasson, Samuel Neves, Zooko Wilcox-O'Hearn y Christian Winnerlein.

Los útiles consejos proporcionados por Alexander Khoroshev y Bulat Ziganshin permitieron mejorar de forma notable la compresión y la velocidad de RAR.

Los archivos 7z se descomprimen usando la librería 7zxa.dll cuyos derechos de copia son propiedad de Igor Pavlov, desarrollador del compresor 7-zip. 7zxa.dll se distribuye bajo licencia GNU Lesser General Public License (LGPL) versión 2.1 o posterior. Usted puede modificar partes de la librería 7zxa.dll y usar técnicas de ingeniería inversa unicamente para depurar las modificaciones en dicha librería en acordancia con la licencia LGPL. Los archivos XZ se descomprimen usando el DSK de dominio público LZMA de Igor Pavlov. El código fuente de la libreria 7zxa.dll y el SDK LZMA están disponibles en www.7-zip.org.

Hemos usado el escrito "Screaming Fast Galois Field Arithmetic Using Intel SIMD Instructions" de James S. Plank, Kevin M. Greenan y Ethan L. Miller para mejorar la velocidad del código Reed-Solomon. También damos las gracias a Artem Drobanov y Bulat Ziganshin por los ejemplos e ideas que permiten hacer el código Reed-Solomon mas effciente.

Los archivos ACE se descomprimen usando la librería unacev2.dll proporcionada por los desarrolladores de WinAce - www.winace.com.

Francesco Indrio <om-studio@tiscali.it> diseñó todos los gráficos nuevos de WinRAR.

La idea de la ampliación del intérprete de órdenes WinRAR está inspirada en Ylian Saint-Hilaire y su programa "Extensión del intérprete de órdenes RAR".

Gracias a Judit Rodriguez Blanco por su inestimable ayuda en la traducción de la versión 2.90 del WinRAR al castellano, también a Iván Romero Raposo por la traducción al gallego y a M.A.G. por la trducción del fichero Rar.txt y NotasTec.txt de la versión 3.70.

Y, en especial, gracias a Andrey Spasibozhko por su ayuda en el desarrollo y promoción de las primeras versiones RAR.


Tutorial breve

Modos intérprete de órdenes y línea de órdenes

WinRAR se puede utilizar de dos formas: en el modo gráfico del intérprete de órdenes con la interfaz estándar de Windows o en línea de órdenes. Para iniciar el intérprete de órdenes WinRAR, sencillamente haga doble clic en el icono de WinRAR. Entonces podrá utilizar botones y menús para comprimir y extraer. Consulte los temas incluidos a continuación para conocer las instrucciones paso a paso

Cómo extraer ficheros utilizando el modo intérprete de órdenes WinRAR

Cómo comprimir ficheros utilizando el modo intérprete de órdenes WinRAR

Para utilizar WinRAR en el modo línea de órdenes, es necesario abrir en el Menú Inicio las ventanas "Programas/ Accesorios / Simbolo del sistema" o "Ejecutar…" e introducir el texto de la orden. En los temas expuestos a continuación, puede encontrar ejemplos de órdenes sencillas para comprimir y extraer. No obstante, encontrará una explicación más detallada del modo línea de órdenes en el tema de ayuda Modo línea de órdenes. Tenga en cuenta que si ejecuta WinRAR desde la línea de órdenes sin parámetros, se activará el modo intérprete de órdenes.

Cómo extraer ficheros utilizando la línea de órdenes

Como comprimir ficheros utilizando la línea de órdenes

Si no desactivó la opción "Integrar WinRAR en el intérprete de órdenes" al instalar WinRAR, también puede extraer y comprimir ficheros directamente en el intérprete de órdenes de Windows (Explorador o Escritorio). Encontrará más detalles a continuación.

Cómo extraer ficheros en el Explorador o en el Escritorio

Cómo comprimir ficheros en el Explorador o en el Escritorio


Tutorial breve: extraer ficheros utilizando el modo intérprete de órdenes WinRAR

Tutorial rápido: extraer ficheros utilizando el modo intérprete de órdenes WinRAR

En primer lugar, para extraer ficheros utilizando el modo intérprete de órdenes WinRAR, debe abrir el archivo necesario en WinRAR. Esto lo puede conseguir de varias formas:

Haga doble clic o pulse Intro sobre el nombre del archivo situado en el intérprete de órdenes de Windows (Explorador o Escritorio). Si se asoció WinRAR con archivos durante la instalación (la opción predeterminada de instalación), se abrirá un archivo en WinRAR. También puede asociar WinRAR con archivos una vez realizada la instalación utilizando el cuadro de diálogo Configuración de la integración;

Haga doble clic o pulse Intro sobre el nombre del archivo situado en la ventana WinRAR;

Arrastre y coloque un archivo en el icono o en la ventana de WinRAR. Antes de hacer esto, asegúrese de que no hay ya otro archivo en WinRAR, ya que sino se agregará el archivo colocado al que ya aparecía en pantalla;

Ejecute WinRAR desde la línea de órdenes con un único parámetro, el nombre de archivo.

Al abrir un archivo en WinRAR, se muestra su contenido. Seleccione los ficheros y las carpetas que se deberán extraer. Puede hacer esto pulsando MAYÚS + teclas de dirección o MAYÚS + botón izquierdo del ratón del mismo modo que en el Explorador y en otros programas de Windows. En WinRAR, también se pueden seleccionar ficheros utilizando la barra espaciadora o la tecla Ins (Insertar). Las teclas "NUM+" y "NUM -" del teclado numérico permiten seleccionar grupos de ficheros utilizando máscaras de fichero.

Una vez haya seleccionado uno o más ficheros, haga clic en Extraer en situado en la parte superior de la ventana WinRAR o pulse Alt+E, escriba la carpeta de destino en el cuadro de diálogo y haga clic en Aceptar. Este cuadro de diálogo también ofrece algunas opciones avanzadas (consulte el cuadro de diálogo Ruta de extracción y opciones para más información).

Durante el proceso de extracción, aparecerá una ventana en pantalla con las estadísticas de la operación. Si desea interrumpir el proceso de extracción, haga clic en el botón Cancelar de la ventana de mandos. Puede hacer clic en "Segundo plano" para minimizar WinRAR en la bandeja. Si finaliza la extracción sin ningún error, WinRAR regresará al intérprete de órdenes. En caso contrario, aparecerá en pantalla una ventana de mensaje de diagnóstico.


Tutorial breve: extraer ficheros desde la línea de órdenes

Tutorial rápido: extraer ficheros desde la línea de órdenes

La sintaxis de línea de órdenes común para extraer ficheros con su ruta de acceso completa es:

WinRAR X [ -parámetro] <Archivo> [ Fichero] [ @Listas de fichero] [ Carpeta de destino\ ]

Para extraer los ficheros, ignorando las rutas de extracción, se utiliza:

WinRAR E [ -parámetros] <Archivo> [ Ficheros] [ @Listas de fichero] [ Carpeta de destino\ ]

Por ejemplo, si desea extraer el fichero CARTA.TXT en la carpeta actual desde el archivo CARTAS.RAR, utilice la siguiente orden:

WinRAR X CARTAS.RAR CARTA.TXT

La extensión del archivo es opcional y se puede omitir.

La siguiente orden extrae todos los ficheros *.WAV en la carpeta Audio desde el archivo Canciones:

WinRAR X Canciones *.WAV Audio\

También se pueden listar en un fichero aquellos ficheros que se van a extraer, en lugar de enumerarlos en la línea de órdenes. En este caso, se debe escribir en la línea de órdenes el nombre del fichero de texto que contiene la lista de ficheros que se van a extraer. Esto se indica mediante la colocación del símbolo @ antes del nombre de este fichero. Así pues, si usted crea un fichero Binarios, que contiene la cadena de caracteres *.exe y *.com, ejecute la orden:

WinRAR X TOOLS @Binarias

se extraerán en la carpeta actual todos los ficheros del archivo TOOLS con extensión EXE y COM.

Durante el proceso de extracción, aparecerá en pantalla una ventana con las estadísticas. Si desea interrumpir el proceso de extracción, haga clic en el botón Cancelar de la ventana de mandos. Puede pulsar el botón "Segundo plano" de esta ventana para minimizar WinRAR en la bandeja. Si se completa la extracción sin ningún problema, se finalizará WinRAR. En caso de que se produjese un error, aparecerá en pantalla una ventana de mensaje de diagnóstico.

Consulte Interfaz de línea de órdenes para una descripción más detallada de las órdenes y los parámetros.


Tutorial breve: extraer ficheros en el Explorador o en el Escritorio

Tutorial rápido: extraer ficheros en el Explorador o en el Escritorio

Si no desactivó la opción "Integrar WinRAR en el intérprete de órdenes" al instalar WinRAR, puede extraer ficheros directamente en un intérprete de órdenes Windows. Pulse el botón derecho del ratón sobre el icono del archivo, seleccione la orden "Extraer ficheros…", introduzca la carpeta de destino en el cuadro de diálogo y haga clic en "Aceptar". Este cuadro de diálogo ofrece algunas opciones avanzadas (consulte el cuadro de diálogo Ruta de extracción y opciones para más información).

También puede seleccionar la orden "Extraer en <nombre de la carpeta>" para extraer en la carpeta propuesta sin ninguna petición adicional o “Extraer aquí” para extraer los ficheros en la carpeta actual.

Tenga en cuenta que si la opción "Menús contextuales en cascada" del cuadro de diálogo Configuración de la integración está activada, necesita abrir el submenú "WinRAR" para acceder a las órdenes antes descritas. En caso contrario, estarán situadas en el menú de nivel superior.

Otro método es arrastrar uno o varios archivos con el botón derecho del ratón, colocarlos en la carpeta de destino y seleccionar "Extraer aquí” en el menú que aparecerá.


Tutorial breve: comprimir ficheros desde el intérprete de órdenes

Tutorial rápido: comprimir ficheros desde el intérprete de órdenes WinRAR

En primer lugar, necesita ejecutar WinRAR. Haga doble clic o pulse Intro sobre el icono de WinRAR. También puede iniciarlo desde el "Menú Inicio" de Windows: colóquese sobre "Programas", después sobre "WinRAR" y, por último, ejecute el elemento "WinRAR".

Cuando se está ejecutando WinRAR, muestra una lista de ficheros y carpetas en la carpeta actual. Debe ir a la carpeta que contiene los ficheros que va a comprimir. Puede utilizar Ctrl+D, la lista de unidades situada debajo de la barra de herramientas o hacer clic en el pequeño icono de un disco colocado en la esquina inferior izquierda para cambiar la unidad actual. Pulse la tecla de retroceso, Ctrl+RePág, haga clic en el botón "Subir un nivel" situado debajo de la barra de herramientas o doble clic sobre la carpeta cuyo nombre es ".." para ir a la carpeta anterior. Pulse Intro, Ctrl+AvPág o haga doble clic sobre cualquier otra carpeta para abrirla. Ctrl+\ fija como carpeta actual la carpeta raíz del disco o del archivo.

Una vez haya introducido la carpeta con los ficheros deseados, seleccione los ficheros y las carpetas que va a comprimir. Para ello, puede utilizar MAYÚS + teclas de dirección o el ratón del mismo modo que en el Explorador o en otros programas de Windows. En WinRAR, también puede utilizar la barra espaciadora o la tecla Ins (insertar) para seleccionar los ficheros. Las teclas "NUM +" y "NUM -" del teclado numérico permiten seleccionar grupos de ficheros utilizando máscaras de fichero.

Una vez seleccionados uno o más ficheros, haga clic en el botón Agregar situado en la parte superior de la ventana WinRAR, pulse Alt+A o seleccione la orden "Agregar ficheros al archivo" del Menú Órdenes. Escriba el nombre del archivo de destino en el cuadro de diálogo que aparece en pantalla o simplemente acepte el nombre predeterminado. En este cuadro de diálogo, puede seleccionar el formato del nuevo archivo (RAR o ZIP), el nivel de compresión, el tamaño del volumen y otros parámetros de compresión. La descripción detallada de este cuadro de diálogo aparece en el tema cuadro de diálogo Nombre de archivo y parámetros. Haga clic en Aceptar cuando esté preparado para crear un nuevo archivo.

Durante el proceso de compresión, aparecerá en pantalla una ventana donde se verán las estadísticas de la operación. Si desea interrumpir el proceso de compresión, haga clic en el botón Cancelar de la ventana de mandos. Puede pulsar el botón "Segundo plano" de esta ventana para minimizar WinRAR en la bandeja. Una vez finalizada la compresión, la ventana de mandos desaparece y el nuevo archivo creado se convierte en el fichero seleccionado en ese momento.

También se pueden agregar ficheros a un archivo RAR existente utilizando la función Arrastrar y colocar. Seleccione el archivo deseado en la ventana WinRAR y pulse Intro (o haga doble clic) sobre su nombre. RAR leerá el archivo y mostrará su contenido en pantalla. Ahora puede agregar ficheros al archivo con tan sólo arrastrarlos desde otro programa y colocarlos en WinRAR.


Tutorial breve: comprimir ficheros desde la línea de órdenes

Tutorial rápido: comprimir ficheros desde la línea de órdenes

La sintaxis de línea de órdenes común para comprimir ficheros es:

WinRAR A [ -parámetros] <Archivo> [ Ficheros] [ @Listas de fichero]

Por ejemplo, si desea agregar el fichero CARTA.TXT al archivo CARTAS.RAR, escriba:

WinRAR A CARTAS.RAR CARTA.TXT

Si no se especifica la extensión de un archivo, WinRAR utilizará el formato de archivo predeterminado que esté seleccionado en el perfil de compresión predeterminado. No obstante, usted puede anularlo al concretar la extensión .RAR o la .ZIP.

El ejemplo siguiente: agregue al archivo sólido RAR Canciones todos los ficheros *.WAV:

WinRAR A -S Canciones.RAR *.WAV

También se pueden listar en un fichero aquellos ficheros que se van a comprimir, en lugar de enumerarlos en la línea de órdenes. En este caso, se debe escribir en la línea de órdenes el nombre del fichero de texto que contiene la lista de ficheros que se van a comprimir. Esto se indica mediante la colocación del símbolo @ antes del nombre de este fichero. Así pues, si usted crea un fichero Binaries, que contiene la cadena de caracteres *.exe y *.com, ejecute la orden:

WinRAR A TOOLS.ZIP @Binarios

se agregarán todos los ficheros de la carpeta actual con extensiones . EXE y . COM al archivo ZIP TOOLS .

Durante el proceso de compresión, aparecerá en pantalla una ventana con las estadísticas. Si desea interrumpir el proceso de compresión, haga clic en el botón Cancelar de la ventana de mandos. Puede pulsar el botón "Segundo plano" de esta ventana para minimizar WinRAR en la bandeja. Si se completa la compresión sin ningún problema, se finalizará WinRAR. En caso de que se produjese un error, aparecerá en pantalla una ventana de mensaje de diagnóstico.

Consulte Interfaz de línea de órdenes para una descripción más detallada de las órdenes y los parámetros.


Tutorial breve: comprimir ficheros en el Explorador o en el Escritorio

Tutorial rápido: comprimir ficheros en el Explorador o en el Escritorio

Si no desactivó la opción "Integrar WinRAR en el intérprete de órdenes" al instalar WinRAR, puede comprimir ficheros directamente en un intérprete de órdenes Windows. En el Explorador o en el Escritorio, seleccione los ficheros que va a comprimir, pulse el botón derecho del ratón sobre los ficheros seleccionados y escoja "Agregar al archivo…". Escriba el nombre del archivo de destino en el cuadro de diálogo que aparece en pantalla o acepte el nombre predeterminado. También puede seleccionar el formato del nuevo archivo ( RAR o ZIP), el nivel de compresión, el tamaño del volumen y otros parámetros de compresión. La descripción detallada de este cuadro de diálogo aparece en el tema cuadro de diálogo Nombre de archivo y parámetros. Haga clic en Aceptar cuando esté listo. Se creará un archivo en la misma carpeta que la de los ficheros seleccionados.

También puede seleccionar la orden "Agregar al <nombre de archivo> archivo" para agregarlo al archivo propuesto sin peticiones adicionales. En ese caso, se utilizará la configuración de compresión seleccionada en el perfil de compresión predeterminado.

Tenga en cuenta que si la opción "Menús contextuales en cascada" del cuadro de diálogo Configuración de la integración está activada, necesita abrir el submenú "WinRAR" para acceder a las órdenes antes descritas. En caso contrario, estarán situadas en el menú de nivel superior.

Otro método sería arrastrar los iconos del fichero hasta el icono de un archivo existente y colocarlos allí. Se agregarán a este archivo los ficheros.


RAR contra ZIP

WinRAR está capacitado para crear archivos en dos formatos diferentes: RAR y ZIP. A continuación, se describen las ventajas de cada formato:

Archivos ZIP

La principal ventaja del formato ZIP es su difusión. Por ejemplo, la mayoría de los archivos de Internet son archivos ZIP. Así pues, si va a enviar un archivo a alguien y no está seguro de si su destinatario tiene WinRAR para extraer el contenido del archivo, podría ser una buena idea utilizar el formato ZIP. Por otra parte, usted puede enviarle un archivo auto extraíble. Aunque este tipo de archivos son algo más grandes, se pueden extraer sin ningún tipo de programa externo.

Otra ventaja de ZIP es la velocidad. Por regla general, los archivos ZIP se crean más rápido que los RAR.

Archivos RAR

Normalmente el formato RAR mejor compresión que el ZIP, especialmente en el modo sólido. Los archivos WinRAR multivolumen en formato RAR permiten mas funcionalidades como por ejemplo volumenes auto extraíbles.

El formato RAR presenta algunas características interesantes que no existen en el ZIP como el registro de recuperación, que permite la recuperación física de los datos dañados, y el bloqueo de archivos importantes que evita su modificación por error.

Tanto el formato RAR como el ZIP permiten manejar ficheros de tamaño prácticamente ilimitado (hasta 8.589.934.591 GB).


Formato de archivo RAR 5.0

WinRAR 5.0 introduce una nueva version del formato de archivo RAR.

Las nuevas características del formato RAR 5.0 incluyen:

  • Tamaño del diccionario/a> de compresión de hasta 1 GB. Al comprimir ficheros grandes, especialmente en modo sólido, tamaños mayores de diccionario suelen permitir razones de compresión mayores.
  • Cifrado basado en el algoritmo AES-256, que es teóricamente mas seguro que el AES-128 del RAR 4.x.
  • Registro de recuperación con los códigos de corrección de errores Reed-Solomon con mucha mas resistencia a daños múltiples comparados con los registros de recuperación de RAR 4.x.
  • Operaciones con volumenes de recuperación mas rápidas. El número máximo de volumenes RAR+REV en RAR 5.0 es de 65535 en vez de 255.
  • La fecha de los ficheros se almacena como Tiempo Universal Coordinado (UTC) en vez de la fecha local en RAR 4.x, haciendo que el intercambio de ficheros entre zonas horarias diferentes sea mas sencillo.
  • Sumas de control BLAKE2sp para los datos de los ficheros. A revés que con la suma de control CRC32, es practicamente imposible con BLAKE2 encontrar dos ficheros diferentes con la misma suma de control. De esta forma puede usarse también para la identificación de ficheros.
  • Se puede añadir al archivo información de acceso rápido opcional para proporcionar un acceso más rápido al contenido del archivo.
  • Soporte para proceso paralelo en el algoritmo de descompresión. El beneficio en velocidad se nota mas en ficheros grandes con poca razón de compresión o con sumas de control BLAKE2.
  • Soporte para NTFS: puntos de reanálisis, enlces simbólicos, enlaces fuertes.
  • Posibilidad de almacenar la segunda copia y las posteriores de ficheros idénticos como referencias a la primera copia del conjunto.
  • Soporte completo Unicode. Los nombres de ficheros y comentarios se almacenan en formato UTF-8.

Algunas características RAR 4.x obsoletas o ineficientes no se han incluido en el formato RAR 5.0:

  • Algoritmos especiales incluyendo la compresión de texto, compresión de sonido e imagenes de color real sin comprimir o compresión de ejecutables para Itanium no pueden usarse en archivos RAR 5.0. Estos formatos de audio e imagenes de color real sin comprimir, que son reconocidos por versiones anteriores de RAR, han resultado ser significativamente poco frecuentes. La velocidad de compresión en los ordenadores modernos con varios nucleos es demasiado baja comparada con la del algoritmo general. Aunque estos algoritmos no están soportados en RAR 5.0, la última versión de WinRAR puede descomprimir archivos RAR 4.x, incluyendo aquellos que usan estos algoritmos. RAR 5.0 todavía incluye los algoritmos de compresión de ejecutables Intel IA-32 y de compresión delta, que son efecientes en equipos y datos modernos.
  • No esta soportado el esquema antiguo de nombres de volumenes archivo.r00, archivo.r01 ... El motivo principal de este esquema era la compatibilidad con el sistema de ficheros MS-DOS, pero este esquema no funciona bien en plataformas como Windows donde la extensión del fichero se usa para definir tipos de ficheros y asociaciones.

Aplicaciones antiguas, incluyendo versiones antiguas de WinRAR no son capaces de reconocer archivos RAR 5.0. Así que desea estar seguro que el archivo puede ser descomprimido por programas antiguos puede ser mejor usar el formato de archivo RAR 4.x. Puede hacerlo desde el cuadro de diálogo Nombre de archivo y parámetros o con el modificador -ma de la línea de ordenes. También puede preferir el formato RAR 4.x si necesita compresión de texto o multimedia o usar el esquema antiguo de nombres de volumenes.


Compatible con otros formatos de archivo

Para completar la compatibilidad con RAR y ZIP, WinRAR proporciona además operaciones básicas para los ficheros 7Z, ACE, ARJ, BZ2, CAB, GZ, ISO, JAR, LZH, TAR, UUE, XZ, Zcreadas con otras herramientas de compresión: visualización del contenido, extracción de ficheros, muestra de comentarios e información de archivo. No necesita poseer ningún programa externo para manejar estos formatos.


Archivos sólidos

Un archivo sólido es un archivo RAR comprimido con un método especial de compresión que trata algunos o todos los ficheros del archivo como si fuesen un flujo continuo de datos. Los archivos sólidos sólo son compatibles con el formato de compresión RAR. Los archivos ZIP nunca son sólidos. El método de compresión para archivos RAR es una opción que escoge el usuario y puede ser Sólido o No sólido. Use la opción Crear archivo sólido en el cuadro de diálogo de compresión o el modificador -s de la línea de órdenes para activar la compresión sólida.

La compresión sólida aumenta notablemente la compresión cuando se añade un número elevado de ficheros pequeños y similares. Pero también tiene algunas desventajas importantes:

  • Actualización más lenta de los archivos sólidos existentes;

  • Para extraer un solo fichero de un archivo sólido, todos los ficheros que le preceden deben ser analizados. Esto implica que la extracción desde la mitad de un archivo sólido es más lenta que la realizada desde un archivo normal. Sin embargo, la velocidad de extracción no se verá afectada si todos los ficheros que se van a extraer pertenecen a un archivo sólido.

  • Si algún fichero de un archivo sólido está dañado, no se podrá extraer ninguno de los que están a continuación de la zona dañada. Así pues, si se almacena un archivo sólido en soportes potencialmente no confiables, es recomendable utilizar el registro de recuperación.

La compresión sólida es preferible si:

  • No se actualiza a menudo el archivo;

  • Si no se necesita extraer con frecuencia un único fichero o parte de los ficheros del archivo;

  • La razón de compresión es más importante que la velocidad de compresión.

Normalmente los ficheros de un archivo sólido se ordenan por su extensión. Pero también es posible desactivar el ordenado con el modificador -DS o establecer un orden de ficheros alternativo utilizando el fichero especial rarfiles.lst .

Los volúmenes y los archivos auto extraíbles(SFX) también pueden ser sólidos.

Consulte también: parámetro -S, parámetro -DS, rarfiles.lst


Volúmenes (archivos divididos)

WinRAR puede crear archivos partidos en varios ficheros. Este tipo de archivos de llaman multivolumen y los ficheros individuales que los componene se llamn volumenes. Por regla general, los volúmenes se utilizan para almacenar un archivo grande en varios discos extraíbles o para enviarlos por email.

WinRAR puede crear volumenes RAR y ZIP. Otro nombre usado comunmente para los volumenes ZIP es ficheros ZIP partidos.

Por defecto, los volúmenes RAR tienen nombres del tipo 'nombrevolumen.partNNN.rar', donde NNN es el número de volumen. Para el formato de archivo RAR 4.x usando el modificador -vn es posible utilizar otro esquema basado en la extensión donde el primer volumen de la secuencia tiene extensión .rar y los siguientes volúmenes tienen extensiones numeradas desde .r00 hasta .r99. Los archivos RAR 5.0 no soportan -vn ni el equema basado en la extensión.

Los volúmenes también pueden ser sólidos y auto extraíbles. Un volumen auto extraíble presenta un identificador de extensión de fichero diferente (es decir, no es .rar), por ejemplo, .exe para los volúmenes auto extraíbles de Windows.

Para descomprimir los volúmenes RAR, debe empezar la extracción por el primero. Si todos los volúmenes están almacenados en un soporte no extraíble como, por ejemplo, un disco duro, deberá colocar todos los volúmenes en la misma carpeta antes de comenzar la extracción.

Los volumenes ZIP tienen nombres como 'volumen.zip', 'volumen.z01', 'volumen.z02'. Use el volumen con la extensión ".zip" en todas las operaciones para procesar el archivo, como iniciar la descompresión o abrir un archivo.

Al revés que los volumenes RAR, los volumenes ZIP no pueden ser auto extraíbles. WinRAR necesita tener acceso a todos los volumenes ZIP del conjunto al mismo tiempo al crearlos o descomprimirlos. Así es imposible crear o descomprimir volumenes ZIP desde discos extraíbles volumen por volumen. Si necesita hacerlo es necesario crearlos todos en la misma carpeta y luego copiarlos manualmente en los discos extraíbles. De la misma forma, es necesario copiar todos los volumenes en la misma carpeta antes de inciar la extracción.

No es posible añadir, actualizar o eliminar ficheros en volumenes existentes. Solo es posible crear un nuevo conjunto de volumenes.

Desde la versión 3.40, WinRAR almacena el número del volumen dentro del volumen. Puede ver este número en la parte superior de la ventana "Mostrar información" si aplica la órden Mostrar información al volumen. Este número puede ser útil si los nombres originales de los volúmenes se han modificado y necesita restaurar los nombres manualmente.


Volúmenes de recuperación

Los volúmenes de recuperación o fichero .rev son ficheros especiales que pueden ser creados por WinRAR y que permiten reconstruir volúmenes ausentes o dañados. Solo pueden usarse con archivos multivolumen.

Esta característica es útil cuando, por ejemplo, haya publicado un archivo multivolumen en un grupo de noticias y algunos de sus subscriptores no hayan recibido algunos volúmenes. Publicar volúmenes de recuperación en vez de volúmenes normales puede reducir el número total de ficheros a publicar.

Cada volumen de recuperación es capaz de reconstruir un volumen RAR dañado. Por ejemplo, si tiene 30 volúmenes y 3 volúmenes de recuperación es posible reconstruir cualquier conjunto de 3 volúmenes dañados. Si el número de ficheros .rev es menor que el número de volúmenes dañados la reconstrucción es imposible. El número total de volúmenes, tanto normales como de recuperación no debe exceder de 255 para RAR 4.x y 65535 para el formato de archivo RAR 5.0. El número de volúmenes de recuperación debe ser inferior al número total de volúmenes RAR.

Los volúmenes RAR originales no deben ser modificados después de crear los volúmenes de recuperación. El algoritmo de recuperación utilice los datos almacenados tanto en los archivos RAR como en los REV para reconstruir los volúmenes dañados. Si modifica los volúmenes RAR, por ejemplo, bloqueándolos, una vez creados los volúmenes REV, entonces el proceso de recuperación fallará.

Además de para recuperar datos, los volumenes de recuperación RAR 5.0 también almacenan información de servicio como las sumas de control de los ficheros RAR protegidos, de forma que son ligeramente más grandes que los volúmenes RAR que protegen. Si piensa copiar volumenes individuales RAR y REV al mismo medio extraíble necesita tener en cuenta y especificar el tamaño de los volumenes RAR unos cuantos kilobytes menor que el espacio total del medio extraíble.

WinRAR reconstruye cualquier volumen dañado o perdido al hacer clic sobre un fichero .rev, al usar la orden rc o automáticamente al descomprimir si no puede localizar el siguiente volumen pero si la cantidad necesaria de ficheros .rev.

Puede usar la opción "Volúmenes de recuperación” del dialogo Nombre de archivo y parámetros o la opción similar de la orden Proteger archivo para crear volúmenes de recuperación. En el modo de línea de órdenes puede hacerlo usando la opción -rv o la orden rv.

Las copias originales de los volúmenes dañados se renombran a *.bad antes de su reconstrucción. Por ejemplo, nombrevol.part03.rar se renombrará a nombrevol.part03.rar.bad.


Archivos auto extraíbles (SFX)

Un archivo auto extraíble o SFX (del inglés, Sel F-eXtracting) es un archivo fusionado con un módulo ejecutable que se usa para extraer ficheros del archivo al ejecutarlo. De este modo, no se necesita ningún programa externo para extraer el contenido del archivo auto extraíbles y basta con ejecutarlo. No obstante, WinRAR puede trabajar con los archivos auto extraíbles de igual modo que con cualquier otro archivo. Por ello, si no desea ejecutar un archivo auto extraíbles que ha recibido (por ejemplo, debido a la posible existencia de virus), puede utilizar WinRAR para ver o extraer su contenido.

Los archivos auto extraíbles normalmente tienen extensión .exe al igual que cualquier otro fichero ejecutable.

Los archivos auto extraíbles son prácticos si desea dar un archivo a alguien, pero no sabe si esa persona tiene un compresor adecuado con el que extraer el fichero. También puede emplear los archivos auto extraíbles para distribuir su propio software. Por ejemplo, el paquete WinRAR se basa en el módulo auto extraíble RAR gráfico Default.sfx.

Para crear un archivo auto extraíbles desde la línea de órdenes, puede utilizar el parámetro -sfx para crear un nuevo archivo o la orden S para transformar un archivo existente en auto extraíble. En el intérprete de órdenes WinRAR, seleccione la opción "Crear un archivo auto extraíble " en el cuadro de diálogo Nombre de archivo y parámetros si está creando un nuevo archivo o abra un archivo ya existente y haga clic en "Auto extraíble" .

El programa de distribución WinRAR incluye varios módulos auto extraíbles para diferentes plataformas. Todos los módulos auto extraíbles tienen extensión .sfx y deben estar en la misma carpeta que WinRAR. WinRAR siempre utiliza por defecto el módulo default.sfx, pero usted puede especificar directamente el nombre de otro módulo en el parámetro"-sfx" o en la orden "S". Por ejemplo, para transformar miarchivo.rar en auto extraíble utilizando el módulo WinCon.SFX ejecute:

WinRAR SWinCon.SFX miarchivo.rar

En el intérprete de órdenes WinRAR, puede seleccionar el módulo auto extraíble deseado en el menú que apareció al ejecutar la orden "Auto extraíble".

Estos temas incluyen más información sobre los módulos auto extraíbles proporcionados en el paquete WinRAR:

  • Módulos auto extraíbles gráficos RAR y ZIP (Default.SFX y Zip.SFX)
  • Módulo auto extraíble RAR para consola (WinCon.SFX)


Codificación

Tanto el formato RAR como el ZIP permiten la codificación. Para ficheros, debe especificar una contraseña antes de comprimir o hacerlo directamente en el cuadro de diálogo Nombre de archivo y parámetros. En la línea de órdenes, se utiliza para esto el parámetro -p[ctña]. Para introducir una contraseña en el intérprete de órdenes WinRAR, puede pulsar Ctrl+P, seleccionar la orden "Contraseña" del Menú Archivo o hacer clic sobre el icono de una llave pequeña situado en la esquina inferior izquierda de la ventana WinRAR. Para introducir la contraseña en el cuadro de diálogo Nombre de archivo y parámetros, haga clic en "Establecer la contraseña" del conjunto de opciones "Avanzado".

A diferencia del formato ZIP, el formato RAR permite además de codificar los datos, codificar otras áreas sensibles del archivo: nombres de ficheros, tamaños, atributos, comentarios y otros bloques. Si usted desear hacerlo debe activar la opción “Codificar nombres de fichero” cuando le pregunte la contraseña o, desde la línea de órdenes, usar la opción -hp[contraseña] en vez de p[contraseña]. Sin la contraseña será totalmente imposible ver ni siquiera la lista de ficheros en un archivo cifrado de este modo.

Los archivos RAR sólidos y los archivos con nombres de ficheros cifrados solo pueden tener una única contraseña para todos los ficheros comprimidos. Los ficheros en archivos RAR no sólidos o en archivos sin nombres de ficheros cifrados , así como en archivos ZIP, pueden tener diferentes contraseñas.

No olvide eliminar una contraseña introducida cuando no vuelva a necesitarla, ya que, en alguna ocasión, podría comprimir con ella algunos ficheros por error. Para eliminar una contraseña, introduzca una cadena de caracteres vacía en lugar de una contraseña o cierre WinRAR y vuelva a iniciarlo. Mientras exista una contraseña, el icono de la llave será rojo. En el caso contrario, se volverá amarillo. De igual modo, cuando usted inicia una operación de compresión con contraseña, la barra de título del cuadro de diálogo Nombre de archivo y parámetros parpadea dos veces.

Si activó la opción "Usar para todos los archivos" cuando introdujo la contraseña y entró una contraseña vacía, las operaciones de extracción y verificación omitirán todos los ficheros y archivos cifrados. En este modo no se muestra el icono de la llave en la barra de estado de WinRAR.

No necesitará eliminar una contraseña si la introdujo directamente en el cuadro de diálogo Nombre de archivo y parámetros. Este tipo de contraseña, al contrario que en otros casos, tan sólo es válida para esa operación de compresión y será eliminada automáticamente una vez se haya completado.

Cuando se extraen ficheros codificados, no es necesario introducir la contraseña antes de comenzar la operación aunque también puede hacerlo. Si no se introdujo la contraseña antes de la extracción y WinRAR encuentra un fichero codificado, pedirá la contraseña al usuario.

El formato ZIP 2.0 soportado por WinRAR usa algoritmos de codificación propietarios; sin embargo, los archivos RAR están codificados con el algoritmo estándar mas fuerte AES-128 para RAR 4.x y AES-256 en modo CBC para los archivos for RAR 5.0. La función de derivación de la clave en archivos RAR 5.0 esta basada en PBKDF2 usando HMAC-SHA256.

Si necesita codificar información importante, es mejor que elija el formato de archivo RAR. Para que la seguridad sea efectiva, utilice contraseñas de al menos 8 caracteres. Evite usar palabras comunes en la contraseña ya que la hacen mas debil. En las contraseñas se diferencia entre mayúsculas y minúsculas. La longitud máxima de la contraseña es de 127 carácteres. Las contraseñas más largas se cortarán a la longitud máxima permitida.

Si la opción "Cifrar nombres de fichero" está desactivada las sumas de control en ficheros cifrados RAR 5.0 se modifican usando un algortitmo que depende de la contraseña. Esto es importante porque de otra forma puede ser posible adivinar el contenido del fichero basandose solo en la suma de control sin conocer la contraseña. Este riesgo es especialmente alto para ficheros pequeños o para la suma de control mas fuerte BLAKE2. No espere que estas sumas de control cifradas se parezcan a los valores habituales del cRC32 y BLAKE2. Si la opción "Cifrar nombres de fichero" está activada las sumas de control se almacenan sin modificación porque solo puede accederse a su valor con la contraseña correcta.

Recuerde que si olvida su contraseña, le será imposible recuperar los ficheros codificados, ni siquiera el autor de WinRAR puede extraer ficheros codificados.


Comentario de archivo

Usted puede agregar información opcional en forma de texto a los archivos RAR y ZIP. Esta información recibe el nombre de comentario de archivo. Para agregar manualmente un comentario a un archivo ya existente en el modo intérprete de órdenes WinRAR, utilice la orden Agregar el comentario de archivo y para leerlo desde un fichero en la línea de órdenes use la orden "c" o el parámetro -z<fichero>.

Al comprimir los ficheros, también puede especificar un comentario directamente en el cuadro de diálogo Nombre de archivo y parámetros

Si se abre un archivo con comentario en WinRAR y la opción "Mostrar el comentario de archivo" del cuadro de diálogo Configuración general está activada, la ventana con el comentario aparecerá a la derecha de la lista de ficheros. Puede cambiar la anchura de esa ventana arrastrándola con el ratón por el borde izquierdo.


Protección de archivos contra daños

El formato de archivo RAR es compatible con un tipo especial de información redundante denominada registro de recuperación. Si un archivo contiene un registro de recuperación, se puede reparar incluso en caso de deterioro físico de los datos causado por un fallo de disco o en caso de cualquier otro tipo de pérdida de datos, siempre que el daño sufrido no sea muy severo. Estos daños pueden ser reparados con la orden Reparar archivo. El formato de archivo ZIP no permite el uso de registros de recuperación.

Active la opción "Añadir registro de recuperación" en el cuadro de diálogo Nombre de archivo y parámetros para agregar el registro de recuperación a un archivo. Otra posibilidad ese activar la opción "Incluir el registro de recuperación" en el perfil de compresión predeterminado. En este caso, se agregará a los archivos un registro de recuperación cada vez que éstos sean modificados.

Si necesita agregar el registro de recuperación desde la línea de órdenes, por favor, lea la ayuda de la orden "rr[N]" y el parámetro -rr[N] que pueden usarse para este propósito.

El registro de recuperación RAR 5.0 usa los códigos de corrección Reed-Solomon. Su capacidad de reparar daños continuos es la misma que la del RAR 4.x, permitiendo restaurar ligeramente menos datos que el tamaño del registro de recuperación. Pero es significativamente mas eficiente que el registro RAR 4.x cuando hay daños en múltiples áreas.

El registro de recuperación RAR 4.x contiene en sectores de 512 bytes y no puede contener mas de 524288. El tamaño util y su capacidad de recuperar daños esta limitada a 256 MB. En el caso del formato RAR 5.0 el registro de recuperación puede ser tan grande como el propio archivo.

Puede especificar el tamaño del registro de recuperación en las Opciones avanzadas del cuadro de diálogo "Nombre de archivo y parámetros" como un porcentage sobre el tamaño del archivo. También puede establecerse con la orden Proteger el archivo. Registros mayores permiten recuperar áreas dañadas mayores pero incrementan el tamaño del archivo y su proceso es mas lento. Normalmente el 3 - 10% del tamaño del archivo es una opción razonable. Debido a los datos adicionales requeridos el tamaño resultante solo se aproxima al porcentaje definido por el usuario, siendo la diferencia mayor en archivos pequeños.

Para reparar un archivo dañado que tenga registro de recuperación, en el modo intérprete de órdenes WinRAR, utilice la orden "Reparar". En la línea de órdenes, utilice la orden "r". El nombre del archivo reparado será fixed.nombrearchivo.rar. Si un archivo dañado no contiene un registro de recuperación o si no se repara totalmente debido a la gravedad de sus daños, se inicia una segunda fase. Durante esta fase, sólo se reconstruye la estructura del archivo y es imposible recuperar los ficheros que no superan la validación de la suma de control. Sin embargo, todavía se pueden recuperar los ficheros no dañados que permanecían inaccesibles a causa de la estructura dañada del archivo. Esto sólo es útil para los archivos que no son sólidos. Esta fase no se lleva a cabo para archivos con nombres de ficheros cifrados, que solo pueden ser reparados si disponen de registro de recuperación.

Una vez finalizada la segunda fase, el archivo reconstruido se guardará como rebuilt.nombrearchivo.rar donde nombrearchivo es el nombre original del archivo.

El registro de recuperación RAR 5.0 es mas resistente a daños en el propio registro de recuperación y puede usar un registro de recuperación parcialmente dañado. Tenga en cuenta que la órden "Reparar" no arregla bloques dañados en el registro de recuperación, solo los datos de los ficheros son corregidos. Después de un proceso de reparación exitoso puede que necesite crear de nuevo los registros de recuperación para los ficheros recuperados.

Tanto los registros 4.x como los 5.0 son mas eficientes si las posiciones de los daños en el archivo no estan desplazadas. Si copia el archivo desde un medio dañado usando algún tipo de programa especial y le da la posibilidad de escoger entre rellenar las áreas dañadas con ceros o no incluir estas áreas en el fichero, es preferible escoger la opción de rellenarlas con ceros o con cualquier otro valor porque esto permite preservar las posiciones originales de los datos. De todas formas, incluso no siendo el modo mas óptimo, ambas versiones de registros intentan reparar los datos incluso cuando se han producido eliminaciones o inserciones de tamaño razonable que han producido desplazamientos en las posiciones de los datos. El registro de recuperación RAR 5.0 maneja estos casos mas eficientemente que RAR 4.x.


Bloqueo de archivos

El formato de archivo RAR permite el bloqueo de archivos. WinRAR no puede modificar los archivos bloqueados. Puede bloquear los archivos importantes para impedir que sean modificados por accidente.

Utilice la orden "Bloquear archivo" en el modo intérprete de órdenes WinRAR o la orden "K" en la línea de órdenes para bloquear un archivo.


Cómo escoger la configuración óptima de compresión

Al crear un nuevo archivo se le ofrecen varias opciones de compresión en la página Opciones generales del cuadro de diálogo "Nombre de archivo y parámetros". Primero debe seleccionar el formato de archivo que puede ser RAR, ZIP o or RAR5. ZIP sólo es preferible cuando desconoce si la persona que va a recibir el archivo tiene WinRAR u otro programa capaz de descomprimir archivos RAR. Para el resto de los casos, es recomendable el uso de RAR, que permite un mayor número de funciones y una mayor compresión. "RAR5" es la última versión del formato RAR introducida en WinRAR 5.0. Aunque incluye cambios importantes como el cifrado AES-256, registros de recuperación mas eficientes, tamaños mayores de diccionario, programas antiguos inluyendo las versiones anteriores de WinRAR no son capaces de descomprimir archivos RAR 5.0. Así que necesita valorar los problemas de compatibilidad al seleccionar RAR5 si va a proporcionar estos archivos a terceros.

Independientemente del formato de archivo, el siguiente paso es la selección del método de compresión. Se permiten seis métodos de compresión: "Almacenamiento", "El más rápido", "Rápido", "Normal", "Bueno" y "El mejor". El método "El mejor" proporciona una mejor compresión, aunque más lenta; "El más rápido" comprime poco, pero es muy rápido; "Almacenamiento" unifica los ficheros en un archivo sin comprimirlos. "El más rápido" es recomnedable para copias de seguridad diarias, "El mejor" para distribuir contenido por Internet y "Normal" para uso diario como el envio de adjuntos por email.

Si usted seleccionó el formato de archivo ZIP, sus preparativos finalizan en esta fase. En el caso de RAR y RAR5 hay todavía dos opciones importantes que afectan la comrpesión: el tamaño del diccionario y la compresión sólida.

El diccionario de compresión es el área de memoria que usa el algoritmo de compresión para encontrar y comprimir patrones de datos que se repiten. Diccionarios mayores suelen mejorar la compresión de ficheros grandes, especialmente en modo sólido, pero también resultan en compresiones mas lentas y con mayor necesidad de memoria. Normalmente se recomienda usar un diccionario de 4 MB para el formato RAR y 32 MB para el formato RAR5 (RAR 5.0). Puede leer mas sobre el tamaño del diccionario aquí.

La opción "Crear archivo sólido" comprime los ficheros como un solo flujo de datos continuo resultando en una razón de compresión mayor al procesar muchos ficheros pequeños similares. Pero también reduce la velocidad de las modificaciones posteriores del archivo e incrementa el tamaño de las perdidas de datos en caso de daños en el archivo. Este modo está explicado con mayor detalles en el tema Archivos solidos.

Estas son todas las características principales de la configuración que afectan a la razón y a la velocidad de compresión. En realidad, no necesita fijarlas antes de cada compresión. Simplemente seleccione una vez los valores predeterminados que usted prefiera en el perfil de compresión predeterminado, que se puede crear desde el cuadro de diálogo Configuración de la compresión.


Introducción a la interfaz WinRAR

Este tema describe brevemente los principales elementos de la interfaz WinRAR.

WinRAR incluye los siguientes menús: Archivo, Órdenes, Herramientas , Favoritos, Opciones y Ayuda. Seleccione el tema apropiado para informarse sobre las órdenes de un menú concreto.

El siguiente elemento de la interfaz es la barra de herramientas. Está situada debajo de los menús y sobre la lista de ficheros. Los botones de la barra de herramientas repiten los elementos del menú Órdenes (observe que todos los elementos de este menú también tienen teclas de método abreviado). Algunos botones sólo están disponibles cuando se ve el contenido de una carpeta; otros, sólo al ver un archivo y otros, en los dos casos. Cuando WinRAR muestra en pantalla el contenido de un archivo, algunos botones pueden no aparecer si las funciones correspondientes de manejo del archivo no se pueden aplicar al archivo. Si lo desea, puede escoger los botones que aparecerán en pantalla, eliminar los que tengan texto o reducir su tamaño utilizando el cuadro de diálogo Configuración general o haciendo clic con el botón derecho del ratón sobre la barra de herramientas.

Debajo de los botones de la barra de herramientas, verá el pequeño botón de "Subir un nivel" y la lista de discos. El botón "Subir un nivel" cambia la carpeta actual por la anterior. La lista de discos se necesita para seleccionar la unidad en uso o, por ejemplo, una unidad de red. Puede desplegarla utilizando el ratón o pulsando la tecla F4. Se puede arrastrar el botón "Subir un nivel" y la lista de discos hacia la esquina derecha de la barra de herramientas. Pulsando Ctrl+D o haciendo clic sobre el icono "Disco" situado en la barra de estado también se puede cambiar la unidad en uso.

La lista de ficheros se encuentra debajo de la barra de herramientas. Puede mostrar tanto el contenido descomprimido de la carpeta actual como, si se introduce WinRAR en un archivo, los ficheros comprimidos. Esto recibe el nombre de modos de gestión de fichero y de gestión de archivo. Los siguientes parámetros aparecen en cada fichero: nombre, tamaño, tipo y hora de modificación. Los ficheros comprimidos tienen dos parámetros adicionales: tamaño comprimido y suma de control. La suma de control es una suma especial basada en los datos del fichero que puede permite detectar si un fichero comprimido esta dañado. WinRAR puede usar tanto el algoritmo CRC32 como el BLAKE2 para calcular la suma de contol

Todos los parámetros se organizan en columnas. Haciendo clic en el título de la columna puede cambiar el orden de clasificación de los ficheros (la flecha azul dibujada en el título indica la dirección de la clasificación). También es posible modificar la anchura de las columnas arrastrando los separadores del título de columna con un ratón. Se puede acceder a varias opciones adicionales de lista en el cuadro de diálogo Lista de fichero.

Si un fichero comprimido está codificado, su nombre aparece seguido de un asterisco. Si un fichero continua en el siguiente volumen, su nombre irá seguido de "-->". Si un fichero es la continuación de un volumen anterior, después de su nombre aparecerá "<--". Y si un fichero es la continuación de otro volumen y va seguido al mismo tiempo de otro volumen, después de su nombre aparecerá "<->".

Antes de procesar los ficheros, necesita seleccionarlos en la lista. Además de los métodos estándar de Windows para seleccionar ficheros, WinRAR proporciona varias teclas más con ese mismo propósito: Barra espaciadora, Ins (Insert), "NUM +", "NUM -". Para más detalles, consulte el tema Selección de ficheros.

Las teclas siguientes se pueden utilizar para navegar por la lista de fichero. La tecla de retroceso, Ctrl+RePág o doble clic sobre la carpeta con nombre ".." para ir a la unidad anterior o a la carpeta de archivo. La misma acción cerrará un archivo si está viendo la carpeta raíz del archivo. Pulse Intro, Ctrl+AvPág o haga doble clic sobre cualquier carpeta para entrar en ella. La misma acción realizada sobre el nombre de un archivo, abrirá el archivo. Ctrl+\ establece como carpeta actual la carpeta raíz del disco o la carpeta del archivo.

Si pulsa el botón derecho del ratón en la lista de ficheros, se verá en pantalla el menú con las órdenes de gestión de ficheros y de interfaz. También se puede acceder a estas órdenes a través de los menús habituales, la barra de herramientas o el teclado; de este modo, usted puede escoger el método de activación que más le convenga.

La parte izquierda de la ventana del WinRAR puede mostrar el panel de navegación con el árbol de carpetas si ha activado la opción “Panel de navegación” del submenú Opciones. El panel de navegación es útil si necesita explorar rápidamente el disco o el contenido del archivo. Puede cambiar el ancho del panel arrastrando su borde derecho con el ratón.

Dependiendo de la opción "Mostrar el comentario de archivo" del cuadro de diálogo Configuración general y de la existencia de un comentario en el archivo abierto, la parte derecha de la lista de fichero puede estar cubierta por la ventana del comentario de archivo. Puede cambiar la anchura de la ventana del comentario arrastrando su borde izquierdo con el ratón.

La barra de estado está situada debajo de la lista de ficheros, en la parte inferior de la ventana WinRAR. La parte izquierda de la barra de estado presenta dos iconos pequeños: "Disco" y "Llave". Haciendo clic sobre el icono de "Disco" puede cambiar la unidad actual. Para cambiar la contraseña actual, haga clic sobre el icono de la "Llave". Estas dos órdenes también las encontrará en el Menú Archivo. El icono de la "Llave" es amarillo por defecto, pero se convierte en rojo al introducir una contraseña. La parte central de la barra de estado muestra el tamaño total de los ficheros seleccionados o información sobre la operación que se está realizando. La parte derecha de la barra de estado muestra el número y el tamaño de los ficheros situados en la carpeta actual.


Modos de gestión de fichero y de gestión de archivo

El intérprete de órdenes WinRAR puede estar en uno o dos estados básicos: modo de gestión de fichero o modo de gestión de archivo.

En el modo de gestión de fichero, aparece una lista de los ficheros y las carpetas situadas en la carpeta en la que se está trabajando. Usted puede seleccionar estos ficheros y estas carpetas siguiendo el estilo habitual de Windows, con un ratón o con el teclado, y realizar diferentes operaciones de fichero como comprimir o eliminar. En este modo, también se pueden realizar operaciones de comprobación o extracción con grupos de archivos.

En el modo de gestión de archivo, se muestra la lista de los ficheros comprimidos y las carpetas del archivo que está abierto. También puede seleccionar ficheros y carpetas, y realizar operaciones específicas de archivo como extraer, comprobar o comentar.

En cualquiera de los dos modos, puede modificar la carpeta actual (real o comprimida). Pulse la tecla de retroceso, Ctrl+Re Pág o haga doble clic sobre la carpeta con nombre ".." para ir a la unidad anterior o a la carpeta de archivo. La misma acción cerrará un archivo y hará que WinRAR vuelva al modo de gestión de fichero si está viendo la carpeta raíz del archivo. Pulse Intro, Ctrl+Av Pág o haga doble clic sobre cualquier otra carpeta para entrar en ella. La misma acción realizada con el nombre de un archivo, abrirá el archivo. Ctrl+\ establece como carpeta actual la carpeta raíz del disco o del archivo.

Para introducir el modo de gestión de fichero WinRAR, inicie WinRAR haciendo simplemente doble clic sobre el icono WinRAR o ejecute el programa desde la línea de órdenes sin ningún parámetro.

Para introducir el modo de gestión de archivo WinRAR, inicie WinRAR en el modo de gestión de fichero, coloque el cursor sobre el archivo deseado y pulse Intro o utilice la orden "Abrir archivo" del Menú Archivo. O simplemente haga doble clic sobre el nombre del archivo en el intérprete de órdenes Windows (Explorador o Escritorio) para abrirlo en WinRAR. No obstante, para que esto ocurra, tiene que haber asociado WinRAR con archivos al instalarlo (es la opción predeterminada de instalación). También puede asociar WinRAR con archivos tras su instalación utilizando el cuadro de diálogo Configuración de la integración. Por último, también es posible entrar directamente en el archivo deseado desde la línea de órdenes si se pasa el nombre del archivo a WinRAR como un parámetro único en la línea de órdenes.


Selección de ficheros

Antes de realizar ninguna operación, necesita seleccionar, dentro de la lista de ficheros WinRAR, todos aquellos ficheros y carpetas que deben ser procesados.

Si sólo necesita seleccionar un fichero, simplemente mueva el cursor hasta él e inicie una operación. Hay varios métodos para seleccionar ficheros. Al igual que en otras aplicaciones de Windows, puede pulsar las teclas de dirección o el botón izquierdo del ratón al tiempo que mantiene presionada la tecla Mayús para seleccionar un grupo de ficheros. Para seleccionar varios objetos separados, mantenga presionada la tecla Ctrl y haga clic sobre cada uno de los objetos que quiera. Pulse Ctrl+A o utilice la orden "Seleccionar todo" del Menú Archivo para seleccionar todos los ficheros y las carpetas de la carpeta actual.

Todos los métodos estándar descritos anteriormente no proporcionan una selección continua y ésta se cancela si usted mueve el cursor. Aunque a menudo los métodos estándar son suficientes, a veces es más conveniente tener una selección continua que permita navegar dentro de la carpeta actual sin que se elimine la selección de los archivos marcados anteriormente. WinRAR proporciona varias teclas para esto:

Barra espaciadora, Ins (Insertar) | Seleccione un fichero situado debajo del cursor y mueva el cursor hacia abajo. Para eliminar la selección de un fichero utilizando la barra espaciadora o la tecla Ins, pulse otra vez dicha barra o tecla sobre el nombre o utilice la orden "NUM -".
NUM * (en el teclado numérico) | Invierte la selección actual.
NUM + (en el teclado numérico) | Selecciona ficheros según la máscara comodín introducida.
NUM - (en el teclado numérico) | Elimina la selección de los ficheros según la máscara comodín introducida.

Si no se ha seleccionado ningún fichero antes de comenzar la extracción o la comprobación, se extraerán o se comprobarán todos los ficheros. Esta regla sólo sirve para operaciones de extracción o de comprobación.


Temas

Los temas permiten modificar el aspecto de WinRAR reemplazando los gráficos por otros alternativas. Los temas se distribuyen a través de archivos RAR cuyo nombre tiene la extensión ".theme.rar". Puede descargarlos desde la sección "Temas" de la página web principal de WinRAR. Para instalar un nuevo tema solo tiene que abrir el fichero con WinRAR como lo haría con otro fichero RAR, por ejemplo, haciendo doble click en su icono. Luego solo tiene que confirmar la instalación en el cuadro de dialogo que le mostrará WinRAR.

La lista de los temas instalados está disponible en el submenú “Temas” del menú Opciones, solo tiene que seleccionar el tema deseado para activarlo. El menú también contiene las órdenes "Organizar temas…" que proporciona funciones para el manejo de temas y "Obtener más temas …" que le remite a la página de descarga de temas.

Los ficheros de temas se almacenan en la subcarpeta "Themes" dentro de la carpeta %APPDATA%\WinRAR


El asistente

El asistente de WinRAR está diseñado para usuarios no experimentados y permite realizar operaciones básicas de compresión y descompresión usando un procedimiento sencillo paso a paso.

Para iniciar el asistente solo tiene que pulsar el botón Asistente de la barra de botones. Por defecto este botón esta siempre visible pero puede desactivarlo al igual que los demás botones de la barra con la opción "Seleccionar botones…" del cuadro de diálogo Configuración . Otra opción del mismo cuadro de diálogo, “Activar el asistente al empezar” permite iniciar el asistente cada vez que inicie WinRAR.

Cada diálogo del asistente contiene unas instrucciones breves en la parte superior describiendo el contenido del diálogo y las posibles acciones. Pude pulsar el botón Ayuda para obtener instrucciones adicional.


Asistente: escoger operación

Aquí puede escoger la tarea a realizar.

Si desea descomprimir el contenido de archivos RAR, ZIP o alguno de los demás formatos soportados por WinRAR escoja la opción "Descomprimir un archivo". Por ejemplo, use esta opción para descomprimir un archivo que se haya descargado de Internet.

Si desea crear un nuevo archivo y comprimir en él algunos ficheros escoja la opción "Crear un archivo nuevo". Es de gran utilidad comprimir los ficheros antes de enviarlos por correo electrónico o copiarlos en un disco externo ya que así disminuimos su tamaño.

Si desea añadir ficheros a un archivo existente en vez de crear uno de Nuevo escoja la opción "Añadir ficheros a archivo existente".

Después de seleccionar la tarea deseada pulse el botón “Siguiente" situado en la parte inferior. Si ha seleccionado la opción "Crear un archivo nuevo" o "Añadir ficheros a archivo existente" , se le abrirá el cuadro de diálogo "Seleccionar ficheros a añadir", donde deberá seleccionar los ficheros que desee comprimir. Si seleccionó la opción "Descomprimir un archivo" se abrirá el cuadro de dialogo "Seleccionar archivo".


Asistente: Escoger el archivo

Aquí debe escoger el archivo a descomprimir.

Pulse el botón "Examinar", localice el archivo, seleccione su nombre y pulse el botón "Abrir". También puede arrastrar y soltar el archivo en este cuadro de diálogo.

Después de seleccionar el nombre de archivo pulse el botón "Siguiente".

Tenga en cuenta que WinRAR puede intentar averiguar el nombre de archivo y establecerlo al nombre de algún archivo que tenga en el Escritorio al activar este diálogo. Si realmente es el archivo que desea solo deberá pulsar "Siguiente", en caso contrario simplemente siga los pasos que le hemos indicado anteriormente.


Asistente: Escoger el archivo

Aquí debe escoger el archivo a comprimir o actualizar.

Si va a crear un archivo nuevo, WinRAR le sugerirá un nombre. Puede aceptarlo o bien cambiarlo por otro diferente. Tenga en cuenta que si el nombre no incluye una ruta el archivo será creado en el Escritorio. Si desea crearlo en otra carpeta pulse el botón "Examinar", escoja la carpeta donde crear el archivo, entre el nombre del archivo en la casilla "Nombre del fichero" y pulse "Abrir".

Si desea añadir ficheros a un archivo existente puede usar también el botón "Examinar" para localizar el archivo a actualizar o arrastrar y soltar el archivo en este diálogo.

Después de seleccionar el nombre de archivo pulse el botón "Siguiente".


Asistente: Escoja la carpeta para los ficheros descomprimidos

Aquí debe escoger la carpeta donde descomprimir el archivo.

Por defecto WinRAR le sugerirá descomprimir el archivo en el Escritorio. Puede aceptar la carpeta propuesta o bien escoger otra pulsando el botón "Examinar".

Después de seleccionar la carpeta de destino pulse el botón "Finalizar" para iniciar la extracción.


Wizard: Archiving options

Asistente: Opciones de compresión

Aquí puede escoger varias opciones adicionales de compresión.

Si la velocidad de compresión es mas importante para usted que la compresión seleccione la opción "Rápida, pero con menor compresión".

Si desea eliminar los ficheros después de comprimirlos active la opción " Eliminar ficheros después de comprimir ".

Si desea crear un archivo auto extraíble , active la opción " Crear archivo auto-extraíble (.exe)". Este tipo de archivos no necesitan que WinRAR este instalado para descomprimirlos, es suficiente ejecutarlos (haciendo doble clic en su icono) para descomprimir su contenido.

Puede pulsar el botón "Establecer contraseña…" y especificar una contraseña si desea cifrar los ficheros comprimidos. No olvide su contraseña, es totalmente imposible descomprimir los ficheros comprimidos sin ella.

Al crear un Nuevo archivo también puede partirlo en varios trozos (llamados volúmenes). A veces es más conveniente tener varios archivos pequeños que uno de grande. Si desea realizar esta operación solo tiene que especificar el tamaño de cada trozo en la casilla de la parte inferior de la ventana. Puede especificar el tamaño en bytes, kilobytes, megabytes o gigabytes. Simplemente seleccione las unidades de la lista desplegable a la derecha de la casilla del tamaño. También se permiten fracciones decimales.

Si esta actualizando un archivo las opciones para crear una archivo auto extraíble o para partir el archivo en volúmenes estarán desactivadas. Estas solo se activan al crear un archivo nuevo.

Todas las opciones de este diálogo son opcionales y normalmente usará los valores por defecto.

Cuando este listo pulse el botón "Finalizar" para iniciar la compresión.


Visualización de ficheros

Cuando usted ejecuta una orden "Ver el fichero", WinRAR muestra el contenido del fichero situado debajo del cursor en la ventana del visor interno independientemente del contenido del fichero o de la configuración. Sin embargo, si usted iba a pulsar Intro sobre un nombre de fichero, se pueden producir varios resultados diferentes. Si el fichero situado debajo del cursor es un archivo, WinRAR lo abrirá y mostrará su contenido, si no la ejecución de otras acciones depende de la configuración especificada en el cuadro de diálogo Configuración del visor. Con este cuadro de diálogo, puede obligar a WinRAR a utilizar siempre el visor interno, a abrir el fichero en el visor externo, a llamar a un programa asociado por Windows con este tipo de ficheros o a preguntar cada vez, antes de visualizar el fichero, qué acción descrita debajo deberá ser ejecutada.

Se puede utilizar WinRAR para ver ficheros normales, tanto si están en un archivo como si no. Si se utiliza un programa externo para ver un fichero comprimido, WinRAR lo descomprime en una carpeta temporal, pasa su nombre al programa externo y espera a que el programa termine. Tras esto, WinRAR comprueba la hora de modificación del fichero y si fue actualizado, se ofrece a actualizar el fichero en el archivo y, después, elimina la carpeta temporal con el fichero extraído.

Tenga en cuenta que el esquema descrito anteriormente se ve ligeramente modificado cuando se pulsa Intro sobre un fichero comprimido y con extensión .exe. En este caso, WinRAR no sólo extrae en la carpeta temporal este fichero sino también todo el contenido del archivo y luego ejecuta el fichero ejecutable. Los pasos siguientes son similares a los ya descritos arriba: WinRAR espera a que el ejecutable termine, luego comprueba la hora de modificación del fichero extraído y, en el caso de que haya cambiado o de que se hayan creado nuevos ficheros, se ofrece a actualizar el archivo. Entonces, se borra la carpeta temporal junto con su contenido. Este método de procesar ficheros .exe permite ejecutar los programas directamente desde el archivo. Por ejemplo, puede utilizarlo para instalar programas nuevos sin descomprimir manualmente un programa de distribución. Simplemente entre en un archivo y pulse Intro sobre el programa setup.exe o install.exe.


Visor interno

Órdenes del visor interno.

Menú/ Elemento | Método abreviado | Función
Fichero/ Salir | Alt+F4, Ctrl+W | Salir del visor interno
Editar/ Copiar | Ctrl+C | Copiar en el portapapeles el texto seleccionado.
Editar/ Seleccionar todo | Ctrl+A | Seleccionar todo el texto visualizado
Editar/ Buscar | Ctrl+F | Buscar una cadena de caracteres en el texto
Editar/ Buscar siguiente | F3 | Buscar la siguiente aparición de una cadena de caracteres
Ver/ Ver como texto de Windows | Ctrl+I | Utilizar la tabla de caracteres de Windows
Ver/ Ver como texto de DOS | Ctrl+D | Utilizar la tabla de caracteres de DOS
Ver/Ver como Unicode (UTF-16LE) |  | Ver texto como Unicode en formato UTF-16 little endian
Ver/Ver como Unicode (UTF-8) |  | Ver texto como Unicode en formato UTF-8
ver/ Ajuste automático de linea | Ctrl+S | Cambiar el tipo de ajuste automático de linea
Ver/ Establecer el tipo de letra… | ninguno | Establecer el tipo de letra del visor
Ayuda/ Ver ayuda | F1 | Mostrar el visor interno de ayuda

Para cambiar esta tabla de caracteres, puede hacer clic en la parte derecha de la barra de estado del visor, donde se muestra el nombre de la tabla actual. Se puede especificar la tabla de caracteres predeterminada en el cuadro de diálogo Configuración del visor.


Orden "Agregar al archivo"

Se puede acceder a esta orden tanto desde el modo de gestión de ficheros como desde el de gestión de archivos.

Cuando WinRAR examina ficheros en un disco, usted necesita seleccionar en primer lugar los ficheros y las carpetas que va a comprimir. Luego, ejecute la orden "Agregar al archivo" del Menú Órdenes, pulse el botón "Agregar" de la barra de herramientas o el método abreviado Alt+A. Seleccione el nombre de archivo y los parámetros en el cuadro de diálogo Nombre de archivo y parámetros y pulse Intro para iniciar la compresión.

Cuando WinRAR muestra el contenido del archivo, debe ejecutar primero la orden "Agregar al archivo", luego seleccionar ficheros en el cuadro de dialogo que aparece y fijar el nombre de archivo y los parámetros como se describió anteriormente.

Equivalente a la línea de órdenes: orden "a"


Orden "Extraer ficheros en la carpeta especificada"

Se puede acceder a esta orden tanto desde el modo de gestión de ficheros como desde el de gestión de archivos.

En el modo de gestión de archivo, cuando WinRAR muestra el contenido del archivo, debe seleccionar en primer lugar los ficheros y las carpetas comprimidas que va a extraer. A continuación, ejecute la orden "Extraer ficheros en la carpeta especificada" del Menú Órdenes, pulse el botón "Extraer en" de la barra de herramientas o el método abreviado Alt+E. En el cuadro de diálogo Ruta de extracción y opciones , puede especificar la carpeta de destino para los ficheros extraídos y, en caso de que sea necesario, establecer opciones adicionales. Una vez cerrado este cuadro de diálogo, comienza la extracción.

En el modo de gestión de ficheros, se pueden descomprimir varios archivos al mismo tiempo. En general, la operación es similar a la descrita en el párrafo anterior. Sin embargo, en lugar de seleccionar los ficheros dentro del archivo, debe seleccionar los archivos y carpetas en las que WinRAR debe buscar los archivos. Si se encuentra alguno de los archivos, aparecerá en pantalla el cuadro de diálogo Ruta de extracción y opciones. Una vez cerrado este cuadro de diálogo, se extraerá el contenido de todos los archivos encontrados.

Equivalente a la línea de órdenes: orden "x"


Orden "Comprobar los ficheros comprimidos"

Se puede acceder a esta orden tanto desde el modo de gestión de ficheros como desde el de gestión de archivos.

En el modo de gestión de archivos, cuando WinRAR muestra el contenido del archivo, usted debe seleccionar en primer lugar los ficheros y las carpetas comprimidas que va a comprobar. Después ejecute la orden "Comprobar los ficheros comprimidos" del Menú Órdenes, pulse el botón "Examinar" de la barra de herramientas o el método abreviado Alt+T.

Todos los errores encontrados durante la comprobación aparecerán en pantalla en la ventana de "Mensajes de diagnóstico". Si no se detecta ningún error, WinRAR mostrará en pantalla el mensaje correspondiente.

En el modo de gestión de ficheros, se pueden comprobar varios archivos al mismo tiempo. En general, la operación es similar a la descrita en el párrafo anterior, pero, en lugar de seleccionar los ficheros dentro del archivo, debe seleccionar los archivos y carpetas en las que WinRAR debe buscar los archivos. Una vez completada la búsqueda, WinRAR examinará el contenido de todos los archivos encontrados.

Equivalente a la línea de órdenes: orden "t"


Orden "Ver el fichero"

Se puede acceder a esta orden tanto desde el modo de gestión de ficheros como desde el de gestión de archivos. Abre el fichero situado debajo del cursor en el visor interno. Para ejecutar esta orden, utilice el Menú Órdenes, el botón "Ver" de la barra de herramientas o el método abreviado Alt+V.

Consulte también: Visor interno, Visualización de ficheros


Orden "Eliminar ficheros"

Se puede acceder a esta orden tanto desde el modo de gestión de ficheros como desde el de gestión de archivos. En el modo de gestión de ficheros, envía los ficheros y las carpetas seleccionadas a la papelera de reciclaje. De este modo, le ofrece la oportunidad de recuperar datos eliminados accidentalmente. Sin embargo, en el modo de gestión de archivos, los ficheros y las carpetas seleccionadas son eliminadas por completo del archivo sin ninguna posibilidad de recuperarlas más tarde; por lo tanto, debe tener mucho cuidado en este caso. Para ejecutar esta orden, utilice el Menú Órdenes, el botón "Eliminar" de la barra de herramientas o los métodos abreviados Alt+L o Supr.

En el modo de gestión de ficheros, también puede eliminar por completo los ficheros. Pulsar Mayús-Supr en lugar de Supr impide mover los ficheros a la papelera de reciclaje.

Equivalente a la línea de órdenes: orden "d"


Orden "Renombrar fichero"

Esta orden permite renombrar el fichero o carpeta seleccionada y es accesible desde el modo de manejo de ficheros y el de manejo de archivos. Renombrar ficheros dentro de archivos comprimidos esta soportado en los formatos RAR y ZIP. Para ejecutar esta orden puede usar tanto el menú de órdenes como la tecla de acceso directo F2.

La orden Renombrar tiene algunas restricciones cuando trabaja con archivos multivolumen Solo se pueden renombrar los ficheros contenidos en el volumen actual. Si quiere renombrar ficheros dentro de los volúmenes necesita desactivar la opción "Fusionar el contenido de los volúmenes " en la sección Lista de ficheros del cuadro de diálogo de Configuración y abrir el volumen que contenga los ficheros requeridos.

Tenga cuidado al escoger el nuevo nombre. Si incluye caracteres que no estén soportados por el sistema de ficheros puede tener problemas al extraer los ficheros renombrados. Si es este el caso solo tiene que renombrarlo de nuevo usando un nombre más coherente.

Equivalente de la línea de órdenes: orden "rn"


Orden "Prueba de velocidad"

Orden "Pruebas de velocidad"

Con esta orden puede comparar la velocidad del algoritmo de compresión del RAR en diferentes ordenadores.

Esta orden genera datos aleatorios que contienen redundancia especialmente generada para aumentar el uso del procesador y de la memoria. Después estos datos se comprimen y descomprimen y se comparan con los datos originales. Si se encuentra alguna diferencia WinRAR mostrará "Errores encotrados - Sí" en la ventana de resultados. Estos errores indican posibles problemas físicos en el ordenador como fallos en la memória. WinRAR también le mostrará el tamaño de los datos procesados y la velocidad de compresión en kilobytes por segundo. Puede usar el valor de la velocidad para comparar la velocidad de compresión de WinRAR en diferentes condiciones. Por ejemplo, puede serle de utilidad cuando desee adquirir un nuevo ordenador y desee conocer cual de ellos comprime más rápido. Solo se usa el algoritmo de compresión en modo “Mejor” con un diccionario de 4096K, todos los demás filtros y algoritmos se desactivan, de forma que se mide la velocidad del algoritmo RAR base con los peores datos posibles.

Usando la opción "Proceso paralelo" puede comparar la diferencia de velocidad entre las versión normal y la de proceso paralelo (optimizada para arquitecturas multiprocesador) del algoritmo de compresión RAR. Dependiendo de los resultados puede activar o desactivar el proceso paralelo en el cuadro de dialogo Opciones generales.

AL principio WinRAR debe llenar el diccionario de compresión que inicialmente está vació, tarea que lleva cierto tiempo. Hasta que esto no sucede la velocidad es inconsistente de forma que la ventana de resultados sólo empieza a mostrar la velocidad de compresión unos segundos después de iniciada la operación. La velocidad calculada se muestra cuando ya se han procesado al menos 10MB de datos, momento en el cual su calculo es ya suficientemente preciso y los cambios de velocidad cercanos a cero. Una vez calculada la velocidad esta ya no se vuelve a modificar. Aunque los datos son aleatorios, su redundancia y demás parámetros son constantes, de forma que esta orden informará prácticamente siempre la misma velocidad, independientemente del tiempo de operación siempre que la carga del sistema no varíe.

No hay ninguna garantía que diferentes versiones de WinRAR calculen velocidades de compresión idénticas, así que si usa esta orden para comparar la velocidad de compresión en diferentes ordenadores asegúrese de usar la misma versión de WinRAR en todas las pruebas. También se recomienda cerrar todas las demás aplicaciones antes de empezar la prueba de velocidad.

Esta operación no finaliza nunca automáticamente, es necesario cancelarla manualmente. Tampoco utiliza el disco duro, todas las operaciones se realizan en memória.


Orden "Extraer sin pedir confirmación"

Se puede acceder a esta orden cuando WinRAR está en los modo de gestión de ficheros y gestión de archivos. Si esta examinando el contenido de un archivo comprimido debe seleccionar los ficheros y las carpetas comprimidas que va a extraer. Si esta examinando ficheros sin comprimir en el modo de gestión de ficheros seleccione los ficheros y carpetas en los que desea buscar archivos a descomprimir. Luego ejecute la orden "Extraer sin pedir confirmación" del Menú Órdenes, pulse el botón "Extraer" de la barra de herramientas o el método abreviado Alt+W. Los ficheros seleccionados se extraerán en la carpeta actual o en la carpeta predeterminada para la extracción de ficheros si se especifica en el cuadro de diálogo Configuración de la compresión. Si necesita determinar una carpeta de destino distinta o activar alguna opción adicional, utilice la orden Extraer en la carpeta especificada.

Equivalente a la línea de órdenes: orden "x"


Orden "Agregar el comentario de archivo"

Sólo se puede acceder a esta orden cuando WinRAR está en el modo de gestión de archivos. No necesita seleccionar ningún fichero para realizarla. Simplemente ejecute la orden "Agregar el comentario de archivo" del Menú Órdenes, pulse el botón "Comentario" de la barra de herramientas o el método abreviado Alt+M y escriba el comentario de archivo en el cuadro de diálogo que aparece en pantalla.

Equivalentes a la línea de órdenes: orden "c" , parámetro -z<fichero>


Orden "Proteger el archivo de daños"

Orden "Proteger el archivo contra daños"

Se puede acceder a esta orden cuando WinRAR está en los modos de gestión de ficheros y gestión de archivos. Si esta dentro de un archivo no necesita seleccionar ningún fichero, simplemente ejecute la orden "Proteger el archivo contra daños" del menú Órdenes, pulse el botón "Proteger" de la barra de herramientas o el método abreviado Alt+P. Si esta examinando ficheros no comprimidos en el modo de gestión de ficheros, primero seleccione los ficheros y carpetas en los que desea buscar archivos a proteger.

Esta orden agrega un registro de recuperación al archivo que está abierto en ese momento o a los archivos seleccionados. Puede ayudar a repararlo más tarde en caso de que se produzca algún pequeño deterioro físico de los datos del archivo.

Si el archivo abierto es el primero de una secuencia multivolumen , también puede crear volúmenes de recuperación. Para ello solo tiene que especificar el número de ficheros .rev a crear. También puede añadir un signo de porcentaje a este parámetro para que el número de ficheros .rev a crear sea igual a dicho porcentaje aplicado al número total de archivos RAR en la secuencia multivolumen..

Equivalente a la línea de órdenes: orden "rr" , orden "rv"


Orden "Bloquear el archivo"

Se puede acceder a esta orden cuando WinRAR está en los modo de gestión de ficheros y gestión de archivos. Si esta en el interior de un archivo no necesita seleccionar ningún fichero, simplemente ejecute la orden "Bloquear el archivo" del Menú Órdenes, pulse el botón "Bloquear" de la barra de herramientas o el método abreviado Alt+L. Si esta examinando ficheros sin comprimir en el modo de gestión de ficheros, primero seleccione los ficheros y carpetas en los que buscar archivos a bloquear.

WinRAR no puede modificar un archivo bloqueado. Puede bloquear archivos importantes para evitar que sean modificados por accidente.

Equivalente a la línea de órdenes: orden "k"


Orden "Buscar virus en el archivo"

Esta orden está accesible tanto desde el modo manejo de ficheros como desde el modo de manejo de archivos . Los archivos se descomprimen en un directorio temporal y se verifica su contenido con algún programa antivirus no distribuido con WinRAR que el usuario haya instalado previamente. En el modo de manejo de archivos solo se procesa el archivo actual, mientras que en modo de manejo de ficheros se procesan todos los archivos encontrados en los ficheros y carpetas seleccionadas.

El cuadro de diálogo que muestra esta orden contiene los siguientes campos:

Antivirus encontrados por WinRAR

Lista todos los programas antivirus instalados en su ordenador e identificados por WinRAR. Si esta lista contiene varios antivirus puede escoger el que desee. Si la lista solo contiene una entrada llamada “Definido por el usuario”, significa que WinRAR no ha podido encontrar ningún programa antivirus y que usted debe configurar manualmente el nombre del antivirus y su línea de órdenes.

Nombre del antivirus

Nombre del fichero ejecutable del antivirus. Es necesario modificar este campo solo si WinRAR no puede encontrar el programa antivirus instalado en su ordenador. En este caso deberá pulsar el botón “Examinar” y localizar el fichero .exe de su programa antivirus, que será ejecutado por WinRAR para verificar los ficheros descomprimidos.

Opciones del antivirus

Opciones del programa antivirus. Necesitará modificar este campo tanto si WinRAR no puede encontrar su programa antivirus como si desea modificar o corregir los parámetros que WinRAR pasa al antivirus. Por ejemplo, es posible que nuevas versiones del antivirus tengan sintaxis diferentes para su línea de órdenes. Normalmente los programas antivirus solo requieren de un parámetro - el nombre de la carpeta que contiene los ficheros a verificar. WinRAR substituirá %f con el nombre real de la carpeta y debido a que esta puede contener espacios es conveniente que la encierre entre dobles comillas. Así lo más normal es que use “%f” en este campo, aunque algunos programas pueden requerir otras opciones que podrá encontrar en la documentación del antivirus.

Si usted usa solo un programa antivirus y no necesita modificar sus parámetros cada vez, puede omitir la selección del programa antivirus desactivando la opción ‘Preguntar por el programa antivirus” en las opciones de Seguridad .

Notas

a) WinRAR no puede detectar virus por si mismo, necesita que disponga de algún programa antivirus instalado en sus sistema. Si no dispone de algún programa antivirus no podrá usar esta característica de WinRAR;

b) WinRAR no muestra ningún tipo de mensaje después de completar esta orden. Usted debe verificar la información proporcionada por su programa antivirus para comprobar si se han encontrado virus o no;

c) WinRAR descomprime todos los archivos seleccionados en una carpeta temporal antes de llamar al antivirus de forma que debe disponer de espacio suficiente en su disco duro para almacenar todos los ficheros descomprimidos. WinRAR elimina estos ficheros después de finalizar la verificación;

d) WinRAR es capaz de detectar automáticamente muchos programas antivirus populares, así que normalmente no es necesario modificar los campos “Nombre del antivirus” y “Opciones del antivirus”. Solo selecciones el programa antivirus de la lista y pulse “Aceptar”, y solo modifique los valores de estos campos si esto no funciona;

e) WinRAR guarda los valores de configuración del último antivirus utilizado y los restaura cuando activa esta orden de nuevo.


Orden "Convertir archivos"

Esta orden permite precomprimir archivos de un formato a otro. Es accesible tanto desde el modo de manejo de ficheros como desde el modo de manejo de archivos . En el modo de manejo de ficheros puede seleccionar varios ficheros y/o carpetas y WinRAR buscaré en ellos y convertirá los archivos encontrados. En el modo de manejo de archivos solo el archivo actual será convertido. El diálogo "Convertir archivos" contiene varias opciones para controlar el proceso que se describen a continuación.

Archivos a convertir

Lista de archivos que serán convertidos por WinRAR. Puede añadir o eliminar elementos de la lista usando los botones "Añadir" y "Eliminar". El botón "Eliminar" no elimina ficheros del disco, solo los elimina de la lista de ficheros a convertir.

El contenido de la lista depende del siguiente parámetro; listado de formatos.

Tipos de archivos

Aquí puede escoger que tipos de archivos serán convertidos. Los formatos de archivo en la lista pueden ir seguidos de un número encerrado entre paréntesis. Este número indica cuantos archivos de ese tipo se han encontrado y están listos para ser convertidos. Por ejemplo, “zip(12)” significa que WinRAR ha encontrado 12 archivos del tipo zip. Cuando no se ha encontrado ningún archivo del tipo especificado no se muestra ningún número.

Opciones de conversión/Compresión mínima

Esta opción permite especificar la razón de compresión mínima aceptable (<tamaño comprimido nuevo>/<tamaño comprimido anterior>) para los archivos convertidos. Por ejemplo, si especifica una razón de 100, WinRAR mantendrá el archivo original si el tamaño del archivo convertido es superior al original. Si desactiva esta opción WinRAR ignorará los tamaños de los archivos.

Opciones de conversión/Compresión

El botón "Compresión" active un Nuevo cuadro de diálogo donde puede escoger varios parámetros de compresión para los archivos nuevos. Por ejemplo, puede seleccionar entre el formato rar o el zip.

Opciones de conversión/Carpeta de destino

Aquí puede especificar la carpeta donde desea crear los archivos convertidos. Si no establece ningún valor para esta opción los archivos convertidos se crearán en la misma carpeta que los archivos originales.

Opciones de conversión/Eliminar archivos originales

Al activar esta opción se eliminarán los archivos originales cuando hayan sido convertidos correctamente al Nuevo formato.

Si los archivos convertidos son del mismo formato que los originales y la opción “Carpeta de destino” esta en blanco, los archivos originales serán eliminados aunque esta opción no este activada.

Opciones de conversión/Omitir archivos encriptados

Si esta opción esta activada, los archivos con datos encriptados no serán procesados. Puede ser útil si desea ejecutar la conversión de forma desatendida evitando así que la conversión se pare para preguntarle la contraseña. De todas formas, si sabe que todos los archivos encriptados usan la misma contraseña, otra forma de hacerlo es desactivar esta opción y establecer la contraseña predeterminada en el Menú Archivo antés de iniciar la conversión.

Botón "Guardar"

Este botón almacena los valores seleccionados excepto la lista de “Archivos a convertir” de forma que se restauren automáticamente a los valores seleccionados la próxima vez que utilice este diálogo. Puede usarlo para guardar su configuración favorita.

Notas

  1. WinRAR solo mantiene el archivo convertido si se ha creado y verificado correctamente de forma que el tamaño total de los ficheros comprimidos sea igual que el tamaño total de los ficheros descomprimidos del archivo original.
  2. WinRAR intenta conservar los comentarios de archivo siempre que es posible. Sin embargo, si el usuario ha especificado un comentario en las opciones activadas al pulsar el botón compresión, este tendrá preferencia. Los comentarios de fichero no son convertidos. Otros tipos de información como los flujos de NTFS y los atributos de seguridad pueden o no ser convertidas dependiendo de los parámetros de compresión y el formato de archivo.
  3. WinRAR descomprime los archivos originales en una carpeta temporal antes de convertirlos, por lo que necesita suficiente espacio en disco parar realizar esta operación.
  4. Es posible que WinRAR no pueda convertir archivos que contengan datos especiales como enlaces o versiones de ficheros.


Orden "Reparar el archivo"

Se puede acceder a esta orden cuando WinRAR está en los modo de gestión de ficheros y gestión de archivos. Considera que los ficheros seleccionados son archivos dañados e intenta repararlos. Para ejecutar esta orden, utilice el Menú Herramientas , el botón "Reparar" de la barra de herramientas o el método abreviado Alt+R.

WinRAR sólo puede reparar archivos RAR y ZIP. WinRAR intenta detectar automáticamente el tipo de archivo mediante los datos de archivo y la extensión; sin embargo, el usuario también puede establecer manualmente el tipo de archivo.

El archivo fuente no cambia y se almacena el resultado de la operación en un archivo nuevo al que se da el nombre de fixed.nombrearchivo.rar o rebuilt.nombrearchivo.rar, donde 'nombre archivo' es el nombre original del archivo.

El resultado de la operación "Reparar" depende del tipo de archivo y del tipo y tamaño del area dañada. Las posibilidades de que la reparación de un archivo RAR sea exitosa son notablemente más altas si tiene un registro de recuperación. Tenga en cuenta que un archivo sólido que carece de registro de recuperación, normalmente, no puede ser reparado con éxito y que no es posible reparar archivos con nombres de fichero cifrados.

En la descripción de la orden "r" ("r" es la línea de órdenes equivalente a "Reparar el archivo"), se proporcionan detalles técnicos sobre la reparación de archivos

Equivalente a la línea de órdenes: orden "r"


Orden "Convertir el archivo en SFX"

Orden "Convertir el archivo a auto extraíble"

Se puede acceder a esta orden cuando WinRAR está en los modo de gestión de ficheros y gestión de archivos. Convierte un archivo en auto extraíble (SFX). Si esta dentro de un archivo no necesita seleccionar ningún fichero para realizar esta operación. Simplemente ejecute la orden "Convertir el archivo a auto extraíbles" del Menú Herramientas, pulse el botón "Auto extraíble" de la barra de herramientas o el método abreviado Alt+X y seleccione el módulo auto extraíble necesario en la lista. Si esta examinando ficheros descomprimidos en el modo de gestión de ficheros, primero seleccione los ficheros y carpetas en los que buscar archivos a convertir.

Si un archivo ya es auto extraíble, con esta orden también puede eliminar del archivo un módulo auto extraíble ya existente. En este caso, WinRAR no toca el archivo original y crea un archivo nuevo con el mismo contenido, pero sin módulo auto extraíble.

Si seleccionó el módulo auto extraíble gráfico para Windows, que es la opción predeterminada, también puede hacer clic en "Opciones avanzadas …" para determinar una serie de parámetros para la auto extracción como la ruta predeterminada de destino, un título y el texto de la ventana. Consulte el tema Opciones avanzadas para más información.

Estos temas describen los módulos auto extraíbles que se facilitan en el paquete WinRAR:

  • Módulos RAR y ZIP gráficos(Default.SFX y Zip.SFX)
  • Módulo RAR para consola (WinCon.SFX)

Equivalente a la línea de órdenes: orden "s"


Orden "Buscar ficheros"

Esta orden esta disponible tanto desde el modo de manejo de ficheros como desde el modo de manejo de archivos. Usando este cuadro de diálogo es posible buscar ficheros que contengan una cadena de texto determinada tanto en el archivo abierto como en las carpetas o disco seleccionados. A continuación se describen las opciones disponibles.

Ficheros donde buscar

Por defecto contiene “*” que significa buscar en todos los ficheros. Puede especificar aquí cualquier otra mascara de búsqueda como, por ejemplo, “*.txt” para buscar solo en los ficheros .txt. Se permiten varias mascaras separadas por espacios. Si necesita especificar un nombre de fichero que contenga espacios deberá encerrarlo entre comillas.

Palabras a buscar

Aquí puede especificar la cadena de texto a buscar. Si deja este campo en blanco, WinRAR listará todos los ficheros que cumplan con los demás criterios especificados.

Mayúsculas/minúsculas

Activa o desactiva la búsqueda sensible a mayúsculas/minúsculas.

Usar todas las tablas

Usar las tablas de caracteres ANSI, Unicode y OEM (MS DOS) al buscar la cadena de texto. Si esta opción no esta activada, WinRAR usará solo la tabla de caracteres por defecto de Windows (ANSI).

Búsqueda hexadecimal

Trata la cadena de texto a buscar como una secuencia de valores hexadecimales separados por espacios.

Discos y carpetas

Este campo contiene la lista de discos, carpetas o nombres de archivos donde buscar. También puede seleccionar <Carpeta actual>, <Discos duros locales> o seleccionar individualmente cada disco por separado de la lista.

Tipos de archivos

Tipos de archivos en los que buscar. Por defecto su valor es “*” lo que significa “todos los tipos de archivos”, aunque, por ejemplo, puede especificar “*.rar” para buscar solo en archivos rar. Se permite entrar varias mascaras de archivos separadas por espacios Debido a limitaciones técnicas WinRAR no puede buscar en archivos ACE, pero si en los demás formatos soportados por WinRAR.

Opción "Búsqueda recursiva"

Hace que WinRAR busque en la carpeta seleccionada y, recursivamente, en todas sus subcarpetas.

Opción "Buscar en ficheros"

Si esta activada, WinRAR además de buscar en archivos comprimidos, también realizará la búsqueda en ficheros no comprimidos cuyo nombre concuerde con la mascara especificada.

Opción "Buscar en archivos"

Activa la búsqueda en ficheros comprimidos. Puede activar tanto "Buscar en ficheros" como "Buscar en archivos" para realizarla búsqueda tanto en archivos comprimidos como en ficheros normales.

Botón "Guardar"

Este botón guarda los valores de cada campo para que estén disponibles la próxima vez que use este cuadro de diálogo.

Orden equivalente de la línea de comandos: orden "i"


Orden "Mostrar la información de archivo"

Sólo se puede acceder a esta orden cuando WinRAR está en el modo de gestión de archivos. No necesita seleccionar ningún fichero para realizar esta operación, simplemente ejecute la orden "Mostrar información de archivo" del Menú Herramientas, pulse el botón "Información" de la barra de herramientas o el método abreviado Alt+I.

En el modo de gestión de archivos permite obtener información sobre el contenido de los ficheros y carpetas seleccionadas: el tamaño total, el número de ficheros y subcarpetas y el número de archivos. Para aumentar la velocidad de operación los archivos se detectan según su extensión de modo que los archivos auto extraíbles no se tienen en cuenta. La detección de ficheros puede tardar bastante pero puede cancelarla en cualquier momento cerrando esta ventana.

El espacio en disco se asigna a los ficheros en bloques de tamaño fijo llamados clusters. Por ejemplo, si el tamaño de cluster es de 4096 bytes y usted crea un fichero de solo 1 byte, de hecho ocupará 4096 bytes en su disco duro. Por ello y para informarle de cuanto espacio realmente ocupan sus ficheros y cuanto espacio puede ahorrarse después de comprimirlos este cuadro de dialogo también le muestra el tamaño de cluster del disco actual, el tamaño real de los ficheros seleccionados incluyendo el espacio en desuso de cada cluster y el tamaño del espacio desaprovechado.

Cuando la detección haya finalizado, puede pulsar el botón “Estimar” para obtener una aproximación sobre el tiempo y razón de compresión de los ficheros seleccionados. La estimación de la compresión se realiza de forma rápida y poco precisa, así que no espere aquí un resultado exacto, aunque puede indicarle si merece la pena el tiempo de compresión en relación a la compresión esperada. Si selecciona la opción “Empezar automáticamente” antes de cerrar la ventana, la próxima vez que la abra, la estimación se realizará de forma automática sin que tenga que pulsar el botón “Estimar”.

También es posible, después de finalizar la operación de detección, cambiar a otras paginas de esta ventana y especificar diferentes opciones como comentarios, registro de protección, módulos auto extraíbles, etc , permitiendo aplicar los cambios necesarios a todos los archivos RAR y ZIP comprendidos en la selección de carpetas y ficheros. A diferencia de la operación de detección, aquí si se procesan los archivos auto extraíbles. Tenga cuidado con esta operación ya que puede cambiar los parámetros de cientos de miles de archivos de una sola vez. Esta característica es muy potente pero puede ser peligrosa si se usa de forma inadecuada.

En el modo de gestión de archivo, cuando active “Mostrar información” tanto dentro como fuera de un archivo, pero solo cuando haya un solo fichero seleccionado, WinRAR le mostrará la siguiente información sobre dicho archivo:

  • nombre de archivo (en el título del cuadro de diálogo);
  • tipo de archivo (sólido, auto extraíble, volumen ) y formato (RAR, ZIP, CAB, ARJ, LZH, etc.). Todos esto parámetros se combinan en la única cadena de caracteres que aparece en la parte superior del cuadro de diálogo.

Para volúmenes RAR creados con WinRAR 3.40 o superior este texto también incluye el número de volumen. Este número puede ser útil si el nombre original del volumen se pierde y necesita restaurarlo manualmente;

  • versión del compresor que, como mínimo, se necesita para realizar la extracción;
  • sistema operativo en el que se creó el archivo;
  • número total de ficheros;
  • tamaño total de los ficheros descomprimidos y comprimidos;
  • razón total de compresión;
  • tamaño del módulo auto extraíble o cero para los archivo que no son auto extraíbles;
  • presencia del comentario de archivo ;
  • presencia de ficheros codificados ;
  • si el archivo está bloqueado o no;
  • un tamaño de la zona máxima de daños continuos que se puede reparar aún en el mejor de los casos utilizando el registro de recuperación, en caso de que exista;
  • tamaño máximo del diccionario utilizado para cualquier fichero dentro del archivo;

Si el archivo incluye un comentario de archivo, aparece en pantalla una hoja de diálogo adicional con este comentario.

Al igual que en el modo de gestión de ficheros, es posible cambiar a otras páginas de la ventana y especificar diferentes parámetros para el archivo actual. Pulse el botón “Ayuda” en cada página para obtener más ayuda sobre cada una de ellas.


Orden "Generar informe"

Esta orden está disponible tanto en los modos de manejo de ficheros como en el de archivos.

En el modo de manejo de archivos esta orden crea un informe que contiene la lista completa de ficheros contenidos en el archivo abierto. Se ignora el estado actual de selección de ficheros.

En el modo de manejo de ficheros el informe proporciona información solo sobre los elementos seleccionados. Dependiendo de las opciones seleccionadas, el informe puede incluir tanto ficheros normales como el contenido de los archivos encontrados en los elementos seleccionados. Si usted selecciona una carpeta, WinRAR procesará sus ficheros y sus subcarpetas.

Dispone de las siguientes opciones para generar el informe:

Guardar informe en fichero

Aquí puede especificar en que fichero guardar el informe. Si no desea guardar el informe puede dejar esta opción en blanco.

Imprimir informe

Active esta opción si desea imprimir el informe.

Copiar informe al portapapeles

Active esta opción si desea copiar el informe al portapapeles. Guardar datos en el portapapeles requiere una determinada cantidad de memoria, así que tenga cuidado con esta opción si espera generar un informe de gran tamaño (varios megabytes). Puede requerir mucha memoria y reduce la velocidad de la operación.

Formato de sálida (HTML, texto Unicode, texto)

Seleccione el formato de sálida del informe. HTML y Texto Unicode soportan Unicode de forma que los carácteres no ingleses en los nombres de ficheros y archivos se muestran correctamente. El formato Texto no es compatible con Unicode y puede mostrar incorrectamente los carácteres no ingleses.

Ordenar ficheros por (orden original, nombre, tamaño, tamaño comprimido, fecha de modificación, suma de control)

Aquí puede seleccionar el tipo de ordenación de los ficheros o seleccionar “orden original” si no desea ningún tipo de ordenación.

Ordenar archivos por separado

Si esta opción está activada, el contenido de cada archivo incluido en el informe se ordenará de forma independiente de otros archivos y ficheros de forma que todos los ficheros de un mismo archivos se muestren agrupados. De lo contrario todos los ficheros incluidos en el informe se ordenaran conjuntamente ignorando a que archivo pertenecen. Esta opción no tiene ningún efecto sobre el órden original.

Incluir en el informe / Archivos

Esta opción solo está disponible en el modo de manejo de ficheros. Si esta activa WinRAR analiza todos los ficheros y si encuentra algún archivo también incluye su contenido. Si desea obtener un listado de ficheros de su disco y no le preocupa el contenido de archivos comprimidos desactive esta opción para mejorar la velocidad de la operación.

Incluir en el informe / Ficheros

Esta opción está disponible solo en el modo de manejo de ficheros. Si esta activada, WinRAR incluirá todos los ficheros que encuentre. Si solo desea incluir ficheros comprimidos debe desactivar esta opción.

Incluir en el informe / Nombre de archivo

Si esta opción está activada, el informe incluirá el nombre del archivo antes del grupo de ficheros pertenecientes al archivo. En algunos casos especiales puede querer desactivar esta opción, por ejemplo, si necesita enviar el informe a algún programa externo para su proceso.

Incluir en el informe / Información total

Si esta activada, WinRAR incluirá información sobre el número y tamaño total de ficheros al final del informe. Si la opción “Ficheros” esta activada, sólo se incluirá en esta información a los ficheros no comprimidos, en caso contrario sólo se incluirá la información de archivos comprimidos. Esta información nunca incluye a ambos, ficheros normales y archivos. Para los ficheros que están incluidos en varios volúmenes esta información sólo incluye a aquellos ficheros que empiezan en el volumen actual, de forma que así se evita tener que procesar los volúmenes varias veces cuando se procesa un grupo de volúmenes.

Incluir en el informe / Tamaño de fichero

Incluir el tamaño real, no comprimido, del fichero en el informe.

Incluir en el informe / Tamaño comprimido

Incluir el tamaño comprimido del fichero en el informe. Para ficheros normales el tamaño comprimido puede que no sea igual al tamaño real del fichero si el fichero esta en un disco NTFS y tiene el atributo de “Comprimido”.

Incluir en el informe / Fecha del fichero

Incluir la fecha de la última modificación del fichero en el informe. El formato de la fecha es siempre YYYY-MM-DD hh:mm, y no depende de la configuración regional del sistema.

Incluir en el informe / Suma de control

Incluir la suma de control del fichero en el informe. Esta opción está disponible tanto para ficheros normales como para archivos comprimidos. La suma de control de los ficheros comprimidos depende del formato y opciones del archivo, para ficheros normales siempre es el CRC32. Activarla para ficheros normales puede ralentizar notablemente la generación del informe, ya que WinRAR deberá leer todos los ficheros a procesar y calcular su CRC32. Normalmente los archivos ya contienen ls suma de control calculada previamente, por lo que esta opción no añade ningún tiempo de proceso extra.

Botón "Guardar"

Utilícelo para guardar las opciones seleccionadas, excepto el nombre del informe, y establecerlas como las opciones por defecto. WinRAR guarda dos juegos diferentes de opciones predeterminadas, una para el modo de manejo de ficheros y otra para el modo de manejo de archivos.


Menú Fichero

Orden | Acceso directo | Función
Abrir archivo | Ctrl+O | Abre el archivo especificado. También puede consultar otros métodos para abrir un archivo.
Guardar copia del archivo como ... |  | Guarda una copia del archivo abierto en el explorador de WinRAR en otra carpeta.
Cambiar unidad | Ctrl+D | Cambia la unidad que se está utilizando
Establecer contraseña | Ctrl+P | Establece la contraseña predeterminada. Deberá escribir la contraseña dos veces para asegurar su exactitud. Esta contraseña se utilizará en todas las operaciones de compresión y extracción.
Seleccionar todo | Ctrl+A | Selecciona todos los ficheros y las carpetas
Copiar ficheros al portapapeles | Ctrl+C | Copia los archivos o ficheros seleccionados al portapapeles. Por ejemplo, puede seleccionar algunos ficheros del archivo, pulsar Ctrl-C , abrir una carpeta en el Explorador de Windows y pulsar Ctrl-V para descomprimir los ficheros seleccionados en dicha carpeta. Puede pulsar Ctrl+V en un editor de texto para copiar sólo los nombres de los ficheros en vez de su contenido
Pegar ficheros desde el portapapeles | Ctrl+V | Al pegar ficheros en WinRAR se inicia el proceso de compresión, de forma que puede seleccionar los ficheros en el Explorador de Windows y pegarlos en WinRAR para comprimirlos.
Seleccionar grupo | NUM + | Selecciona todos los ficheros y las carpetas que corresponden a una máscara introducida
Eliminar selección de grupo | NUM - | Elimina la selección de todos los ficheros y carpetas que corresponden a una máscara introducida
Invertir selección | NUM * | Invierte la selección de todos los ficheros y carpetas
Salir | Alt+F4, Ctrl+w | Sale de WinRAR

Dependiendo de la opción "Conservar el historial de los archivos" del cuadro de diálogo Configuración general, pueden aparecer los nombres de algunos archivos abiertos recientemente debajo de la orden "Salir" . Puede utilizarlos para abrir rápidamente esos archivos en WinRAR.


Menú Órdenes

Función | Acceso directo
Agregar ficheros al archivo | Alt+A
Extraer en la carpeta especificada | Alt+E
Comprobar ficheros comprimidos | Alt+T
Ver fichero | Alt+V
Eliminar ficheros | Supr, Mayús-Supr
Renombrar ficheros | F2
Imprimir fichero | Ctrl+I
Extraer sin pedir confirmación | Alt+W
Agregar comentario de archivo | Alt+M
Proteger archivo de daños | Alt+P
Bloquear archivo | Alt+L


Menú herramientas

Función | Acceso rápido
Asistente |
Buscar virus en el archivo | Alt+D
Convertir archivos | Alt+Q
Reparar archivo | Alt+R
Convertir archivo a SFX | Alt+X
Buscar ficheros | F3
Mostrar información | Alt+I
Generar informe | Alt+G
Pruebas de velocidad | Alt+B


Menú Favoritos

El Menú Favoritos contiene una lista de sus carpetas y archivos favoritos. Puede agregar el archivo o la carpeta abierta en este momento a la lista utilizando la orden "Agregar a favoritos…", cuyo método abreviado es Ctrl+F. Las descripciones son opcionales, si la descripción esta disponible, WinRAR la mostrará en el menú, en caso contrario mostrará el nombre de archivo o de carpeta.

Si selecciona un archivo o carpeta de la lista, se abrirá en WinRAR. Tenga en cuenta que puede abrir rápidamente los diez primeros elementos favoritos sin abrir el menú, con tan sólo pulsar las teclas Ctrl+1 … Ctrl+0. Ctrl+1 activa el primer elemento favorito; Ctrl+2, el segundo; …; Ctrl+9, el noveno; Ctrl+0, el décimo.

La orden "Organizar favoritos" permite editar/ eliminar los favoritos y también subirlos o bajarlos en la lista. Seleccione el elemento deseado y haga clic en el botón correspondiente para realizar cualquiera de estas operaciones. Para eliminar un favorito además del botón "Eliminar" también puede utilizar la tecla Supr.


Menú Opciones

La orden "Configuración…" de este menú activa el cuadro de diálogo que contiene la siguiente configuración de WinRAR: General, Compresión, Rutas de acceso, Lista de ficheros, Visor , Seguridad e Integración. Seleccione cualquiera de estos temas para más información. El método abreviado para la orden "Configuración…" es Ctrl+S.

Puede exportar la configuración de WinRAR a un fichero e importarla más tarde utilizando dos órdenes apropiadas del submenú "Importar/ Exportar". El nombre del fichero es "Settings.reg" y se sitúa en la carpeta %APPDATA%\WinRAR. Restablecer la configuración desde el fichero puede reducir el tiempo necesario para configurar WinRAR si vuelve a instalar Windows o necesita mover WinRAR a otro ordenador. Si WinRAR no puede encontrar la configuración en Registro y el fichero Settings.reg están en la carpeta WinRAR o en la carpeta %APPDATA%\WinRAR, se importará automáticamente. Es posible que sea necesario reiniciar WinRAR para aplicar algunas de las opciones importadas.

El submenú “Lista de ficheros" contiene dos grupos de opciones. La orden "Carpetas" (tecla de acceso rápido Ctrl+H) cambia entre la vista clásica en forma de árbol a la vista simple, donde todos los ficheros y carpetas comprimidas se muestran en la misma lista. Solo se aplica al modo de manejo de archivos. Otras opciones del grupo son "Lista" y "Detalles", que controlan la apariencia del listado de ficheros. La opción "Lista" cambia el listado al modo multicolumna donde solo se muestran los nombres de los ficheros, mientras que "Detalles" muestra información mas detallada sobre cada fichero como su tamaño.

El submenú "Panel de navegación" permite mostrar u ocultar el panel de navegación con la vista del árbol de carpetas. Puede configurarlo de forma separada para el modo de manejo de ficheros (opción del menú "Mostrar carpetas de disco”) y para el modo de manejo de archivos (opción del menú "Mostrar carpetas de archivo"). Otra forma de cambiar el estado de visualización del panel de navegación es mediante la combinación de teclas Ctrl+T. El panel con la vista de árbol de carpetas es conveniente si necesita navegar rápidamente por el contenido del su PC o del archive en curso. Puede cambiar el ancho de este panel arrastrando su borde derecho con el ratón.

El submenú "Temas" contiene una lista de los temas gráficos de WinRAR , la orden "Organizar temas…" que proporciona funciones de manejo de temas y la orden "Obtener más temas …" que permite bajarse mas temas desde Internet.

Otra orden de este menú es "Ver registro…". Abre en el visor interno el contenido de rar.log, que está situado en la carpeta %APPDATA%\WinRAR. Tenga en cuenta que necesita activar "Registrar los errores en el fichero" en el cuadro de diálogo Configuración general para obligar a WinRAR a escribir los errores en el fichero de registro. Utilice la orden de menú "Borrar registro" para borrar el contenido del fichero de registro. Sólo se puede acceder a este registro en las versiones registradas.


Menú Ayuda

Seleccione la orden "Temas de ayuda" para ver el contenido de la ayuda WinRAR.

Utilice el elemento "Página oficial WinRAR" para conectarse a la página oficial WinRAR, donde siempre puede descargar la última versión de WinRAR y registrar en línea su copia de evaluación del WinRAR.

La orden "Acerca de WinRAR…" muestra en pantalla el cuadro de diálogo con la versión y la información del copyright.


Cómo abrir un archivo desde el intérprete de órdenes de Windows

Si no desactivó la opción "Asociar WinRAR con archivos" al instalar WinRAR, es realmente fácil abrir un archivo en WinRAR desde el Explorador o el Escritorio. Tan sólo tiene que hacer doble clic en el icono del archivo.

Tras la instalación, también puede asociar WinRAR con archivos utilizando el cuadro de diálogo Configuración de la integración.


Empleo de menús contextuales

Si no desactivó la opción "Integrar WinRAR en el intérprete de órdenes" al instalar WinRAR, se agregarán varios elementos adicionales al menú contextual estándar de fichero y de carpeta. Éste aparece al hacer clic con el botón derecho del ratón sobre un icono de fichero en el Explorador o en el Escritorio.

En los archivos, WinRAR añade los siguientes elementos: "Extraer ficheros…", “Extraer aquí” y "Extraer en <nombre de la carpeta>", sustituyendo <nombre de la carpeta> por el nombre real de la carpeta. Las dos órdenes hacen que WinRAR extraiga el contenido del archivo. No obstante, mientras que la primera le permite a usted entrar en la carpeta de destino y en algunas opciones de extracción del cuadro de diálogo Ruta de Extracción y opciones, la segunda realiza la extracción en la carpeta propuesta sin formular preguntas adicionales. Cuando ha seleccionado un grupo de archivos el menú contextual incluye la opción “Extraer cada archivo en carpetas separadas” que le permite extraer el contenido de cada archivo en carpetas diferentes.

WinRAR también modifica el elemento "Propiedades" del menú contextual de los archivos para mostrar la información de archivo y el comentario de archivo en caso de que exista. La información de archivo es similar a la mostrada por la orden Mostrar la información de archivo./P>

En los ficheros y las carpetas comunes, WinRAR añade los siguientes elementos: "Agregar al archivo…", "Agregar al archivo <nombre de archivo>", “Agregar y enviar por email ..”, “Agregar al archivo <nombre de archivo> y enviar por email ...”, sustituyendo <nombre de archivo> por el nombre real del archivo. Los dos órdenes hacen que WinRAR agregue los ficheros seleccionados al archivo. No obstante, mientras que la primera le permite entrar en el nombre de archivo y en algunas opciones de compresión del cuadro de diálogo Nombre de archivos y parámetros, la segunda comienza a agregar al archivo propuesto sin formular preguntas adicionales. De forma similar las dos órdenes para enviar por email comprimen los ficheros seleccionados y adjuntan el archivo recién creado a un mensaje de correo electrónico. Para que estas opciones para correo electrónico funcionen necesita tener instalado algún programa que soporte MAPI (actualmente la mayoría de los programas modernos para correo electrónico lo soportan)


Compatibilidad con la función "arrastrar y soltar"

WinRAR permite el uso de la función de Windows "arrastrar y soltar".

Si, en el modo de gestión de ficheros , se deja un único archivo en WinRAR, se mostrará su contenido y WinRAR entrará en el modo de gestión de archivo.

Si, en el modo de gestión de ficheros, se dejan en WinRAR uno o varios ficheros que no pertenezcan al archivo, WinRAR solicitará confirmación del nombre de archivo y los agregará al archivo.

Si en el modo de gestión de archivos, se deja un solo archivo en la barra de herramientas o en la barra de direcciones, WinRAR mostrará el contenido de dicho archivo. Si desea añadir uno o mas ficheros al archivo que tiene abierto, suelte los ficheros en la lista del contenido del archivo. De todas formas, si los ficheros no son archivos comprimidos y los deja en la barra de herramientas o la barra de direcciones el resultado será el mismo que dejarlos en la lista de ficheros. Soltar ficheros solo esta disponible para archivos RAR y ZIP.

Independientemente del modo actual de WinRAR y del formato de archivo, usted puede arrastrar ficheros desde WinRAR hasta otros programas.

Si no desactivó la opción "Integrar WinRAR en el intérprete de órdenes" al instalar WinRAR, puede soltar los ficheros en los iconos de archivo RAR o ZIP, situados en el Escritorio, para así agregarlos a un archivo. De igual modo, si usted arrastra un archivo con el botón derecho del ratón y lo coloca en la carpeta de destino, puede seleccionar en el menú que aparece "Extraer en aquí” para extraer todos los ficheros de ese archivo en la carpeta de destino.


Sintaxis de la línea de órdenes

Se pueden ejecutar órdenes WinRAR desde la línea de órdenes. A continuación, se describe la sintaxis común de la línea de órdenes:

WinRAR <orden> -<parámetro1> -<parámetroN> <archivo> <ficheros...> <@lista_de_ficheros...> <ruta_de _extracción\>

Orden | Combinación de carácteres que especifica la función que va a realizar WinRAR, vea la lista de ordenes aquí
Opción | Parámetros utilizados para definir un tipo específico de operación, un método de compresión, un tipo de archivo, etc. Vea la lista de opciones de WinRAR aquí
Archivo | Nombre del archivo que se va a procesar.
Ficheros | El nombre o los nombres de los ficheros que se van a procesar.
Lista_de_ficheros | Lista_de_ficheros es el nombre de un fichero de texto que contiene los nombres de los ficheros que se van a procesar. Los nombre de fichero deben empezar en la primera columna. Es posible poner comentarios en esta lista después de los caracteres //. Por ejemplo, usted puede crear el fichero backup.lst cuyo contenido sea el siguiente: c:\Mis Documentos\*.doc// Ficheros Word c:\Mis Documentos\*.xls // Ficheros Excel c:\Mis Documentos\*.jpg // Imágenes y después ejecutar: winrar a backup @backup.lst Puede especificar en la línea de órdenes simultáneamente tanto nombres de ficheros como listas de ficheros.
Ruta_de_extracción | Utilizada sólo con las órdenes e y x , indica la carpeta en la que se van a situar los ficheros extraídos. Si esta carpeta no existe, se creará.

Notas

a) Si no se especifican ni los ficheros ni la lista de ficheros, se sobrentiende *.* y WinRAR procesará todos los ficheros;

b) Si no se especifica la extensión del archivo al crearlo, WinRAR utilizará el formato predeterminado de archivo que se seleccionó en el perfil de compresión. No obstante, usted puede anularlo especificando bien la extensión .RAR bien la .ZIP;

Si no se especifica la extensión del archivo al extraer, WinRAR utilizará .rar, de esta forma * significa todos los archivos con extensión .rar. Si necesita descomprimir archivos sin extensión, use la máscara *. La máscara *.* selecciona todos los ficheros. Puede usar comodines en el nombre del archivo en muchas de las operaciones como en la extracción, verificación y muchas otras, pero no estan permitidos al comprimir o eliminar.

c) Los parámetros escritos en la línea de órdenes anulan los mismos valores de configuración;

d) Para los órdenes c, e, s, t, rr, k y x se pueden utilizar comodines en el nombre de archivo. De este modo, se puede procesar más de un archivo con una única orden. Además, si usted especifica el parámetro -r con estas órdenes, buscarán archivos en las subcarpetas;

e) Algunas órdenes y parámetros sólo se pueden utilizar con archivos RAR; otros, con los archivos RAR y ZIP y otros, con todos los formatos de archivo. Esto depende de la funcionalidad proporcionada por el formato de archivo;

f) las órdenes y los parámetros no diferencian entre letras mayúsculas y minúsculas, puede escribirlos tanto en un tipo de letra como en el otro.

g) Si algún componente de la línea de ordenes contiene espacios, encierrelo entre comillas.

Ejemplos

  1. añadir la carpeta "c:\ultimos datos" al archivo Info.rar

WinRAR a Info.rar "c:\ultimos datos"

  2. descomprimir el archivo Info.rar en la carpeta d:\datos

WinRAR x Info.rar d:\datos\


Lista alfabética de órdenes

a | agregar ficheros a un archivo
c | agregar un comentario de archivo
ch | cambiar parámetros del archivo
cv | convertir archivos
cw | escribir el comentario de archivo en el fichero
d | eliminar ficheros de un archivo
e | extraer ficheros de un archivo, ignorando las rutas de acceso
f | refrescar los ficheros de un archivo
i | buscar texto dentro de los archivos
k | bloquear un archivo
m | mover ficheros y carpetas a un archivo
r | reparar un archivo dañado
rc | reconstruir volúmenes perdidos
rn | renombrar ficheros comprimidos
rr[N] | agregar el registro de recuperación de datos
rv[N] | crear volúmenes de recuperación
s[nombre] | convertir un archivo en auto extraíble
s- | eliminar el módulo auto extraíble
t | comprobar los ficheros de un archivo
u | actualizar los ficheros de un archivo
x | extraer ficheros de un archivo con las rutas de acceso completas


Orden A : agregar a un archivo

Agrega los ficheros y las carpetas especificadas a un archivo. Es una línea de órdenes equivalente a la orden Agregar.

Nota: dado que la modificación del volumen de archivo está desactivada, esta orden sólo se puede utilizar para crear un volumen de archivo y no para actualizarlo.

Ejemplos:

  1. añade todos los ficheros *.hlp de la carpeta actual al archivo help.rar

WinRAR a help *.hlp

  2. comprime todos los ficheros de la carpeta actual y de las subcarpetas en volúmenes sólidos auto extraíbles con un tamaño de 362000 bytes save.part1.exe, save.part2.rar, save.part3.rar, …, y agrega un registro de recuperación a cada volumen.

WinRAR a -r -v362 -s -sfx -rr save

Dado que no se especifica ningún nombre de fichero, se sobrentiende todos los ficheros (*).

  3. Como excepción especial, si se especifica el nombre de una carpeta como un argumento y este nombre no contiene ningún comodín ni la barra final, se agregará todo el contenido de la carpeta y las subcarpetas al archivo incluso sin la necesidad de usar el modificador -r.

La siguiente orden agregará todos los ficheros de la carpeta Bitmaps al archivo RAR Pictures.

WinRAR a Pictures.rar Bitmaps

  4. si el nombre de la carpeta incluye comodines o la barra final en el nombre de la carpeta, se aplican las normas usuales de forma que si desea procesar las subcarpetas deberá usar el modificador -r.

La siguiente orden añadirá todos los ficheros de la carpeta Bitmaps, pero no sus subcarpetas ya que no se ha usado el modificador -r:

WinRAR a Pictures.rar Bitmaps\*


Orden C : agregar un comentario de archivo

Esta orden permite agregar un comentario a un archivo. La extensión máxima de un comentario para archivos RAR es de 62000 bytes y para archivos ZIP, de 32768 bytes. También se puede agregar un comentario de archivo mediante la orden de manejo de archivo Agregar comentario de archivo.

Dado que la modificación del volumen de archivo está desactivada, no se puede aplicar esta orden a los volúmenes. Puede utilizar el parámetro -z<fichero> para agregar un comentario a un volumen en el momento en que lo crea.

Ejemplos:

a) añada un comentario al archivo distrib.rar

WinRAR c distrib.rar

b) los comentarios se pueden añadir desde un fichero utilizando el parámetro -z<fichero>.

WinRAR c -zinfo.txt dummy


Orden CH - cambiar parámetros de compresión

Orden CH – cambiar parámetros de compresión

Esta orden puede usarse para modificar la mayoría de las opciones y parámetros de un archivo ya comprimido. Es especialmente útil en combinación con las opciones como -cl, -cu, -tl que no tienen órdenes especificas.

Esta orden no permite recomprimir, cifrar o descifrar datos ni tampoco puede usarse para unir volúmenes o dividir un archivo en volúmenes. Si se utiliza esta orden sin ninguna opción adicional, el archivo resultante será exactamente el mismo que el original.

Ejemplo:

Establecer la fecha del archivo a la del fichero más nuevo

WinRAR ch -tl filecheros.rar


Orden CV - convertir archivos

Esta orden proporciona acceso a la funcionalidad de WinRAR para Convertir archivos. Puede combinarla con la opción -y para omitir el cuadro de dialogo "Convertir archivos" e iniciar la operación de conversión usando los parámetros predefinidos de conversión. Puede usar el botón “Guardar” en el cuadro de diálogo “Convertir archivos” para cambiar los parámetros por defecto.

Ejemplo:

Convertir todos los archivosl ZIP de la carpeta c:\ficheros usando los parámetros de conversión predefinidos

WinRAR cv -y c:\ficheros\*.zip


Orden CW - guardar comentario de archivo en fichero

Orden CW – guardar comentario de archivo en fichero

Esta orden permite guardar en un fichero el comentario del archivo. Use esta opción con la opción -sc si necesita especificar el juego de carácteres que usa el fichero con el comentario.

Ejemplos:

a) Guardar el comentario del archivo arc al fichero ASCII comentario.txt

WinRAR cw arc comentario.txt


Orden D : eliminar de un archivo

Elimina de un archivo los ficheros y las carpetas especificadas. Es el equivalente en línea de órdenes a la orden de manejo de archivo Eliminar.

Notas:

1) Si, después de la eliminación, se quitan todos los ficheros del archivo, el archivo vacío también se eliminará.

2) Dado que la modificación del volumen de archivo está desactivada, no se puede aplicar esta orden a los volúmenes.

Ejemplo:

elimine del archivo dummy todos los ficheros *.dmy

WinRAR d dummy *.dmy


Orden E : extraer del archivo ignorando las rutas de acceso

Orden E : extraer de un archivo ignorando las rutas de acceso

Extrae ficheros comprimidos en la carpeta actual o en una que se haya especificado ignorando las rutas de acceso. Es el equivalente en línea de órdenes a la orden de manejo de archivo Extraer en la carpeta especificada con la opción "No extraer las rutas" del cuadro de diálogo Ruta de extracción y opciones activada.

Ejemplo:

extraiga en la carpeta actual todos los ficheros *.doc pertenecientes a todos los archivos RAR existentes en la carpeta actual.

WinRAR e *.rar *.doc


Orden F : actualizar los ficheros de un archivo

Orden F : refrescar los ficheros de un archivo

Actualiza los ficheros de un archivo sólo si éstos son anteriores a los ficheros que se van a actualizar. Esta orden no agregará ficheros nuevos al archivo. Es el equivalente en línea de órdenes a la orden Agregar al archivo con el modo de actualización "Actualizar sólo los ficheros existentes" del cuadro de diálogo Nombre de archivo y parámetros seleccionado.

Esta orden no se puede aplicar a los volumenes.

Consulte también: orden A : agregar a un archivo


Opción I - buscar texto en los archivos

Opción I[i|c|h|t]=<texto> - buscar texto en los archivos

Buscar texto en los archivos. Soporta los siguientes parámetros opcionales:

i búsqueda no sensible a mayúsculas/minúsculas (predeterminado);

c búsqueda sensible a mayúsculas/minúsculas;

h búsqueda hexadecimal;

t usar tablas ANSI, Unicode y OEM;

Si no se especifica ningún parámetro es posible usar la sintaxis simplificada i<texto> en vez de i=<texto>

Es posible especificar el parámetro 't' junto a otros parámetros, por ejemplo, ict=texto realice una búsqueda sensible a mayúsculas/minúsculas usando las tablas mencionadas.

Debido a limitaciones técnicas WinRAR no soporta esta búsqueda en archivos ACE.

Ejemplos:

  1. Busca el texto “primer nivel” de forma sensible a mayúsculas/minúsculas en los ficheros *.txt de todos los archivos *.rar del disco c:

WinRAR "ic=primer nivel" -r c:\*.rar *.txt

  2. Busca la cadena hexadecimal f0 e0 ae ae ab 2d 83 e3 a9 en los archivos rar en el directorio e:\textos.

rar ih=f0e0aeaeab2d83e3a9 -r e:\textos


Orden K : bloquear un archivo

Esta orden impide que WinRAR realice cualquier otra modificación de archivo. Es el equivalente a la orden de manejo de archivo Bloquear el archivo en la línea de órdenes.

Ejemplo:

WinRAR k release


Orden M : mover ficheros y carpetas a un archivo

Es similar a la orden a, pero los ficheros y las carpetas se borran una vez completada con éxito la operación de compresión. En la línea de órdenes, es el equivalente a la orden Agregar al archivo con la opción "Eliminar los ficheros tras la compresión" del cuadro de diálogo Nombre de archivo y parámetros activada.

Dado que la modificación de volumen de archivo está desactivada, esta orden sólo se puede utilizar para crear un volumen de archivo y no para actualizarlo.


Orden R : reparar un archivo dañado

La reparación de un archivo consta de dos fases. Primero, se analiza el archivo dañado en busca de un registro de recuperación (consulte la orden rr ). Si el archivo contiene un registro de recuperación agregado con anterioridad y si la porción de datos dañados es continua y menor que el tamaño de código de correción de errores en el registro de recupración, las posibilidades de reconstruir con éxito el archivo son muy altas. Una vez completada esta fase, se creará un nuevo archivo con el nombre de fixed.nombrearc.rar, donde 'nombrearc' es el nombre del archivo dañado original.

Si un archivo dañado no contiene registro de recuperación o si no se puede recuperar totalmente debido a la gravedad de los daños, se iniciará una segunda fase. Durante esta fase, sólo se reconstruye la estructura del archivo y es imposible recuperar los ficheros que no superan la validación de la suma de control. Sin embargo, todavía se pueden recuperar los ficheros intactos que permanecían inaccesibles a causa de la estructura dañada del archivo. Por regla general, esto es útil para archivos que no son sólidos. A menudo, sólo se puede recuperar durante la segunda fase el primer fichero de un archivo sólido dañado. Esta fase no se lleva a cabo para archivos con nombres de ficheros cifrados, que solo pueden ser reparados si disponen de registro de recuperación.

Una vez completada esta fase, se creará un nuevo archivo llamado rebuilt.nombrearc.rar, donde 'nombrearc' es el nombre del archivo original.

Por defecto, los archivos reparados se crean en la carpeta actual, pero puede añadir un parametro opcional con la trayectoria si quiere especificar otra carpeta de destino.

Esta orden es el equivalente en línea de órdenes a la orden de manejo de fichero Reparar archivo.

Ejemplo:

reparar buggy.rar y crear el resultado en la carpeta 'c:\fixed'

WinRAR r buggy.rar c:\fixed\


Orden RC - reconstruir volumen dañado

Orden RC – reconstruir volumen dañado

Reconstruye los volúmenes dañados o perdidos usando volúmenes de recuperación (.rev files). Debe especificar cualquier nombre de volumen existente como nombre de archivo, por ejemplo:

WinRAR rc backup.part03.rar

Puede leer más acerca de los volúmenes de recuperación aquí.


Orden RN - renombrar ficheros comprimidos

Renombra ficheros dentro del archivo. Esta orden está soportada en archivos con formato RAR y ZIP. La sintaxis de la orden es:

winrar rn <arcname> <srcname1> <destname1> … <srcnameN> <destnameN>

Por ejemplo, la siguiente orden:

WinRAR rn data.rar readme.txt readme.bak info.txt info.bak

renombrará readme.txt a readme.bak e info.txt a info.bak en el archivo data.rar.

Se permite el uso de comodines en los nombres de origen y destino para transformaciones simples como cambiar las extensiones de los ficheros. Por ejemplo:

WinRAR rn data.rar *.txt *.bak

renombrará todos los ficheros *.txt a *.bak.

WinRAR no comprueba que el fichero de destino no exista ya en el archivo así que deberá ir con cuidado para evitar nombres duplicados. Esto es especialmente importante al usar comodines. Esta orden puede por tanto, ser peligrosa ya que el uso de comodines puede corromper todos los nombres de los ficheros comprimidos.


Orden RR[N] : agregar registro de recuperación de datos

Orden RR[N] : añadir registro de recuperación de datos

Opcionalmente, se puede añadir a un archivo RAR información redundante (registro de recuperación). Aunque incrementa dl tamaño del archivo le ayudará a recuperar ficheros dañados por errores de disco o perdidas de datos de cualquier otro tipo siempre que los daños no sean muy severos. Esta recupración de daños se puede hacer con la orden "r". El formato de archivo ZIP no soporta el registro de recuperación.

Los archivos RAR 4.x y RAR 5.0 usan diferentes estructuras y algoritmos para el registro de recuperación de daños.

El registro de recuperación de daños de RAR 4.x esta basado en el algoritmo XOR. Puede especificar el tamaño del registro de recuperación 4.x como el número de sectores o como un porcentaje sobre el tamaño del archivo. Para especificar el número de sectores añadalo directamente a continuación de 'rr', por ejemplo 'rr1000' para 1000 sectores. Para usar un porcentaje añada el modificador 'p' o '%' después del porcentaje, por ejemplo, 'rr5p' o 'rr5%' para un 5%. Tenga en cuenta que en ficheros .bat y .cmd de Windows es necesario usar 'rr5%%' en vez de 'rr5%', debido a que el procesador de ordenes trata un solo '%' como el inicio de un parámetro, de forma que quiza sea mas conveniente usar 'p' en vez de '%' en estos casos.

Los registros de recuperación RAR 4.x tienen un tamaño de 512 bytes. Si el área dañada es continua, cada sector ayuda a recuperar 512 bytes de información dañada. Este valor puede ser menor en casos con daños multiples. El número máximo de sectores de recupración es de 524288.

El tamaño del registro de recuperación 4.x puede determinarse aproximadamente como <tamaño del archivo>/256 + <número de sectores de recuperación>*512 bytes.

El registro RAR 5.0 no usa sectores de 512 bytes y solo puede especificar su tamaño como un porcentaje respecto al tamaño del archivo. Incluso si el modificador '%' o 'p' no está presente, RAR trata este valor como un porcentaje en el caso de formato de archivo RAR 5.0, de forma que tanto 'rr5' como 'rr5p' significan 5%. Debido a los datos adicionales requeridos el tamaño resultante solo se aproxima al porcentaje definido por el usuario, siendo la diferencia mayor en archivos pequeños.

El tamaño del registro de recuperación RAR 5.0 no puede superar el tamaño del archivo a proteger, así que no es posible usar mas de 100% como parámetro. Los registros de recuperación grandes se procesan de forma mas lenta tanto al crear como al reparar.

Tanto los registros 4.x como los 5.0 son mas eficientes si las posiciones de los daños en el archivo no estan desplazadas. Si copia el archivo desde un medio dañado usando algún tipo de programa especial y le da la posibilidad de escoger entre rellenar las áreas dañadas con ceros o no incluir estas áreas en el fichero, es preferible escoger la opción de rellenarlas con ceros o con cualquier otro valor porque esto permite preservar las posiciones originales de los datos. De todas formas, incluso no siendo el modo mas óptimo, ambas versiones de registros intentan reparar los datos incluso cuando se han producido eliminaciones o inserciones de tamaño razonable que han producido desplazamientos en las posiciones de los datos. El registro de recuperación RAR 5.0 maneja estos casos mas eficientemente que RAR 4.x.

Si usa la órden 'rr' sin especificar el tamaño, WinRAR establecerá por defecto el tamaño del registro de recuperación al 3% del tamaño del archivo.

Esta orden es el equivalente a la orden de manejo de archivo Proteger el archivo de daños en la línea de órdenes

Ejemplos:

  1. agregar un registro de recuperación de datos con el tamaño predeterminado (1%) al archivo backup

WinRAR rr backup

  2. añada un registro de recuperación de datos al archivo pictures y fije su tamaño en un 5% del tamaño total del archivo

WinRAR rr5p pictures


Orden RV[N] - crear volúmenes de recuperación

Orden RV[N] – crear volúmenes de recuperación

Crea volúmenes de recuperación (ficheros .rev) que podrán ser usados mas adelante para reconstruir volúmenes dañados.

Esta orden solo tiene sentido en archivos multivolumen RAR y necesita especificar el nombre del primer volumen de la secuencia como nombre de archivo. Por ejemplo:

WinRAR rv3 datos.part01.rar

El parámetro opcional <N> especifica el número de volúmenes de recuperación a crear y debe ser menor que el número total de volúmenes RAR de la secuencia. También puede añadir el símbolo de porcentaje a este parámetro en cuyo caso el número de ficheros .rev creados será igual al porcentaje especificado respecto al número total de volúmenes RAR. Por ejemplo:

WinRAR rv15% datos.part01.rar

Puede leer más sobre los volúmenes de recuperación aquí.


Orden S[nombre] : convertir un archivo en auto extraíble

Esta orden crea un archivo auto extraíble (SFX) que extrae los ficheros que lleva en su interior al ser ejecutado.

También se puede crear un archivo auto extraíble como primer volumen de una secuencia multivolumen, pero se debe tener en cuenta que el tamaño será mayor debido a la suma del módulo auto extraíble. En caso de que se creen los volúmenes auto extraíbles utilizando la orden a con los parámetros: -v[<tamaño>] -sfx, no necesita asegurar el tamaño del volumen: el primer volumen se creará automáticamente con el tamaño adecuado.

Esta orden es el equivalente en línea de órdenes a la orden de manejo de archivo Convertir archivo en auto extraíble.

Ejemplo:

WinRAR s diamant

Por defecto, WinRAR utiliza el fichero de módulo auto extraíble default.sfx para los archivos RAR y dicho fichero debe estar situado en la misma carpeta que winrar.exe. Para los archivos ZIP, utiliza el módulo zip.sfx. En la orden "s", se puede especificar un nombre alterno para el módulo auto extraíble.

Por ejemplo, para agregar el módulo auto extraíble para DOS WinCon.sfx ejecute:

WinRAR sWinCon.sfx myinst


Orden S- : quitar el módulo SFX

Orden S- : quitar el módulo auto extraíble

Esta orden elimina un módulo auto extraíble del archivo auto extraíble (SFX) ya existente.

WinRAR crea un nuevo archivo sin módulo auto extraíble. No se elimina el archivo auto extraíble original.

Ejemplo:

WinRAR s- rarsetup.exe


Orden T : comprobar los ficheros de archivo

Orden T : comprobar los ficheros comprimidos

Esta orden simula una extracción de fichero, sin escribir nada en el flujo de salida, para validar el fichero o los ficheros especificados. Es el equivalente en línea de órdenes a la orden de manejo de archivo Comprobar los ficheros.

Ejemplo:

compruebe todos los archivos *.rar situados en el disco actual

WinRAR t -r \*.rar


Orden U : actualizar los ficheros de un archivo

Esta orden, al igual que la orden f, actualiza ficheros en el archivo sólo si estos son anteriores a los ficheros que se están agregando. Sin embargo, a diferencia de "f", también agregará ficheros nuevos.

Es el equivalente en línea de órdenes a la orden Agregar al archivo con el modo de actualización "Agregar y actualizar los ficheros" del cuadro de diálogo Nombre y archivo y parámetros seleccionado.

Esta orden no se puede aplicar a los volumenes.

Consulte también: orden A : agregar a un archivo


Orden X : extraer ficheros de un archivo con las rutas de acceso completas

Extrae ficheros y carpetas con las rutas de acceso completas. La estructura de la carpeta, guardada en el archivo, se restablece por completo. Es el equivalente en línea de órdenes a la orden de manejo de archivo Extraer.

De forma similar a la orden e, esta orden puede extraer ficheros en la carpeta actual y en una carpeta especificada.

Por ejemplo, la orden:

WinRAR x Fonts *.ttf

extraerá los ficheros *.ttf del archivo Fonts en la carpeta actual; sin embargo, la orden:

WinRAR x Fonts *.ttf NewFonts\

extraerá los ficheros *.ttf del archivo Fonts en la carpeta NewFonts

Necesita utilizar la barra invertida final como en el ejemplo anterior para indicar la carpeta de destino.


Lista alfabética de modificadores

-- | detener el proceso de parámetros
-@[+] | desactivar [activar] listas de ficheros
-ac | borrar el atributo Archivo tras la compresión o extracción
-ad | agregar el nombre de archivo a la ruta de destino
-af<tipo> | especificar formato del archivo
-ag[formato] | generar el nombre de archivo usando la fecha y la hora actual
-ai | ignorar atributos de fichero
-ao | agregar los ficheros con atributo de Archivo
-ap<trayectoria> | establecer la ruta de acceso dentro del archivo
-as | sincronizar los contenidos del archivo
-cfg- | ignorar el perfil predeterminado y la variable de entorno
-cl | convertir los nombres de fichero a minúsculas
-cp<nombre> | seleccionar el perfil de compresión
-cu | convertir los nombres de fichero a mayúsculas
-df | eliminar los ficheros tras la compresión
-dh | abrir los ficheros compartidos
-dr | enviar ficheros a la papelera de reciclaje
-ed | no agregar carpetas vacías
-en | no agregar bloque de “final de archivo”
-ds | no ordenar ficheros
-dw | Limipar ficheros después de comprimir
-ep | excluir las rutas de acceso de los nombres
-ep1 | excluir de los nombres la ruta base
-ep2 | expande las rutas de acceso al máximo
-ep3 | expande las rutas de acceso al máximo incluyendo la letra de la unidad
-e[+]<atrib> | excluir o incluir ficheros con atributo <atrib>
-f | actualizar los ficheros
-hp[contraseña] | codificar datos y cabeceras
-ht[b|c] | selecccionar el tipo de algoritmo [BLAKE2,CRC32] para la suma de control
-iadm | solicitar acceso como administrador para el módulo SFX
-ibck | ejecutar WinRAR en segundo plano
-ieml[.][dirección] | enviar archivo por correo electrónico
-iicon<nombre> | especificar icono
-iimg<nombre> | especificar logotipo
-ilog[fichero] | registrar errores en fichero
-inul | desactivar los mensajes de error
-ioff | apagar el PC
-k | bloquear el archivo
-kb | conservar los ficheros dañados
-log[fmt][=nombre] | escribir nombres en fichero de registro
-m<n> | establecer el método de compresión
-ma[4|5] | establecer la versión del formato de archivo
-mc<par> | establecer los parámetros avanzados de compresión
-md<n> | selecciona el tamaño del diccionario
-ms[lista] | especificar los tipos de fichero a agregar
-mt<threads> | especificar número de procesos
-n<f> | filtro adicional de ficheros a incluir
-n@<lf> | leer máscaras de filtros adicionales desde fichero
-oc | establecer el atributo “comprimido” de NTFS
-oh | guardar enlaces fuertes como enlace en lugar de como fichero
-oi[-] | guardar ficheros identicos como referencias
-ol | guardar enlaces simbólicos como enlace en lugar de como fichero
-or | renombrar ficheros automáticamente
-os | guardar flujos de NTFS
-ow | procesar la información de seguridad del fichero
-o[+|-] | establecer el modo de sobreescritura
-p<ctña> | establecer la contraseña
-qo[-|+] | añadir información de acceso rápido [ninguna|forzar]
-r | activar la compresión recursiva
-r- | desactivar recursión
-r0 | sólo activar la recursividad en subcarpetas con nombres con comodines
-ri | establecer prioridad y tiempo de espera
-rr[N] | agregar el registro de recuperación de datos
-rv[N] | crear volúmenes de recuperación
-s | crear un archivo sólido
-s<N> | crear grupos sólidos utilizando la cuenta de fichero
-sl<tamaño> | procesar ficheros mas perqueños que el tamaño especificado
-sm<tamaño> | procesar ficheros mas grandes que el tamaño especificado
-sv | crear volúmenes sólidos independientes
-sv- | crear volúmenes sólidos dependientes
-sc<juego>[objetos] | Especificar el juego de carácteres
-se | crear grupos sólidos utilizando la extensión de fichero
-sfx[nombre] | crear un archivo auto extraíble
-s- | desactivar la compresión sólida
-t | comprobar ficheros después de archivar
-ta<fecha> | procesar ficheros modificados después de la fecha especificada
-tb<fecha> | procesar ficheros modificados antes de la fecha especificada
-tk | conservar la hora del archivo original
-tl | establecer como hora de archivo la del fichero más nuevo
-tn<tiempo> | procesar ficheros posteriores al tiempo especificado
-to<tiempo> | procesar ficheros anteriores al tiempo especificado
-ts<m,c,a> | guardar o restaurar fecha del fichero (modificación, creación, acceso)
-u | actualizar los ficheros
-v<n>[k|b|f|m|M|g|G] | crear volúmenes
-vd | borrar el contenido del disco antes de crear un volumen
-ver[n] | control de versiones de fichero
-vn | usar esquema de nombres de volumen antiguo
-vp | detenerse antes de cada volumen
-w<ruta> | establecer carpeta para ficheros temporales
-x<fichero> | excluir el fichero especificado
-x@<lista> | excluir ficheros listados en el ficheros <lista>
-y | Sí a todo
-z<fichero> | leer el comentario de archivo del fichero


Modificador -- : detener el proceso de parámetros

Este modificador indica a WinRAR que no existen más parámetros en la línea de órdenes. Podría ser útil si el nombre del archivo o el del fichero comenzase por el carácter '-'. Sin el modificador '--', a dicho nombre se lo trataria como si fuera un modificador.

Ejemplo:

agregue todos los ficheros de la carpeta actual al archivo sólido -StrangeName

WinRAR a -s -- -StrangeName


Modificador -@[+] - desactivar [activar] listas de ficheros

WinRAR trata los parámetros de la línea de órdenes que empiezan con el carácter '@' como listas de ficheros. Así de forma predeterminada WinRAR intenta leer la lista de ficheros de 'nombrefichero' cuando encuentra el parámetro '@nombrefichero'. Pero si existe el fichero '@nombrefichero' WinRAR interpreta el parámetro como el nombre de fichero '@nombrefichero' en vez de leer la lista de ficheros.

El modificador -@[+] permite desambiguar este comportamiento y determinar exactamente como procesar los parámetros que empiezan con el carácter '@'

Si usa -@ todos los parámetros de este tipo encontrados a continuación de este modificador serán considerados nombres de fichero y no listas de ficheros.

Si usa -@+ todos los parámetros de este tipo encontrados a continuación de este modificador serán considerados listas de ficheros y no nombres de fichero.

Este modificador no afecta a los parámetros anteriores.

Ejemplo

verificar el fichero comprimido '@casa'

WinRAR t -@ notes.rar @casa


Modificador -AC: borrar el atributo "Archivado"

El propósito para el que se diseñó este modificador es el de realizar copias de seguridad. Si se utiliza al comprimir, se borrará el atributo de fichero "Archivado" tras la compresión. Si se utiliza al extraer, WinRAR borrará el atributo "Archivado" de los ficheros extraídos.


Modificador -AD - añadir nombre de archivo a la carpeta de destino

Este modificador puede ser útil al descomprimir un grupo de archivos. Por defecto, WinRAR descomprime los ficheros de todos los archivos en la misma carpeta, pero con este modificador creará una carpeta separada para descomprimir cada archivo.

Ejemplo:

rar x -ad *.rar datos\

Para cada archivo descomprimido WinRAR creará una subcarpeta en ‘datos’.


Modificador -AF<tipo> - formato del archivo

Este modificador permite definir el tipo del nuevo archivo. El parámetro <Tipo> puede ser 'rar' o 'zip'.

Por ejemplo, 'winrar a -afzip arc' creará el archivo arc.zip.

Este modificador solo esta disponible en WinRAR. La versión RAR para consola no tiene capacidad para crear archivos ZIP.


Modificador -AG[formato] : generar un nombre de archivo usando la fecha y la hora actual

Añade una cadena de caracteres con la fecha actual al nombre de un archivo al crear o procesar un archivo. Útil para las copias de seguridad diarias.

El formato de la cadena de caracteres añadida se define con el parámetro de formato opcional o, en caso de que no exista dicho parámetro, con "YYYYMMDDHHMMSS". La cadena de caracteres del formato puede incluir los siguientes caracteres:

Y | año
M | mes
MMM | mes como cadena de texto (Ene, Feb, etc.)
W | un número de semana (la semana empieza el lunes)
A | día de la semana (el lunes es 1, el domingo es 7)
D | día del mes
E | día del año
H | hora
M | minutos (tratados como minutos si se encuentran después de la hora)
I | minutos (tratados como minutos independientemente de la posición de las horas)
S | Segundos
N | número de archivo (valor númerico empezando por 1). Al comprimir WinRAR busca otros archivos existentes con el mismo nombre y si los encuentra incrementa el número de archivo hasta encontrar un nombre de archivo único. El formato N no esta soportado al crear volumenes Al realizar operaciones distintas a la compresión como la extracción, WinRAR selecciona el archivo existente que precede al primer nombre de fichero no usado o establece N a 1 si no existe dicho archivo.

Cada uno de los caracteres de los formatos especificados representa solo un carácter añadido al nombre del archivo. Por ejemplo, use WW para insertar el número de semana con dos dígitos o YYYY para insertar el año en formato de cuatro cifras.

Si el primer carácter del formato es un signo ‘+’ entonces la fecha precederá al nombre del archivo en vez de ponerse al final.

La cadena puede contener texto opcional encerrado por los caracteres '{' y '}'. Este texto se insertará en el nombre del archivo.

El resto de caracteres se agregan al nombre de archivo sin cambios.

Si necesita procesar un archivo existente, tenga cuidado con el modificador –ag. Dependiendo del formato y del tiempo que haya transcurrido desde el uso anterior del modificador –ag, el nuevo nombre generado puede no coincidir con el anterior. En este caso WinRAR creará o abrirá un nuevo archivo en vez de procesar el archivo existente. Puede usar el modificador -log para escribir el nombre de archivo generado en un fichero y poderlo leer después desde el fichero.

Ejemplos:

  1. usar el formato predeterminado YYYYMMDDHHMMSS

WinRAR a -ag backup

  2. usar el formato DD-MMM-YY

WinRAR t -agDD-MMM-YY backup

  3. usar el formato YYYYMMDDHHMM

winrar a –ag+YYYYMMDDHHMM backup

  4. usar el formato YYYY-WW-A incluyendo la descripción de los campos

WinRAR a –agYYYY{año}-WW{semana}-A{dia_de_la_semana} backup

  5. usar el formato YYYYMMDD y un número de archivo. Permite generar nombres de fichero únicos aunque haya varios ficheros del mismo día

winrar a -agYYYYMMDD-NN backup


Modificador -AI - ignorar atributos de fichero

Al usar este modificador al extraer, RAR no establecerá los atributos de los ficheros a los almacenados en el archivo RAR. Esta opción mantiene los atributos asignados por el sistema operativo a los ficheros nuevos. Afecta a los atributos de archivado, sistema, oculto y solo lectura.

Solo está soportado para los formatos RAR y ZIP.


Modificador -AO : agregar los ficheros con conjunto de atributo "Archivado"

Modificador -AO : agregar los ficheros con atributo de "Archivado"

El propósito para el que se diseñó este modificador es el de realizar copias de seguridad. Si se utiliza al comprimir, sólo se agregarán al archivo aquellos ficheros que tengan el atributo de "Archivado" activado.

Ejemplo:

agregue todos los ficheros de la unidad C: con conjunto de atributo "Archivado" al 'f:backup' y borre el atributo Archivo de los ficheros

WinRAR a -r -ac -ao f:backup c:\*.*


Modificador -AP : establecer la ruta de acceso dentro del archivo

Modificador -AP<ruta> : establecer la ruta de acceso dentro del archivo

Al utilizar este modificador, la ruta de acceso definida se une a los nombres de fichero al agregar los ficheros a un archivo y se elimina al extraerlos.

Por ejemplo, si usted quiere agregar el fichero leame.txt a la carpeta DOCS\ENG del archivo release, debe ejecutar:

WinRAR a -apDOCS\ENG release leame.txt

o si desea extraer ENG en la carpeta actual:

WinRAR x -apDOCS release DOCS\ENG\*.*

Disponible solo para formatos RAR y ZIP.


Modificador -AS : sincronizar los contenidos del archivo

Si se utiliza este modificador al comprimir, los ficheros comprimidos que no están en la lista de los ficheros agregados en ese momento serán eliminados del archivo. Es aconsejable combinar este parámetro con -u para sincronizar los contenidos de un archivo comprimido y una carpeta.

Por ejemplo, una vez ejecutada la orden:

WinRAR a -u -as backup sources\*.cpp

el archivo backup.rar sólo contendrá ficheros *.cpp de la carpeta sources, el resto de los ficheros serán eliminados del archivo. Parece similar a crear un archivo nuevo, pero con una importante excepción: si no se modifica ningún fichero desde la última copia de seguridad, esta operación es mucho más rápida que la de crear un archivo nuevo.


Modificador -CFG- - ignorar el perfil predeterminado y las variables de entorno

Este modificador hace que WinRAR ignore las opciones especificadas en el perfil de compresión predeterminado, la variable de entorno RAR, la carpeta predeterminada, y la opción "Seleccionar archivos" en Organizar contraseñas. dialog


Modificador -CL : convertir los nombres de fichero a minúsculas

Al utilizar este modificador, las letras de los nombres de todos los ficheros extraídos de un archivo, agregados a un archivo, modificados o actualizados en un archivo, se convertirán en minúsculas. A veces, esto es útil al mover un archivo desde un sistema que no diferencia entre letras mayúsculas y minúsculas a otro sistema que si efectúa esa distinción, por ejemplo, al extraer en UNIX un archivo creado en DOS.

Ejemplo:

extraiga todos los ficheros de port.rar convirtiendo los nombres en minúsculas

WinRAR x -cl port


Modificador -CP<perfil> - seleccionar perfil de compresión

Con este modificador puede usar las opciones de compresión almacenadas en un perfil de compresión especifico. El parámetro <perfil> es el nombre del perfil de compresión definido en WinRAR. Si el perfil especifica la compresión de determinados nombres de fichero, WinRAR comprimirá tanto los ficheros especificados en el perfil como los que haya especificado también en la línea de órdenes. Si el perfil especifica el nombre del archivo comprimido este será usado al comprimir y en este caso no deberia especificar ningún nombre de archivo en la línea de órdenes.

Ejemplo

Comprimir los ficheros *.txt usando las opciones del perfil de compresión "Mis textos"

WinRAR a "-cpMis Textos" textos *.txt


Modificador -CU : convertir los nombres de fichero a mayúsculas

Al utilizar este modificador, las letras de los nombres de todos los ficheros extraídos de un archivo, agregados a un archivo, modificados o actualizados en un archivo, se convertirán en mayúsculas.

Ejemplo:

extraiga todos los ficheros de port.rar convirtiendo los nombres en mayúsculas

WinRAR x -cu port


Modificador -DF : eliminar los ficheros tras la compresión

Mueve ficheros al archivo. Este modificador combinado con la orden a ejecuta la misma acción que la orden m.


Modificador -DH : abrir los ficheros compartidos

Permite procesar ficheros abiertos por otras aplicaciones para escribir.

Este modificador puede ser peligroso ya que permite comprimir un fichero aunque puede que éste esté siendo modificado por otra aplicación. Utilícelo con mucho cuidado.

Si no se especifica este modificador, el procesamiento de los ficheros compartidos depende de la opción "Abrir los ficheros compartidos" del perfil de compresión predeterminado.

Ejemplo:

WinRAR a -dh dbf *.dbf


Modificador -DR - mover ficheros a la Papelera tras la compresión

Eliminar los ficheros originales después de comprimirlos enviandolos a la Papelera de Reciclaje.


Modificador -DS : no clasificar la compresión de ficheros

Modificador -DS : no ordenar ficheros

Este modificador sólo es importante para los archivos RAR sólidos. La razón de compresión en los archivos sólidos depende del orden de fichero. Por defecto, WinRAR ordena los ficheros que se van a agregar a un archivo sólido según su extensión. Usted puede desactivar esta opción utilizando el modificador -ds e intentar establecer una ordenación de ficheros mejor. Por regla general, los ficheros con datos similares se deben colocar muy próximos.

Ejemplo:

WinRAR a -s -ds tools *.com *.exe *.doc *.txt *.*

Los ficheros se agregarán con el siguiente orden: *.com, *.exe, *.doc, *.txt, el resto de tipos de fichero.

Nota:

También se puede utilizar el fichero rarfiles.lst para definir la ordenación de los ficheros en los archivos sólidos.


Modificador -DW - limpiar y eliminar ficheros tras la compresión

Eliminar ficheros después de comprimir. Antes de eliminarlos son sobreescritos con ceros para prevenir la recuperación de datos del fichero eliminado.

Por favor, tenga en cuenta que esta técnica esta diseñada para discos duros normales y puede no sobreescribir los datos del fichero original en discos de estado sólido como resultado del uso en estos discos de la tecnologia SSD wear leveling y otros sistemas de direccionamiento de datos mas complejos.


Modificador -ED - no nadir carpetas vacias

Modificador -ED - no añadir carpetas vacías

Este modificador indica que los registros de las carpetas no han de guardarse en el archivo. Al extraer el archivo, WinRAR creará las carpetas no vacías basándose en las rutas de los ficheros contenidos en él. La información de las carpetas vacías se pierde y todos los atributos de las carpetas no vacías excepto el nombre (derechos de acceso, flujos, etc ...) también se perderá. Use esta opción sólo si no necesita preservar dicha información.

Si -ed se utiliza en combinación con la orden m o la opción -df , WinRAR no eliminará las carpetas vacías.


Modificador -EN - no añadir bloque de "final de archivo"

No soportado en los archivos RAR 5.0.

Por defecto WinRAR añade un bloque de "final de archivo" al final de cada archivo nuevo o actualizado. Este bloque permite marcar de forma segura el final del archivo permitiendo que después de él se almacenen datos externos tales como firmas digitales. En algunos casos puede ser útil desactivar esta característica, por ejemplo, si el archivo va a ser transferido entre dos sistemas a través de algún medio poco fiable y al mismo tiempo el emisor añade nuevos ficheros al archivo, de forma que se asegure que la parte recibida del archivo no sea modificada en el otro extremo entre transferencias.

Este modificador no puede usarse con volúmenes ya que el bloque de final de archivo contiene información importante para el proceso correcto de los volúmenes.


Modificador -EP : excluir las rutas de acceso de los nombres

Con este modificador, se agregan a un archivo los ficheros sin incluir información sobre la ruta. El resultado de esto podría ser la existencia de un gran número de ficheros con el mismo nombre en el archivo.

Ejemplo:

comprima todos los ficheros *.bas del disco actual sin las rutas de acceso

WinRAR a -r -ep bsources \*.bas


Modificador -EP1 : excluir de los nombres la carpeta base

No guarda la ruta de acceso introducida en la línea de órdenes.

Ejemplo:

se agregarán todos los ficheros y las carpetas de la carpeta tmp al archivo test, pero la ruta presente en los nombres de los elementos comprimidos no incluirá 'tmp\'

WinRAR a -r -ep1 test tmp\*

Equivale a las órdenes:

cd tmp

WinRAR a -r ..\test

cd ..


Modificador -EP2 : expandir las rutas de acceso al máximo

Guarda las rutas del fichero completas (excepto la letra de la unidad y la barra invertida inicial) al comprimir.


Modificador -EP3 - expandir las rutas de acceso al máximo incluyendo la letra de la unidad

Este modificador almacena las rutas completas incluyendo la letra de la unidad si se usa al comprimir. Los separadores de unidad (dos puntos) se substituyen por signos de subrayado.

Si usa el modificador -ep3 al extraer, los signos de subrayado se substituirán por dos puntos y los ficheros extraídos se descomprimirán en el directorio y disco original. Si el usuario además especifica una carpeta de destino, será ignorada.

También convierte rutas UNC desde \\server\share a __server\share al comprimir y las restaura a su estado original al descomprimir.

Este modificador es útil para crear copias de seguridad de varios discos en un mismo archivo. Por ejemplo, puede ejecutar:

WinRAR a -ep3 -r backup.rar c:\ d:\ e:\

Para crear la copia de seguridad y:

WinRAR x -ep3 backup.rar

Para restaurarla.

Tenga cuidado al usar el modificador –ep3 y asegurese que el archivo no contiene ningún fichero malicioso. En otras palabras, uselo solo para descomprimir ficheros que haya creado usted mismo o alguien de su confianza. Esta opción permite sobrescribir cualquier fichero en cualquier parte de su ordenador incluyendo ficheros importantes del sistema y debe usarse solo para crear y restaurar copias de seguridad.


Modificador -E[+]<atrib> - excluir ficheros según sus atributos

Modificador –E[+]<atrib> - excluir ficheros según sus atributos

Específica la mascara para excluir o incluir ficheros por sus atributos. <atrib> es un número en formato decimal, octal (empezado por 0) o hexadecimal (empezado por 0x).

Por defecto, sin el signo ‘+’, este modificador define los ficheros a excluir. Si el resultado de realizar una operación Y entre <atrib> y los atributos del fichero es diferente de cero dicho fichero no será procesado.

Si el signo '+' esta presente entonces este modificador define los ficheros a incluir. Solo aquellos ficheros que tengan al menos uno de los atributos especificados en la mascara serán procesados.

También es posible usar los símbolos D, S, H, A y R en vez de sus valores numéricos para indicar carpetas, ficheros con el atributo de sistema, oculto, archivo y solo lectura respectivamente. El orden en que se especifiquen los atributos no tiene importancia.

Se permite el uso simultáneo de las dos formas de este modificador -e<atrib> y -e+<atrib> en la misma línea de órdenes.

Ejemplos:

1) comprimir solo las carpetas sin su contenido

WinRAR a -r -e+d carpetas

2) no comprimir ficheros ocultos y del sistema:

WinRAR a -esh ficheros

3) no extraer ficheros de solo lectura:

WinRAR x -er ficheros


Modificador -F : actualizar los ficheros

Se puede utilizar al extraer o al crear un archivo. La cadena de órdenes "a -f" equivale a la orden f. También puede utilizar el parámetro "-f" con la orden m.

Si se utiliza el modificador "-f" con la orden x o con la e, sólo los ficheros desfasados se reemplazarán con nuevas versiones extraídas del archivo. No se extraerán los ficheros comprimidos que carezcan del fichero descomprimido que les corresponda.

El modo de intérprete de órdenes equivalente a este modificador es la opción "Actualizar sólo los ficheros existentes" del cuadro de diálogo Nombre de archivo y parámetros y la opción "Actualizar los ficheros existentes" del cuadro de diálogo Ruta de extracción y opciones.

Soportado solo en los formatos RAR y ZIP.


Modificador -HP[ctña] - codificar cabeceras y datos

Este modificador es similar a -p[p], pero mientras que el modificador –p encripta solo el contenido de los ficheros y deja visible otra información como los nombres de fichero, la opción –hp encripta también todas las áreas sensibles incluyendo los datos de los ficheros, sus nombres, tamaños, atributos, comentarios y otros bloques proporcionando un nivel de seguridad mas alto.

Sin la contraseña es imposible ver ni siquiera la lista de los ficheros comprimidos en un archivo encriptado con -hp.

Ejemplo:

Añadir el fichero report.txt al archivo encriptado secreto.rar usando la contraseña 'fGzq5yKw'

rar a -hpfGzq5yKw secreto report.txt


Modificador -HT[B|C] - selecccionar el tipo de algoritmo [BLAKE2,CRC32] para la suma de control

Modificador -HT[C|S] - selecccionar el tipo de algoritmo [BLAKE2,CRC32] para la suma de control

La integridad de los datos de los ficheros en archivos RAR esta protegida por sumas de control calculadas y almacenadas para cada fichero almacenado.

Por defecto, WinRAR usa el algoritmo CRC32 para calcular la suma de control. El formato de archivo RAR 5.0 también permite seleccionar el algoritmo BLAKE2 además del CRC32.

specifique -htb para BLAKE2 y -htc para el algoritmo CRC32. Ya que CRC32 es el algoritmo predefinido, solo necesitará usar -htc para anular -htb en la configuración de WinRAR.

El tamaño de la suma CRC32 es de 32 bits. Mientras que las propiedades del CRC32 son adecuadas para detectar la mayoría de los errores unintencionados, no es suficientemente confiable como para verificar la identidad de un fichero. En otras palabras, si dos ficheros tienen el mismo CRC32, esto no garantiza que el contenido de los dos ficheros sea identico.

El tamaño de la suma BLAKE2 es de 256 bits. Siendo un algoritmo criptograficamente mas fuerte practicamente garantiza que si dos ficheros tienen la misma suma BLAKE2, su contenido es el mismo. La faceta de detección de errores de BLAKE2 es además mucho mas confiable que la del CRC32.

Debido a que el tamaño del valor BLAKE2 es mayor, el tamaño resultante del archivo también es ligeramente mayor al usar el modificador -htb.

Si las cabeceras de archivo no estan cifradas (no se usa el modificador -hp), las sumas de control en ficheros cifrados RAR 5.0 se modifican usando un algortitmo que depende de la contraseña para hacer imposible que se pueda adivinar el contenido del fichero basandose en la suma de control. No espere que estas sumas de control cifradas se parezcan a los valores habituales del cRC32 y BLAKE2.

Este modificador esta soportado solo para el formato RAR 5.0, así que es necesario usar también el modificador -ma.

-htb es el equivalente en la línea de ordenes de la opción Usar suma de control BLAKE2 en el cuadro de diálogo "Nombre de archivo y parámetros".

Ejemplo

añadir *.lst a lists.rar usando BLAKE2 para la suma de control de los ficheros

WinRAR a -ma -htb lists.rar *.lst


Modificador -IADM - solicitar acceso como administrador para el módulo SFX

Use -IADM si desea crear archivos SFX que soliciten acceso como administrador cuando se ejecuten en Windows Vista o versiones posteriores de Windows. Este modificador no cambia el comportamiento del archivo auto-extraíble en versiones anteriores de Windows.

Este modificador es el equivalente en la línea de órdenes de la opción "Solicitar acceso como administrador" en la ventana Opciones SFX avanzadas.

Ejemplo

WinRAR a -sfx -iadm instalar.exe c:\data


Modificador -IBCK : ejecutar WinRAR en un segundo plano

Minimiza WinRAR en la bandeja al comenzar una operación de proceso de archivo.

El modo de intérprete de órdenes equivalente a este modificador es la opción "Compresión en segundo plano" de la ventana Nombre de archivo y parámetros y la opción "Extracción en segundo plano" en la ventana de extracción.


Modificador -IEML [.][email] - enviar archivo por email

Modificador -IEML [.][email] - enviar archivo por correo

Adjunta el archivo creado o actualizado por la orden añadir a un correo electrónico. Para usar esta opción necesita tener instalado un programa de correo electrónico que soporte MAPI (la mayoría de los programas modernos soportan el interfase MAPI).

Puede especificar directamente la dirección de correo electrónico como parámetro de este modificador o dejarla en blanco, en cuyo caso se la preguntará su programa de correo electrónico.

Si añade un punto a –ieml, el archivo será eliminado después de haber sido enviado correctamente por correo electrónico.

Si usa este modificador al crear archivos multivolumen cada volumen será enviado en un mensaje separado.


Modificador -IICON<nombre> - especificar icono SFX

Permite especificar el icono a usar al crear o actualizar un archivo SFX. El parámetro <nombre> es el nombre de un fichero .ico. No debe comprimir el modulo SFX usando ningún tipo de compresor de ejecutables si va a usar este modificador.

Este modificador es la equivalente en la línea de comandos de la opción "Cargar icono SFX desde fichero" del diálogo Opciones SFX: Texto e icono.

Ejemplos:

  1. ñadir el contenido de la carpeta c:\misficheros al archivo SFX instalar.exe y usar c:\misiconos\ver1.ico como icono

WinRAR a -sfx -iiconc:\misiconos\ver1.ico instalar.exe c:\misficheros

  2. reemplazar el icono del archivo auto extraíble existente instalar.exe por el icono ver2.ico de la carpeta actual

WinRAR s -iiconver2.ico instalar.exe


Modificador -IIMG<nombre> - especificar logotipo SFX

Permite especificar una imagen de mapa de bits para mostrar como logotipo en el archivo SFX que se esta creando o actualizando. El parámetro <nombre> es el nombre del fichero .bmp. Si utiliza este modificador no debe comprimir el modulo SFX con ningún compresor de ejecutables.

Este modificador es el equivalente en la línea de órdenes de la opción “Cargar logotipo SFX desde fichero” del cuadro de diálogo Opciones SFX: Texto e icono .

El tamaño del logotipo por defecto es de 93x302 pixels. Se recomienda usar imágenes del mismo tamaño o inferior.

Ejemplo:

WinRAR a -sfx -iimgc:\imagenes\logo.bmp instalar.exe c:\misficheros

  1. Añadir el contenido de la carpeta c:\misficheros al archivo SFX instalar.exe y usar c:\imagenes\logo.bmp como el logotipo

WinRAR a -sfx -iimgc:\imagenes\logo.bmp instalar.exe c:\misficheros

  2. Cambia el logotipo en el archivo SFX ya existente instalar.exe por logo2.bmp que esta en la carpeta actual

WinRAR s -iimglogo2.bmp instalar.exe


Modificador -ILOG[nombre] - registrar errores en fichero

Registra los mensajes de error al fichero rar.log creado en la carpeta del WinRAR. Puede ver el contenido de este fichero usando la opción del menú “Ver registro …” del menú de opciones. Es posible especificar otro fichero de registro en vez del fichero predeterminado rar.log, por ejemplo, -ilogc:\log\backup.log. Si el nombre especificado no incluye una ruta el fichero de registro será creado en la carpeta %APPDATA%\WinRAR.

Si la opción "Registrar errores en fichero" del diálogo Opciones generales esta activada, los mensajes de error serán registrados en rar.log aunque no se haya especificado el modificador -ilog.

Por defecto, el fichero de registro usa codificación UTF-16 little endian, pero puede cambiarse con el modificador -sc<charset>g, por ejemplo, usando -scag para codificación nativa de un solo byte.


Modificador-INUL : desactivar los mensajes de error

Desactiva los mensajes de error de WinRAR.


Modificador -IOFF - apagar el PC

Apagar el PC después de terminar la operación. Su PC debe soportar la función de apagado por software.


Modificador -K : bloquear el archivo

Este modificador impide que WinRAR realice ninguna otra modificación en el archivo.


Modificador -KB : conservar los ficheros dañados

Este modificador impide que WinRAR elimine los ficheros dañados una vez realizada la extracción.


Modificador -LOG[fmt][=nombre] - escribe nombres en el fichero de registro

Este modificador permite escribir los nombres de archivo y ficheros al fichero de registro especificado en las operaciones de comprimir, extraer, eliminar y listar. Su comportamiento esta definido por la cadena 'fmt' que puede incluir uno o m'as de los siguientes carácteres:

A | Escribe nombres de archivo en el fichero de registro. Si RAR crea o procesa volumenes, todos los nombres de volumen se registran.
F | Escribe los nombres de los ficheros procesados en el fichero de registro. Incluye los ficheros añadidos y extraídos del archivo y los ficheros listados o eliminados del archivo.
P | Si ya existe un fichero de registro con el nombre especificado, añade los datos al fichero existente en vez de crearlo de nuevo.
U | Escribir datos en formato Unicode.

Si no se especifica 'A' ni 'F', se asume 'A'.

El parámetro 'nombre' permite especificar el nombre del fichero de registro. Debe estar separado de la cadena 'fmt' por el carácter '=' Si no se especifica 'nombre' WinRAR usará el nombre de fichero predeterminado rarinfo.log.

Se permite especificar varias opciones -log en la misma línea de ordenes

Esta opción es especialmente útil cuando se necesita procesar un archivo creado con las opciones -ag o -v en un archivo de proceso por lotes. Puede usar -loga=nombrearc.txt al crear el archivo y luego leer el nombre del archivo generado por RAR de nombrearc.txt con la orden adecuada. Por ejemplo, en archivos de procesos por lotes en Windows puede usar: set /p nombre=<nombrearc.txt.

Todas las funciones de este modificador estan soportadas solo en el formato RAR. En el caso del formato ZIP solo se soportan en las operaciones de compresión. Los otros formatos no soportan esta opción.

Ejemplos

  1. escribir nombres de los volumenes creados a listavol.txt

WinRAR a -v100m -loga=listavol.txt volumen.rar c:\datos

  2. escribir el nombre de archivo generado en Unicode en backup.txt

WinRAR a -ag -logau=backup.txt backup.rar misficheros\*

  3. escribir los nombres de los volumenes verificados en listavol.txt y los nombres de los ficheros verificados en listaficheros.txt

WinRAR t -log=listavol.txt -logf=listaficheros.txt volumen.part01.rar


Modificador -m<n> : establecer el método de compresión

Puede seleccionar un método apropiado de compresión escogiendo <n> desde 0 a 5.

-m0 | Almacenamiento | Agrega ficheros al archivo sin compresión
-m1 | El más rápido | El método más rápido (el que menos comprime)
-m2 | Rápido | Método rápido de compresión
-m3 | Normal | Método normal de compresión (predeterminado)
-m4 | Bueno | Buen método de compresión (más compresión)
-m5 | El mejor | El mejor método de compresión (el que más comprime, pero también el más lento)

Si no se especifica este modificador WinRAR utiliza por defecto el método "-m3" (Compresión normal).

También se puede seleccionar el método de compresión en la lista "Método de compresión" del cuadro de diálogo Nombre de archivo y parámetros.


Modificador -MA[4|5] - establecer la versión del formato de archivo

Por defecto WinRAR crea los archivos en formato RAR 4.x. Use -ma5 o solo -ma para crear archivos RAR 5.0. Use -ma4 si necesita cambiar el modificador -ma5 guardado en la configuración predeterminada y forzar RAR a usar el formato RAR 4.x.

Este modificador solo se usa al crear un archivo nuevo y se ignora al actualizar un archivo existente.

Ejemplo

Crear un archivo RAR 5.0 sólido comprimiendo la carpeta SrcDir con un diccionario de 64 MB:

WinRAR a -ma -md64m data SrcDir


Modificador -MC<par> - parámetros avanzados de compresión

Este modificador esta pensado principalmente para realizar pruebas de velocidad y compresión, en situaciones reales es mejor dejar que WinRAR seleccione los parámetros automáticamente. Por favor, tenga en cuenta que el uso inadecuado de este modificador puede degradar seriamente la velocidad y compresión, así que uselo solo si entiende perfectamente que es lo que va a hacer.

Este mnodificador tiene la siguiente sintaxis:

-mc[param1][:param2][modulo][+ o -]

donde <modulo> es un carácter que denota la parte del algoritmo de compresión que va a modificar. Puede tener los siguientes valores:

A | Compresión de audio;
C | Compresión de imágenes en color real (RGB);
D | Compresión delta;
E | Compresión de ejecutables Intel x86 32-bits;
I | Compresión de ejecutables Intel Itanium 64-bit;
T | Compresión de texto

El formato de archivo RAR 5.0 solo soporta los valores 'D' y 'E'.

El signo '+' al final del modificador aplica el modulo seleccionado a todos los datos procesados, ‘-‘ desactiva el modulo del todo. Si no especifica ningún signo, RAR escogerá los módulos automáticamente, basándose en los datos y el método de compresión actual. El modificador -mc- desactiva todos los módulos opcionales y permite solo el algoritmo general de compresión.

<Param1> y <Param2> son parámetros que dependen de cada modulo y que se describen a continuación.

Compresión Audio, compresión delta

<Param1> es el número de canales de un byte (puede ser 1 - 31).

RAR divide los canales multibytes en bytes, por ejemplo, dos canales de audio de 16 bits son considerados por RAR como cuatro canales de un byte cada uno.

<Param2> es ignorado.

Compresión de ejecutables Intel x86 de 32-bits, compresión de ejecutables Intel Itanium de 64-bits, compresión de imágenes de color real (RGB)

<Param1> y <Param2> son ignorados.

Compresión de texto

El algoritmo de compresión de texto proporciona un ratio de compresión notablemente mayor en datos de texto plano pero no puede usar varios núcleos del procesador eficientemente resultado en un tiempo de compresión mayor comparado con el algoritmo general en entornos multi-procesador o en procesadores con varios núcleos. Su velocidad de descompresión es también mas lenta que la del algoritmo general independientemente del número de núcleos del sistema. Este es el motivo por el cual esta opción esta desactivada de forma predeterminada. Puede especificar el modificador -mct para permitir que WinRAR use este algoritmo automáticamente cuando encuentre datos apropiados. El modificador -mct+ forzará el uso de este algoritmo para todos los datos.

El modificador -mct puede incluir también <Param1> y <Param2>, siendo su sintaxis completa -mc[param1][:param2]t[+ o -].

<Param1> es el orden del algoritmo PPM (puede ser 2 - 63).

<Param2> es la memoria en megabytes usada para el algoritmo PPM (1-128).

PPM usa la misma cantidad de memoria tanto para comprimir como para descomprimir, de forma que si especifica mucha memoria al crear el archivo puede tener problemas al descomprimirlo en equipos con menos memoria instalada. La descompresión seria aun posible usando memoria virtual, pero puede degradar considerablemente la velocidad de descompresión.

Ejemplo:

  1. el modificador -mc1a+ fuerza el uso de compresión para audio mono de 8 bits para todos los datos.
  2. el modificador -mc10:40t+ fuerza el uso del algoritmo de compresión para texto para todos los datos y establece el orden de compresión a 10 y un uso de 40MB de memoria.
  3. el modificador -mc12t establece el orden para la compresión de texto a 12 cuando esta sea usada, pero deja que RAR determine cuando usarla.
  4. el modificador -mct -mcd- activa la compresión de texto em modo automático y desactiva la compresión delta.


Modificador -MD<n>[k,m,g] : seleccionar el tamaño del diccionario

El diccionario móvil es un área de memoria que usa el algoritmo de compresión para encontrar y comprimir patrones de datos que se repiten. Si el tamaño del fichero que se está comprimiendo (o e tamaño total de los ficheros en el caso de un archivo sólido) es mayor que el tamaño del diccionario, entonces aumentando el tamaño del diccionario, generalmente aumentará la tasa de compresión, pero disminuirá la velocidad de compesión y se necesitará más memoria.

Para el formato RAR 4.x el tamaño del diccionario puede ser: 64 KB, 128 KB, 256 KB, 512 KB, 1MB, 2 MB, 4 MB.

Para el formato RAR 5.0 el tamaño del diccionario puede ser: 128 KB, 256 KB, 512 KB, 1MB, 2 MB, 4 MB, 8 MB, 16 MB, 32 MB, 64 MB, 128 MB, 256 MB, 512 MB, 1 GB.

Puede usar los modificadores 'k', 'm' y 'g' para especificar el tamaño en kilo, mega y gigabytes, como por ejemplo -md64m para un diccionario de 64 MB. Si no se especifica el modificador, se asume megabytes, así que -md64m y -md64 son equivalentes.

Al comprimir, WinRAR necesita cerca de seis veces mas memoria que el tamaño del diccionario, así que los tamaños 512 MB y 1GB solo están disponibles en la versión de WinRAR para 64 bits. Al descomprimir solo se requiere un poco mas que el tamaño del diccionario, así que tanto la versión de 32 como la de 64 bits pueden descomprimir archivos con cualquier tamaño diccionario incluyendo el de 1 GB.

WinRAR puede reducir el tamaño del diccionario si es significativamente mayor que el tamaño de los datos de origen. Esto ayudará a reducir los requerimientos de memoria sin disminuir la compresión.

Por defecto el tamaño del diccionario es de 4 MB para RAR 4.x y de 32 MB para el formato de archivo RAR 5.0.

Los archivos ZIP siempre se crean con un diccionario de 32KB.

El tamaño del diccionario también se puede seleccionar en la lista de "Tamaño del diccionario" del cuadro de diálogo Nombre de archivo y parámetros.

Ejemplo:

crear un archivo sólido en formato RAR 5.0 con un diccionario de 128 MB

WinRAR a -s -ma -md128 lib *.dll


Modificador -MS - especificar tipos de ficheros a almacenar

Modificador -MS[lista] - especificar tipos de ficheros a almacenar

Permite especificar los tipos de ficheros que serán almacenados sin compresión. Cuando se usa correctamente permite aumentar la velocidad de compresión sin perdida notable en la razón de compresión.

El parámetro opcional <lista> define una lista de extensiones separadas por punto y coma. Por ejemplo, -msrar;zip;jpg hará que WinRAR almacene sin compresión todos los archivos RAR y ZIP y las imágenes JPG. También es posible especificar mascaras de fichero en la lista, de forma que -ms*.rar;*.zip;*.jpg funcionará de la misma forma. Se permite el uso de varios modificadores -ms, como por ejemplo -msrar -mszip en vez de msrar;zip.

Si no se especifica el parámetro <lista> WinRAR usará un conjunto predefinido de extensiones que incluye los siguientes tipos:

7z, ace, arj, bz2, cab, gz, jpeg, jpg, lha, lzh, mp3, rar, taz, tgz, xz, z, zip


Modificador -MT<procesos> - establecer el número de procesos

El parámetro <procesos> puede tomar valores entre 1 y 32. Este modificador define el número máximo de hilos activos recomendado para el algoritmo de compresión, así como para los otros módulos de WinRAR que puedan usar varios hilos. Aunque WinRAR intenta seguir esta recomendación el número real de hilos puede superar el valor especificado.

Los cambios en el número de <procesos> afectan ligeramente la razón de compresión, de forma que archivos creados con opciones –mt diferentes no serán exactamente iguales incluso si las demás opciones de compresión son exactamente las mismas.

Si no se especifica el modificador -mt WinRAR intentará detectar el número de procesadores disponibles y seleccionará el número de procesos optimo automáticamente.


Modificador -N<fichero> - filtro adicional de ficheros a incluir

Aplica la máscara como filtro adicional a la lista de ficheros a incluir. Es posible utilizar comodines tanto en el nombre como en la ruta y puede especificar este modificador varias veces. Este modificador no reemplaza la forma usual de especificar los ficheros a procesar, es un filtro adicional que limita los ficheros a procesar a aquellos que coinciden con la mascara especificada en el modificador -n. A veces, puede ayudar a reducir la longitud de la línea de órdenes.

Por ejemplo, si quiere comprimir todos los ficheros *.txt y *.lst de las carpetas Proyectos e Info, puede usar:

WinRAR a -r texto Proyectos\*.txt Proyectos\*.lst Info\*.txt Info\*.lst

o usando el modificador -n:

WinRAR a -r -n*.txt -n*.lst texto Proyectos Info


Modificador -N@<lista> - leer máscaras de filtros adicionales desde fichero

Idéntico al modificador -n<fichero> , solo que lee la lista de mascaras del fichero <lista>.

Ejemplo:

WinRAR a -r -n@inclist.txt text Proyecto Info


Modificador -OC - Establecer atributo “Comprimido” de NTFS

Este modificador permite restaurar el atributo “Comprimido” de NTFS al extraer los ficheros. WinRAR almacena el atributo “Comprimido” de los ficheros al crear un archivo pero no lo restaura a menos que se especifique esta opción. La opción equivalente en el modo gráfico es la opción “Establecer atributo Comprimido” en la sección "Avanzada" del cuadro de diálogo de extracción.

Este modificador solo se soporta en archivos RAR.


Modificador -OH - guardar enlaces fuertes como enlace en lugar de como fichero

Si los ficheros a comprimir incluyen varios enlaces fuertes NTFS se almacena el primer enlace fuerte como un fichero normal y el resto de enlaces fuertes en el mismo conjunto como enlaces a este primer fichero. Al extraer estos ficheros, WinRAR creará enlaces fuertes en vez de ficheros normales.

No debe eliminar o renombrar el primer enlace fuerte del archivo una vez ha creado el archivo porque haría imposible la extracción de los siguientes enlaces. Si modifica este primer enlace todos los enlaces siguientes también tendrán el contenido modificado cuando se descompriman. El proceso de extracción requiere el primer enlace fuerte para poder crear los siguientes enlaces correctamente. Ssoportado solo para archivos RAR 5.0.

Este modificador es el equivalente en la línea de ordenes del grupo de opciones Almacenar enlaces simbólicos como enlaces del cuadro de diálogo "Nombre de archivo y parámetros".


Modificador -OI[-][:<tmínimo>] - guardar ficheros idénticos como referencias

Si se especifica este modificador WinRAR analiza el contenido de los ficheros antes de iniciar la compresión. Si se encuentran varios ficheros idénticos, el primer fichero se almacena como un fichero normal y el resto de ficheros se alamacenan como referencias al primero. Esto permite reducir el tamaño del archivo pero requiere algunas restricciones sobre el archivo resultante. No debe eliminar o renombrar el primer fichero identico en el archivo una vez el archivo ha sido creado porque esto haría imposible la extracción de los siguiente archivos que lo usan como referencia. Si modifica el primer fichero los ficheros siguientes también verán su contenido modificado una vez extraídos. El proceso de extracción requiere el primer fichero para poder crear los siguientes correctamente.

Se recomienda usar -oi solo si está comprimiendo muchos ficheros idénticos en un archivo que no va a modificar posteriormente y que va a extraer en su totalidad ni necesitar extraer descomprimir o omitir ficheros individuales. Si todos los ficheros idénticos son lo suficientemente pequeños para caber en el diccionario de compresión especificado con el modificador -md<n> , el modificador -s puede proporcionar una solución mas flexible que -oi.

El valor opcional <tmínimo> permite definir el tamaño mínimo de los ficheros. Los ficheros cuyo tamaño sea inferior a <tmínimo> no son analizados y no se consideran idénticos. Si este parámetro no esta presente, se asume como valor predeterminado 64 KB. Al seleciconar un valor pequeño para <tmínimo> se puede incrementar el tiempo requerido para detectar ficheros idénticos.

Soportado solo para archivos RAR 5.0.

Use -oi- if you wish to disable identical file processing enabled in WinRAR configuration.

Este modificador es el equivalente en la línea de ordenes del grupo de opciones Guardar ficheros idénticos como referencias del cuadro de diálogo "Nombre de archivo y parámetros".

Ejemplo:

Guardar el contenido de la carpeta actual en archive.rar. Almacenar ficheros idénticos mayores de 1000000 bytes como referencias.

WinRAR a -oi:1000000 -ma archive


Modificador -OL - guardar enlaces simbólicos como enlace en lugar de como fichero

Guarda los enlaces simbólicos y puntos de reanálisis NTFS como enlaces de forma que el contenido del fichero no se almacena. Estas entradas de archivo se restauran como enlaces simbólicos o puntos de reanalisis al descomprimirse. Soportado solo para archivos RAR 5.0 .

Podría necesitar ejecutar RAR como administrador para crear enlaces simbólicos al extraer..

Este modificador es el equivalente en la línea de ordenes del grupo de opciones Almacenar enlaces simbólicos como enlaces del cuadro de diálogo "Nombre de archivo y parámetros".


Modificador -OR - renombrar ficheros automáticamente

Si al extraer un fichero ya existe otro fichero con el mismo nombre y se ha especificado este modificador WinRAR lo renombrará automáticamente como ‘fichero(N).txt’, donde ‘fichero.txt’ es el nombre original del fichero y ‘N’ es un número.


Modificador -OS : guardar flujos NTFS

Este modificador sólo tienen sentido para el sistema de archivos NTFS y permite guardar flujos de datos alternativos asociados con un fichero. Puede necesitar usar este modificador al comprimir si usa algún programa que guarde datos en flujos alternativos y desee preservar estos flujos de datos.

Los flujos de datos no se guardan para ficheros NTFS cifrados.

El modo de intérprete de órdenes equivalente a este parámetro es la opción "Guardar los flujos de fichero" del cuadro de diálogo Nombre de archivo y parámetros.

Este parámetro sólo es aplicable a archivos RAR.


Modificador -OW : procesar la información de seguridad del fichero

Utilice este modificador para guardar la información de seguridad del fichero cuando esté comprimiendo y para restaurarla cuando esté extrayendo.

WinRAR almacena información del propietario del fichero, del grupo, de los permisos de fichero y de rastreo; pero sólo en los casos en los que usted disponga de los privilegios necesarios para leerla. Tenga en cuenta que el sistema de archivos NT (NTFS) es el único compatible con la seguridad basada en ficheros.

El modo de intérprete de órdenes equivalente a este modificador es la opción "Guardar los datos de seguridad del fichero" del cuadro de diálogo Nombre de archivo y parámetros.

Este modificador sólo es válido para archivos RAR.


Modificador -O[+|-] - establecer el modo de sobreescritura

Este modificador se puede usar tanto al extraer como al actualizar ficheros comprimidos. Están disponibles las siguientes opciones:

-o | Preguntar antes de sobreescribir (opción por defecto al extraer ficheros)
-o+ | Sobreescribir todos los ficheros (opción por defecto al actualizar ficheros comprimidos);
-o- | Omitir fichero existentes


Modificador -P<ctña> : establecer la contraseña

Determina una contraseña <ctña> para encriptar los ficheros durante la compresión o para desencriptarlos durante la extracción. La contraseña diferencia las letras mayúsculas de las minúsculas. Si omite la contraseña en la línea de órdenes, se le pedirá que la escriba.

En el modo de intérprete de órdenes, se puede introducir una contraseña a través del cuadro de diálogo Introducir la contraseña predeterminada o se puede introducir en el cuadro de diálogo Nombre de archivo y parámetros.

Ejemplo:

agregue el contenido de la carpeta "games" al archivo " secret", utilizando la contraseña ZaBaToAd

WinRAR a -pZaBaToAd -r secret games\*.*

Notas

  1. Si desea conseguir la máxima seguridad para sus datos no utilice una contraseña con menos de 8 caracteres o una que sea fácil de adivinar;
  2. No olvide su contraseña o perderá por completo sus datos.


Modificador -QO[-|+] - añadir información de acceso rápido [ninguna|forzar]

Los archivos RAR almacenan una cabecera para cada fichero que continene información como el nombre del fichero, la fecha, su tamaño y sus atributos inmediatamente antes de los datos del fichero descrito. Esta técnica es mas resistente a daños que almacenar todas las cabeceras de ficheros en un solo bloque continuo, que si es dañado o truncado destruye el contenido entero del archivo. Pero aunque son mas confiables, estas cabaceras de fichero esparcidas por todo el archivo son mas lentas de acceder si necesita tener abrir rapidamente el contenido del archivo en un entorno como la interface gráfica de WinRAR.

Para mejorar la velocidad al abrir archivos y evitar que el archivo entero sea vulnerable a un solo bloque dañado, los archivos RAR 5.0 pueden incluir un registro opcional de acceso rápido. Este registro se añade al final del archivo y contiene copia de los nombres de ficheros y otra información almacenada en un solo bloque continuo adicional a las otras cabeceras dentro del archivo. Al ser este bloque continuo su contenido puede leerse rapidamente sin la necesidad de efectuar una gran cantidad de operaciones de búsqueda en el disco. Si RAR detecta que esta información de acceso rápido esta dañada podrá acceder a leer las cabeceras individuales dentro del archivo de forma que la resistencia contra daños no se merma.

El registro de acceso rápido contiene una copia exacta de la cabecera de cada fichero, que puede llegar a ser de varias decenas o centenares de bytes por fichero, lo que incrementa el tamaño del archivo en la misma medida. Este aumento de tamaño se nota mas cuando hay muchos ficheros pequeños cuyo tamaño es comparable al tamaño de la cabecera. Así que por defecto, si no se especifica este modificador o se especifica -qo sin parámetros RAR almacena copias de las cabeceras solo para ficheros relativamente largos y continua usando cabaceras locales para ficheros perqueños. El tamaño límite puede depender de la versión de RAR. Esta técnica proporciona un balance razonable entre la velocidad de acceso y el tamaño del archivo. Si nprefiere obtener la máxima velocidad de acceso y no le importa el tamaño del archivo puede usar el modificador -qo+ para almacenar copia de todas las cabeceras de fichero. Si necesita tener el menor tamaño de archivo posible y no le importa la velocidad de acceso puede especificar -qo- para excluir la información de acceso rápido completamente.

Si quiere medir el efecto de este modificador en la velocidad asegurese que el contenido del archivo no se almacene en la caché de disco. Si el archivo esta en la caché no se realizan búsquedas en disco reales, haciendo que el acceso a las cabeceras de fichero sean rápidas incluso sin el registro de acceso rápido.

Este modificador es el equivalente en la línea de ordenes del grupo de opciones Información de acceso rápido en el cuadro de diálogo "Nombre de archivo y parámetros".


Modificador -R : procesar carpetas recursivamente

Activa la recursividad en las subcarpetas. Se puede utilizar con las órdenes: a, u, f, m, x, e, t, k, rr, c y s.

Al utilizarlo con las órdenes a, u, f ó m, se procesan los ficheros de todas las subcarpetas al igual que los de la carpeta en la que esté trabajando en ese momento.

Cuando se utiliza con las órdenes x, e, t, k, rr, c ó s, se procesan los archivos de todas las subcarpetas al igual que los de la carpeta en la que esté trabajando en ese momento.

Ejemplos:

1) Agregue el contenido de la unidad C al archivo Backup

WinRAR a -r Backup c:\*.*

2) Compruebe todos los archivos *.rar ubicados en el disco actual

WinRAR t -r \*.rar


Modificador -R- - desactivar recursión

Incluso sin usar el modificador -r/ WinRAR puede activar la recursión automáticamente en algunas situaciones. El modificador -r- prohibe totalmente la recursión.

Si especifica un nombre de carpeta al comprimir que no incluya comodines, por defecto RAR añade la carpeta recursivamente aunque no se haya especificado el modificador -r. Sucede lo mismo si se especifica la carpeta raíz de cualquier disco sin comodines. El modificador -r- desactiva este comportamiento.

Por ejemplo:

WinRAR a -r- arc carpeta

esta orden solo añadira la carpeta 'carpeta' vacia, ignorando todo su contenido. La siguiente orden:

WinRAR a -r- arc c:\

comprimirá solo el contenido de la carpeta raíz c: sin incluir sus subcarpetas.


Modificador -R0 : activar sólo la recursividad en subcarpetas con nombres con comodines

Modificador -R0 - activar recursividad solo para nombres con comodines

Es similar al modificador -r, sólo que al utilizarlo con las órdenes a, u, f, m activará la recursividad para las máscares de fichero que incluyan caracteres comodín como '*' y '?'.

Este modificador solo funciona para nombres de fichero. Los nombres de carpeta sin especificar el nombre de fichero, como por ejemplo 'nombrecarpeta', no se ven afectados por -r0 y su contenido se añade entero al archivo a menos que especifique también el modificador -r-.

Ejemplo

añadir todos los ficheros *.doc de la carpeta actual y sus subcarpetas y el fichero leame.txt sólo de la carpeta actual al archivo documentos.rar. Si hubises usado el modificador -r, WinRAR también buscaría ficheros leame.txt en las subcarpetas.

WinRAR a -r0 documentos.rar *.doc leame.txt


Modificador -RI<p>[:<s>] - establecer prioridad y tiempo de espera

Este modificador controla la carga del sistema que ejerce WinRAR. Los posibles valores para la prioridad <p> van de 0 a 15.

Si <p> es 0, WinRAR usará la prioridad por defecto. La prioridad 1 es la prioridad mas baja posible mientras que 15 es la mas alta.

El tiempo de espera <s> es un valor que puede ir desde 0 a 1000 (milisegundos). Este es el periodo de tiempo que WinRAR devuelve al sistema después de cada operación de lectura o escritura mientras comprime o descomprime. Los valores distintos de cero son de utilidad si desea reducir aún mas la carga del sistema que lo que le permite el parámetro <p>.

Ejemplo:

Ejecutar WinRAR con la prioridad por defecto y tiempo de espera de 10 ms:

WinRAR a -ri0:10 backup *.*


Modificador -RR[N] : agregar el registro de recuperación de datos

Este modificador se utiliza al crear o al modificar un archivo RAR para agregarle un registro de recuperación de datos que contiene <n> (n=1… 524288) sectores de recuperación. Usted también puede añadir <n> con el carácter de porcentaje o ‘p’ para especificar en por cientos el tamaño del registro de recuperación para el tamaño del archivo.

El modo de intérprete de órdenes equivalente a este modificador es la opción "Incluir el registro de recuperación" del cuadro de diálogo Nombre de archivo y parámetros.

Ejemplos:

a) Agregue todos los ficheros *.dbf al archivo WeeklyBackup desde la carpeta actual y agregue 8 sectores de registro de recuperación de datos

WinRAR a -rr8 WeeklyBackup *.dbf

b) Agregue todos los ficheros *.txt al archivo Books desde la carpeta actual y fije el tamaño del registro de recuperación en un 3% del tamaño total del archivo

WinRAR a -rr3p Books *.txt

Consulte también la descripción de la orden rr[N] y el tema registro de recuperación.


Modificador -RV[N] - crear volúmenes de recuperación

Este modificador puede usarse al crear archivos multivolumen RAR para generar volúmenes de recuperación. Su sintaxis es igual a la orden rv.


Modificador -S : crear un archivo sólido

Un archivo sólido es un tipo especial de archivo. La compresión sólida mejora considerablemente la razón de compresión a costa de la velocidad de actualización del archivo. Este modificador sólo se usa al crear un nuevo archivo RAR.

La opción equivalente en el modo de intérprete de órdenes a este modificador es la opción "Crear un archivo sólido" del cuadro de diálogo Nombre de archivo y parámetros.

Ejemplo:

agregue todos los ficheros *.c y *.h al archivo sólido Sources desde la carpeta actual

WinRAR a -s Sources *.c *.h

Consulte el capítulo Archivos sólidos para más información.


Modificador -S<N> : crear grupos sólidos utilizando la cuenta de fichero

Es similar a -s, pero reinicia las estadísticas de los sólidos tras comprimir <N> ficheros. Normalmente disminuye la compresión, pero también reduce las pérdidas de datos en caso de deterioro del archivo sólido.


Modificador -SC<juego>[objetos] - especificar el juego de carácteres

Modificador -SC<juego>[objects] - especificar el juego de carácteres

Este modificador permite especificar el juego de carácteres para las listas de ficheros, fichero de registro y comentarios de fichero.

El parámetro 'juego' es obligatorio y puede tener uno de los siguientes valores:

U | Unicode
A | Codificación de un solo byte nativa, que es ANSI para Windows
O | Código OEM (DOS)

Los ficheros en formato Unicode han de empezar por los carácteres Unicode FFFE o FEFF, en caso contrario WinRAR ignorará esta opción y procesara el fichero como texto ASCII.

El parámetro 'Objetos' es opcional y puede tener uno de los siguientes valores:

G | Fichero de registro producido por el modificador -ilog
L | Lista de ficheros
C | Comentario de fichero

Se puede especificar más de un objecto, por ejemplo, -scolc. Si no se especifica este parámetro, esta opción se aplica a todos los objetos.

Este modificador permite especificar el juego de carácteres para los ficheros de la opción -z<fichero>, listas de ficheros y comentarios de ficheros escritos por la orden cw.

Ejemplos:

  1. Leer nombres contenidos en 'lista' usando formato OEM:

WinRAR a a -scol data @lista

  2. Leer comentario.txt como fichero Unicode:

WinRAR c -scuc -zcomentario.txt data

  3. Guardar comentario.txt como fichero Unicode:

WinRAR cw -scuc data comentario.txt


Modificador -SE - crear grupos sólidos por la extensión

Parecido al modificador -s, pero reinicia las estadísticas sólidas cuando cambia la extensión de los ficheros. Normalmente reduce la compresión pero también reduce la perdida de datos en caso de daños.


Modificador -SL<tamaño> - procesar los ficheros de tamaño menor al especificado

Procesa solo los ficheros cuyo tamaño sea menor que el parámetro <tamaño> de esta opción. El valor <tamaño> debe espcificarse en bytes.

Solo esta soportado para formatos RAR y ZIP


Modificador -SM<tamaño> - procesar los ficheros de tamaño mayor al especificado

Procesar solo los ficheros cuyo tamaño sea mayor que el especificado en el parámetro <tamaño> de esta opción. El valor <tamaño> debe espcificarse en bytes.

Solo esta soportado para formatos RAR y ZIP


Modificador -SV - crear volúmenes sólidos independientes

Modificador -SV – crear volúmenes sólidos independientes

Por defecto WinRAR intenta reiniciar las estadísticas en la compresión sólida tan pronto como sea posible al empezar con un nuevo volumen pero solo si ya se comprimieron suficientes datos desde la última reinicialización (como mínimo algunos megabytes). Esta opción fuerza WinRAR a ignorar su funcionamiento normal e intenta reinicializar las estadísticas para volúmenes de cualquier tamaño. Esto reduce la compresión pero aumenta las probabilidades de recuperar datos de un volumen cuando alguno de los volúmenes anteriores estuviese dañado o perdido.

Tenga en cuanta que a veces WinRAR no puede reinicializar las estadísticas aunque se especifique esta opción. Por ejemplo, no lo puede hacer cuando se esta comprimiendo un fichero que ocupa mas de un volumen. WinRAR puede reiniciar estas estadísticas solo entre ficheros separados pero nunca dentro de un solo fichero.

Ignorada si no se están creando volúmenes sólidos.

También puede especificar esta opción en la variable de entorno RAR para usarla desde el entorno de line de órdenes.


Modificador -SV- - crear volúmenes sólidos dependientes

Desactiva la reinicialización de las estadísticas de compresión sólida entre volumen Este modificador incrementa la compresión pero reduce significativamente las probabilidades de extraer datos de un volumen si alguno de los anteriores se hubiese dañado o perdido.

Este modificador se ignora si es usada cuando no se crean volúmenes.

También puede especificar este modificador en la variable de entorno RAR para usarla desde el entorno de linea de órdenes.

Vea también: modificador -sv


Modificador -S- : desactivar la compresión sólida

De este modo, no utiliza la compresión sólida ni si quiera si se activó en el perfil de compresión predeterminado.


Modificador -SFX[nombre] : crear un archivo autoextraíble

Si se utiliza este modificador al crear un archivo nuevo, se creará un archivo autoextraíble (SFX). Por defecto, WinRAR utiliza el fichero Default.SFX para archivos RAR como su módulo auto extraíble y el Zip.SFX para archivos ZIP. Estos módulos deben ubicarse en la misma carpeta que winrar.exe. Se puede especificar un nombre alterno para el módulo auto extraíble en el parámetro "-sfx".

El modo de intérprete de órdenes equivalente a este modificador es la opción "Crear un archivo auto extraíbles" del cuadro de diálogo Nombre de archivo y parámetros.

Ejemplos:

a) Cree volúmenes sólidos auto extraíbles

WinRAR a -sfx -v360 -s Games

b) Cree un archivo utilizando el módulo WinCon.SFX

WinRAR a -sfxWinCon.SFX Gift.rar

Consulte también la orden s[nombre] .


Modificador -T - verificar ficheros después de comprimir

Verifica los ficheros después de comprimir. Este modificador es especialmente útil en combinación con la orden mover ya que así los ficheros solo serán eliminados si han sido correctamente comprimidos y verificados.


Modificador -TA<fecha> - process procesar ficheros modificados después de <fecha>

Modificador -TA<fecha> - procesar ficheros modificados después de <fecha>

Procesa solo los ficheros modificados después de la fecha especificada.

El formato de <fecha> es AAAAMMDDHHMMSS. Se permite el uso de separadores tales como '-' o ':' y también es posible omitir valores por la derecha. Por ejemplo, la siguiente versión es correcta: -ta2001-11-20. Internamente será procesada como -ta20011120000000 y tratada como "ficheros modificados después de las 0 horas 0 minutos 0 segundos del 20 de Noviembre de 2001".


Modificador -TB<fecha> - procesar ficheros modificados antes de <fecha>

Procesa solo los ficheros modificados antes de la fecha especificada.

El formato de <fecha> es AAAAMMDDHHMMSS. Se permite el uso de separadores tales como '-' o ':' y también es posible omitir valores por la derecha. Por ejemplo, la siguiente versión es correcta: -ta2001-11-20. Internamente será procesada como -ta20011120000000 y tratada como "ficheros modificados antes de las 0 horas 0 minutos 0 segundos del 20 de Noviembre de 2001".


Modificador -TK : conservar la hora del archivo original

Impide que WinRAR modifique la hora de archivo al cambiar un archivo.


Modificador -TL : establecer como hora de archivo la del último fichero

Establece como hora de archivo la del fichero más reciente del archivo. Obliga a WinRAR a establecer como hora de un archivo modificado la del fichero más reciente del archivo.


Modificador -TN<tiempo> : procesar los ficheros posteriores al tiempo especificado

Utilice este modificador para procesar sólo aquellos ficheros que sean posteriores al periodo de tiempo especificado. El formato de la cadena de tiempo es:

[<ndías>d][<nhoras>h][ <nminutos>m][<nsegundos>s]

Por ejemplo, utilice el modificador -tn15d para procesar los ficheros posteriores a 15 días y -tn2h30m para procesar los posteriores a 2 horas y 30 minutos.


Modificador -TO<tiempo> : procesar los ficheros anteriores al tiempo especificado

Utilice este modificador para procesar sólo aquellos ficheros que sean anteriores al periodo de tiempo especificado. El formato de la cadena de tiempo es:

[<ndías>d][<nhoras>h][ <nminutos>m][<nsegundos>s]

Por ejemplo, utilice el modificador -to15d para procesar los ficheros anteriores a 15 días y -to2h30m para procesar los anteriores a 2 horas y 30 minutos.


Modificador -TS<m,c,a>[N] - guardar o restaurar fecha del fichero (modificación, creación, acceso)

El modificador -tsm pide a WinRAR que guarde la fecha de modificación del fichero, -tsc - la fecha de creación y tsa - la fecha del último acceso.

PAra el formato de archivo RAR 4.x el parámetro opcional después de este modificador es un número entre 0 y 4 para controlar la precisión de la fecha. El valor '1' activa la precisión de 1 segundo, 2 - 0.0065536 segundos, 3 - 0.0000256 segundos y 4 o '+' activa la máxima precisión de NTFS, que equivale a 0.0000001 segundos. El valor '0' o '-' significa que la fecha de acceso y la de creación no se guardarán y que la fecha de modificación será guardada con baja precisión (dos segundos). Los modos de alta precisión añaden mas datos al archivos, hasta 19 bytes más por fichero con la combinación -tsm4 -tsa4 -tsc4. Si no se especifica la precisión WinRAR usará ‘4’ (alta precisión).

El formato de archivo RAR 5.0 guarda las fechas o bien con una precisión de 1 segundo para el valor del parámetro '1' o con la precisión mñaxima NTFS para '2', '3' y '4'.

Por defecto, WinRAR usa el modo -tsm4 -tsc0 -tsa0, de forma que solo se almacena la fecha de modificación.

Es necesario especificar los modificadores -tsc y -tsa si desea establecer las fechas de creación y acceso al descomprimir los ficheros (la precisión no es relevante pero debe ser diferente de 0). Por defecto WinRAR solo establece la fecha de modificación, incluso aunque el archivo contenga información sobre las fechas de creación y acceso. También puede hacer que WinRAR no establezca la fecha de modificación de los ficheros extraídos con el modificador -tsm-.

Es posible omitir la letra que indica el tipo de fecha si desea aplicar la misma opción a las tres fechas. Por ejemplo, -tsm4 -tsa4 -tsc4 puede reemplazarse por -ts4, -ts+ o -ts. Use -ts- para guardar solo la fecha de modificación con baja precisión o para ignorar todas las fechas al descomprimir.

Al crear un archivo, WinRAR automáticamente reduce la precisión a la soportada por el sistema de ficheros. El sistema FAT solo soporta una precisión de 2 segundos, Unix soporta 1 segundo y NTFS 0.0000001 segundos.

El sistema operativo limita que fechas pueden establecerse al descomprimir. Windows permite establecer las tres fechas, Unix permite establecer las fechas de modificación y acceso, pero no la de creación.

Ejemplos:

1) Guardar todas las fechas con la máxima precisión:

WinRAR a -ts backup

2) Restaurar las fechas de modificación y acceso. El modificador -tsm no es necesaria ya que WinRAR la usa por defecto:

WinRAR x -tsa backup

3) Guardar las fechas de modificación y creación con baja precisión. Sin -tsm1 WinRAR guardaría la fecha de modificación con alta precisión.

WinRAR a -tsm1 -tsc1 backup


Modificador -U : actualizar los ficheros

Se puede utilizar al extraer o al crear un archivo. La cadena de órdenes a -u equivale a la orden u. También puede utilizar el parámetro "-u" con las órdenes m .

Si se utiliza el modificadoro "-u" con las órdenes x ó e, los ficheros antiguos serán reemplazados sólo si las nuevas versiones, extraídas del archivo, son más recientes. Sin embargo, a diferencia del -f, un fichero comprimido será extraído de todos modos en caso de que éste carezca del fichero descomprimido correspondiente.

El modo de intérprete de órdenes equivalente a este parámetro es la opción "Agregar y actualizar los ficheros" del cuadro de diálogo Nombre de archivo y parámetros y la opción "Extraer y actualizar los ficheros" del cuadro de diálogo Ruta de extracción y opciones.

Soportado solo en los formatos RAR y ZIP.


Modificador -V<n>[k|b|f|m|M|g|G] : crear volúmenes

Crea volúmenes con tamaño = <n>*1000.

Por defecto, este modificador utiliza <n> como miles (1000) de bytes (no como 1024 x bytes). Usted también puede introducir el tamaño en kilbytes utilizando el símbolo 'k'; en bytes utilizando el símbolo 'b'; en megabytes utilizando 'm'; millones de bytes, 'M'; gigabytes, ‘g’; miles de millones de bytes, ‘G’; o seleccionar uno de los diversos valores predefinidos utilizando el símbolo 'f' seguido del valor numérico. Los valores predefinidos pueden ser 360, 720, 1200, 1440 ó 2880 y se reemplazan con el correspondiente tamaño de disquete. Si se omite el tamaño, se utilizará la auto detección.

Se permite entrar fracciones decimales usando el punto como separador decimal. Por ejemplo, -v1.5g significa 1,5 gigabytes.

Puede especificar varios parámetros -v para establecer diferentes tamaños para cada volumen. Por ejemplo:

rar a -v100k -v200k -v300k nombrearchivo

creará el primer volumen de 100 KB, el segundo de 200 KB, y el tercero y los siguientes de 300 KB.

En caso de que los volúmenes se hayan creado en un soporte extraíble, se le preguntará al usuario una vez creado el primer volumen:

¿Crear el siguiente volumen?: Sí/ No/ Crear todos

En ese momento, usted deberá cambiar los discos. Respondiendo 'Todos' hará que todos los volúmenes se creen sin ninguna pausa.

Por defecto los volúmenes RAR tienen nombres como 'nombrevol.partNNN.rar', donde NNN es el número del volumen. Para el formato de archivo RAR 4.x usando el modificador -vn es posible cambiar a otro esquema basado en la extensión donde el primer volumen de la secuencia tiene la extensión .rar y los siguientes se numeran del .r00 al .r99. Los archivos RAR 5.0 no soportan -vn ni el equema basado en la extensión.

Al extraer o comprobar un archivo multivolumen, debe utilizar únicamente el nombre del primer volumen. Si no existe ningún otro volumen en la unidad, ante el usuario aparecerá el siguiente indicador del sistema:

Introduzca el disco con <nombre del volumen siguiente>. Aceptar/ Cancelar

Introduzca el disco con el volumen correcto y haga clic en Aceptar.

Si no se encuentra el volumen siguiente durante la extracción, RAR anulará la operación con el mensaje de error:

No se puede encontrar <nombre del volumen>

No se deben modificar los volúmenes de archivo. No se pueden utilizar las órdenes d, f, u ó s con los conjuntos multivolumen. La orden a sólo se utilizará para la creación de un nuevo conjunto multivolumen.

Es posible, aunque poco probable, que el tamaño de fichero de un fichero incluido en un conjunto multivolumen sea mayor que su tamaño descomprimido. Esto se debe al hecho de que el 'almacenamiento' (no se trata de compresión si el tamaño aumenta) no se puede activar en el caso de los conjuntos multivolumen.

Los volúmenes de archivo pueden ser sólidos y/ o auto extraíbles.

El modo de intérprete de órdenes equivalente a este parámetro es el campo "Tamaño del volumen" del cuadro de diálogo Nombre de archivo y parámetros.

Ejemplo:

cree un volumen autoextraíble sólido con un tamaño de 1200000 bytes

WinRAR a -v1200 -s -sfx bitmaps


Modificador -VD : borrar el contenido del disco antes de crear un volumen

Al utilizar '-vd', se borrarán todos los ficheros y todas las carpetas del disco de destino antes de comenzar la operación de compresión. Si usted crea volúmenes, el borrado se realizará antes de la creación de cada volumen, dándole la oportunidad de comprimir en discos extraíbles que no estén vacíos. Debe asegurarse de que los discos no contengan ninguna información útil.

Este modificador sólo es aplicable a soportes extraíbles. No se podrá utilizar para borrar el disco duro.


Modificador -VER[n] - control de versión de ficheros

Obliga a WinRAR a almacenar las versiones anteriores de los ficheros al actualizarlos en un archivo existente. Las versiones anteriores se renombraran como ‘nombrefichero;n’, donde ‘n’ es el número de versión. Esta característica solo se soporta en archivos RAR.

Por defecto, al descomprimir un archivo sin el modificador –ver, WinRAR extraerá solo la ultima versión de cada fichero, cuyo nombre no incluye un sufijo numérico. Sin embargo, si especifica un nombre de fichero exacto incluyendo la versión, también esta será descomprimida. Por ejemplo, ‘rar x nombrearch’ solo descomprimirá las ultimas versiones, pero ‘rar x nombrearch fichero.txt;5’ descomprimirá ‘fichero.txt;5’, si esta presente en el archivo.

Si especifica el modificador –ver sin ningún parámetro, WinRAR descomprimirá todas las versiones de los ficheros que haya especificado. En tal caso el número de versión se conservará en el nombre de los ficheros extraídos. También puede extraer una versión concreta especificando su número como parámetro del modificador –ver para que WinRAR descomprima solo dicha versión y elimine el número de versión del nombre del fichero extraído. Por ejemplo, 'rar x -ver5 nombrearch' solo descomprimirá la quinta versión de cada fichero.

Si especifica el parámetro ‘n’ al comprimir se limitara el numero máximo de versiones de fichero que se almacenarán en el archivo. Las versiones viejas que excedan este número serán eliminadas.


Modificador -VN - usar el esquema antiguo para nombres de volúmen

Modificador -VN - usar el esquema antiguo para nombres de volumen

Por defecto los volúmenes RAR se nombran como 'nombrevol.parteNNN.rar', donde NNN es el número de volumen. Para el formato de archivo RAR 4.x usando el modificador -vn es posible utilizar otro esquema basado en la extensión para nombrar los volúmenes, donde el primer volumen de la secuencia tiene extensión .rar y los siguientes volúmenes tienen extensiones entre .r00 y .r99. Los archivos RAR 5.0 no soportan -vn ni el equema basado en la extensión.


Modificador -VP : detenerse antes de cada volumen

Modificadores -VP : detenerse antes de cada volumen

Por defecto, WinRAR sólo pide confirmación antes de procesar el siguiente volumen al comprimir en discos extraíbles y solo si el espacio disponible es menor que el tamaño del volúmen. Esta opción obliga a WinRAR a pedir siempre este tipo de confirmación al crear o extraer volúmenes. Puede ser útil si desea copiar cada volumen en otro soporte inmediatamente después de crearlo.


Modificador -W<ruta> - establecer carpeta para ficheros temporales

WinRAR necesita crear ficheros y carpetas temporales en algunas operaciones como por ejemplo cuando modifica archivos. Por defecto las crea en la carpeta especificada en el campo "Carpeta para ficheros temporales" en la página Rutas de la ventana de "Configuración". Cuando usa WinRAR desde la línea de ordenes puede modificar esta ruta con el modificador -w<ruta>.

Ejempl0:

usar la carpeta d:\tmp para los ficheros temporales al añadir un nuevo comentario a info.rar

WinRAR c -wd:\tmp -zcomment.txt info.rar


Modificador -X<fichero> : excluir el fichero especificado

Excluye el fichero especificado de la operación. Se pueden utilizar comodines tanto en la parte de la ruta como en la del nombre del fichero. Puede especificar el modificador -x varias veces en la misma línea de órdenes.

Si la mascara contiene comodines, se aplicará a la carpeta actual y a todas sus subcarpetas. Si no usa comodines el proceso no será recursivo de forma que la mascara "nombrefichero" solo excluye el fichero "nombrefichero" de la carpeta actual al comprimir o de la carpeta raíz del archivo al descomprimir.

Use "*\nombrefichero" para excluir "nombrefichero" recursivamente en todas las carpetas.

Por defecto, las mascaras que contienen comodines se aplican solo a ficheros. Si necesita que una mascara con comodines que excluya varias carpetas use la sintaxis especial de exclusión de carpetas. Estas mascaras empiezan con el carácter \. Por ejemplo, "*\tmp\" excluirá todas las carpetas del tipo "*tmp*" y "*\tmp" excluirá solo las carpetas llamadas "tmp". Al incluir comodines las dos mascaras se usarán con el contenido de la carpeta actual y todas sus subcarpetas. Las mascaras de exclusión de carpetas solo están soportadas en los formatos RAR y ZIP.

Si desea excluir solo una carpeta, especifique el nombre exacto de esa carpeta incluyendo su trayectoria relativa o absoluta pero sin usar comodines. En este caso no es necesario añadir el carácter separador de carpetas, que solo es necesario para mascaras de exclusión de carpetas con comodines para distinguirlas de las mascaras de exclusión de ficheros.

Ejemplos

  1. comprimir todos los ficheros excepto los ficheros*.jpg and *.avi de la carpeta actual y sus subcarpetas

WinRAR a -r -x*.jpg -x*.avi rawfiles

  2. comprimir todos los ficheros del disco c: excepto las carpetas temporals y los ficheros que hay en ellas

WinRAR a -r -x*\temp\ savec c:\*

  3. extraer todos los ficheros excepto los ficheros *.txt de docs.rar

WinRAR x -x*.txt docs


Modificador -X@<lista> : excluir ficheros listados en el fichero <lista>

Excluye ficheros cuyos nombres están presentes en la lista de fichero <lista>

Ejemplo:

agregue todos los ficheros *.exe, excepto aquellos cuyos nombres estén presentes en list.txt, al archivo bin

WinRAR a -x@list.txt bin *.exe


Modificador -Y : suponer Sí a todo

Modificador -Y : Sí a todo

Si se especifica este parámetro, Sí será la respuesta predefinida y automática a todas las preguntas.


Modificador -Z<fichero> : leer el comentario de archivo del fichero

Modificadoro -Z<fichero> : leer el comentario de archivo del fichero

Si se especifica este modificador con cualquier orden de actualización de archivo, se leerá un comentario de archivo del fichero y se agregará al archivo. Use este modificador con el modificador -sc si necesita especificar el juego de carácteres que usa el fichero con el comentario.

Ejemplo:

agregue todos los ficheros de la carpeta actual al archivo sólido Receipts con un comentario de archivo del fichero Receipts.diz

WinRAR a -zReceipts.diz -s Receipts


Lista de códigos de salida de WinRAR

WinRAR devuelve un código de salida cero (0) si la operación se ha realizado correctamente. Un código de salida distinto de cero indica algún tipo de error:

Código | Descripción
0 | Operación realizada con éxito.
1 | Advertencia. Ha ocurrido algún error no fatal.
2 | Ha ocurrido un error fatal.
3 | Suma de control inválida. Los datos esta dañados.
4 | Intento de modificación de un archivo bloqueado.
5 | Error de escritura.
6 | Error al abrir un fichero.
7 | Opción de la línea de órdenes incorrecta.
8 | Memoria insuficiente.
9 | Error al crear fichero.
10 | No se encontrarón ficheros coincidentes con la mascara y opciones especificadas.
11 | Contraseña incorrecta.
255 | Operación interrumpida por el usuario.


Configuración general

Cuadro de diálogo Configuración general

Para activar este cuadro de diálogo, seleccione la orden "Configuración…" del Menú Opciones y haga clic en "General". A continuación, se describe el contenido del cuadro de diálogo.

Sistema/ Prioridad baja

WinRAR utiliza este parámetro para regular la carga del sistema en un entorno multitarea. La prioridad predeterminada normalmente es la mejor opción, por tanto, no necesita activar esta opción. Sin embargo, si ejecuta WinRAR con frecuencia en segundo plano mientras trabaja en otras aplicaciones, quizá desee establecer la prioridad baja.

Sistema/Proceso paralelo

Si está activado, WinRAR usará la versión de proceso paralelo del algoritmo de compresión proporcionando la máxima velocidad en arquitecturas con mas de un procesador o con procesadores con más de un núcleo. Por defecto, esta opción esta activada si el número de procesadores reportado por el sistema operativo es mayor de uno, pero también es posible activarla manualmente incluso en ordenadores con un solo procesador.

Esta opción afecta no solo la compresión, si no también otras partes de WinRAR que pueden iniciar varios hilos. Normalmente el estado predeterminado propuesto por WinRAR es óptimo, así que en condiciones normales no necesitará cambiarlo.

Historial/Conservar el historial de los archivos

Por defecto, WinRAR conserva los nombres de unos pocos archivos abiertos recientemente en el Menú Fichero, de forma que usted pueda volver a acceder a ellos rápidamente. No obstante, si usted necesita desactivarla, por ejemplo, por razones de seguridad, puede desactivar esta opción.

También, cuando esta opción esta activada, WinRAR añade los archivos abiertos a la lista de documentos recientes de Windows, mientras que si está desactivada, Windows mantiene el mismo su lista de documentos recientes y en este caso puede que los archivos abiertos sean o no añadidos dependiendo de la versión de Windows y de su configuración.

Historial/Permitir historial en los diálogos

Algunos de los campos de entrada de datos en varios diálogos de WinRAR pueden recordar los valores anteriores (nombres de archivos, carpetas, etc ..) lo que permite recuperarlos de forma rápida. Esta opción puede ahorrarle tiempo pero al igual que la opción anterior, su seguridad puede ser cuestionable en entornos multiusuario. Si comparte su ordenador con otras personas desactive esta opción para mejorar su privacidad.

Barra de herramientas/Botones grandes

Escoja botones grandes (48x36 pixels) o pequeños (24x24).

Barra de herramientas/Mostrar los botones con texto

Muestra u oculta los títulos de los botones.

Barra de herramientas /Bloquear barra de herramientas

Evita que el usuario pueda mover o cambiar el tamaño de las barras de herramientas. Puede activar esta opción para evitar cambios accidentales en la posición y tamaño de las barras de herramientas una vez las ha ajustado a sus necesidades.

Barra de herramientas/Herramientas…

Abre el cuadro de diálogo que permite activar o desactivar la barra de herramientas principal de WinRAR, la pequeña barra adicional que contiene el botón "Arriba un nivel" y la barra de direcciones con la ruta o la información del archivo.

Barra de herramientas/Botones…

Haga clic en "Botones…" para abrir el cuadro de diálogo en el que puede especificar qué tipo de botones de la barra de herramientas aparecerá en pantalla.

Interfaz/Activar el Asistente al iniciar

Cambia al modo de Asistente al iniciar WinRAR.

Interfaz/ Activar el sonido

Permite a WinRAR emitir sonidos si se producen errores o si se terminan operaciones de larga duración.

Interfaz/ Mostrar el comentario de archivo

Muestra en pantalla la ventana de comentario si un archivo abierto contiene un comentario.

Interfaz/ Reutilizar la ventana existente

Si se intenta abrir un archivo nuevo ejecutando la orden "WinRAR <nombrearchi>" o haciendo clic en el icono de archivo y ya existe una ventana de WinRAR, el archivo se abrirá en esa ventana. Si no se activa esta opción, se abrirá una ventana nueva.

Interfaz/ Siempre visible

Sitúa la ventana de WinRAR por encima del resto de programas. Puede activarla si utiliza frecuentemente WinRAR como un objetivo donde arrastrar y colocar los objetos.

Interfaz/Barra de progreso estandard

Esta opción controla la apariencia de la barra de progeso en las ventanas de compresión y extracción. Si esta activada, WinRAR usará la barra de progreso estandard de Windows. Si esta desactivada usará la versión del WinRAR de la barra de progreso. Es razonable desactivar esta opción en versiones antiguas de Windows y dejarala activada en Windows Vista y versiones posteriores para mantener la nueva apariencia mejorada de los controles. Tenga en cuenta que que la barra de progreso estandard de Windows tiene solo dos colores por lo que no puede indicar el ratio de compresión actual, aunque este dato también se muestra fuera de la barra de progreso.

Interfaz/Barra de progreso en bandeja de tareas

Si esta opción esta activada, WinRAR mostrará el progreso total de la operación también en el icono de la bandeja de tareas. Esta opción solo esta disponible a partir de Windows 7 y por eso esta desactivada en versiones anteriores de Windows.

Registro/ Registrar los errores en el fichero

Escribe los mensajes de error y la información sobre los daños del archivo en el fichero rar.log situado en la carpeta %APPDATA%\WinRAR. Sólo se puede acceder a esta opción tras haber realizado el registro. Utilice la orden "Ver registro…" del Menú Opciones para visualizar el contenido del fichero de registro.

Registro/ Limitar el tamaño del fichero de registro a <nnn> KB

Permite restringir el tamaño del fichero rar.log producido por WinRAR. El valor mínimo permitido en los ficheros de registro es 50KB.


Configuración de la compresión

Cuadro de diálogo Configuración de la compresión

Para activar este cuadro de diálogo seleccione la orden "Configuración…" del Menú Opciones y haga clic en "Compresión". A continuación, se describe el contenido del cuadro de diálogo. Tenga en cuenta que se pueden especificar muchas de las opciones de compresión mediante el botón Perfiles de compresión/ Crear predeterminado.

Podrá encontrar más detalles sobre los diferentes parámetros de compresión en el tema Cómo escoger la configuración óptima de compresión.

Perfiles de compresión/Crear predeterminado

En el cuadro de diálogo que aparece en pantalla tras hacer clic en este botón, usted puede especificar los valores predeterminados para la mayoría de las opciones de compresión. Todas las secciones de este cuadro de diálogo disponen de ayuda en línea. Tan sólo haga clic en "Ayuda" para consultar la descripción detallada de las opciones en cualquier momento.

Las opciones introducidas en este cuadro de diálogo se almacenan en el perfil de compresión predeterminado, cuyo nombre es "Perfil predeterminado", y se restablecen automáticamente antes de cada operación de compresión.

Algunas opciones del perfil predeterminado de compresión no solo se utilizan al añadir ficheros al archivo si no también en otras operaciones que modifican el archivo como eliminar o renombrar ficheros. En este caso WinRAR lee solo aquellas opciones que son adecuadas para la operación en curso. La extracción no usa ninguna opción del perfil predeterminado de compresión.

Perfiles de compresión/Organizar

Abre el cuadro de diálogo para organizar los perfiles de compresión. En este cuadro de diálogo Organizar perfiles, usted puede eliminar perfiles existentes o corregir sus parámetros. Por ejemplo, puede renombrar un perfil o fijarlo como predeterminado. Consulte la ayuda en línea asociada a este cuadro de diálogo para más información.

Lista de tamaños de volumen/Definir tamaños de volumen …

Este botón activa el cuadro de dialogo Definir tamaños de volumen . Aquí puede personalizar la lista de tamaños de volumen predefinidos asociada al campo "Partir en volúmenes, tamaño" del cuadro de dialogo Parámetros y nombre de archivo .

Carpeta predeterminada

Si este campo no esta vacío y si un nombre de archivo no contiene una ruta de acceso completa, se creará un archivo en la carpeta especificada. Por ejemplo, si usted introdujo la ruta hasta el Escritorio, los archivos creados por WinRAR aparecerán en el Escritorio.

Si este campo está vacío y si un nombre de archivo no contiene una ruta de acceso completa, se crearán los archivos en la misma carpeta de los ficheros comprimidos.

En el modo de línea de ordenes la opción -cfg- desactiva la gran mayoría de opciones de WinRAR, incluyendo la carpeta predeterminada.

Carpeta predeterminada para extracción

Aquí puede introducir un nombre de la carpeta que se utilizará como base para construir la carpeta de destino en las órdenes Extraer sin pedir confirmación y Extraer los ficheros en la carpeta especificada. WinRAR construye la ruta de destino en estas órdenes de extracción fusionando la carpeta predeterminada con el nombre de archivo. Puede ser conveniente introducir aquí la ruta del Escritorio para que así usted pueda ver inmediatamente los datos descomprimidos en su Escritorio.

Al contrario que la carpeta predeterminada, la carpeta predeterminada para extracción no se usa en el modo de línea de ordenes ni al usar los menús contextuales.

Añadir nombre de archivo a la ruta

Controla si el nombre del archivo se añade al nombre de la carpeta por defecto cuando se construye la ruta de destino.

Eliminar carpetas redundantes de la ruta de extracción

Si esta opción esta activada y usted descomprime un archivo cuya carpeta raíz no tiene ningún fichero y contiene solo una subcarpeta y además la carpeta de destino es nueva o vacía y su nombre coincide con la carpeta a extraer, WinRAR omitirá una de las carpetas de la trayectoria final. WinRAR moverá los datos descomprimidos de una carpeta a otra y para que esta operación pueda realizarse correctamente la carpeta de destino no tiene que estar siendo usada por ningún otro programa hasta que finalice la extracción.

Por ejemplo, si usted tiene la carpeta ‘Textos’, la comprime usando la opción “Añadir a Textos.rar” del menú contextual , luego elimina la carpeta ‘Textos’ y luego descomprime el archivo Textos.rar usando la opción “Extraer a Textos” del menú contextual, sus ficheros se descomprimirán en la carpeta ‘Textos\Textos’ si no tiene activada la opción Eliminar carpetas duplicadas o en la carpeta ‘Textos’ si tiene esta opción activada.


Configuración de las rutas de acceso

Cuadro de diálogo Configuración de las rutas de acceso

Para activar este cuadro de diálogo seleccione la orden "Configuración…" del Menú Opciones y haga clic en "Rutas de acceso". A continuación, se describe el contenido del cuadro de diálogo.

Carpeta para ficheros temporales

WinRAR utiliza esta carpeta para crear ficheros temporales. Si este campo está en blanco, todos los ficheros y carpetas temporales se crearán en la carpeta actual o en la carpeta temporal de Windows, dependiendo del tipo de operación.

El valor inicial para este parámetro es la carpeta temporal de Windows. Si lo cambia y mas adelante quiere restaurar el valor original puede usar %temp% como nombre de carpeta y WinRAR lo convertirá automaticamente al nombre de la carpeta temporal de Windows antes de crear los ficheros temporales.

Carpeta para ficheros temporales/ Usar solo para discos extraíbles

Por regla general, es más rápido crear un archivo temporal en la carpeta actual cuando se trabaja con discos duros. Sin embargo, en el caso de discos externos lentos puede ser más eficaz crear un archivo en el disco duro y luego copiarlo en el disco externo. Para poner en práctica esta acción, debe introducir la Carpeta para ficheros temporales y la opción Usar solo para discos extraíbles.

La opción usar sólo para discos extraíbles afecta únicamente a aquellos comandos que implican modificaciones en los archivos. Otros comandos no se ven afectados por la misma, simplemente ignoran el tipo de disco actual.

Carpeta para ficheros temporales/ Examinar

Haga clic en este botón para seleccionar una carpeta temporal del árbol.

Carpeta de inicio

Usted puede introducir aquí una carpeta que será abierta cada vez que se inicie WinRAR. Tenga en cuenta que esta opción sólo tiene sentido si la opción Restablecer la última carpeta utilizada al iniciar está desactivada. De otro modo, se establecerá la última carpeta abierta.

Inicio/ Restablecer la última carpeta utilizada al iniciar

Si se activa esta opción, WinRAR restablecerá al ser ejecutado sin parámetros la última carpeta que se vio.

Inicio/ Examinar

Haga clic en este botón para buscar la carpeta de inicio.


Configuración de la lista de fichero

Cuadro de diálogo Configuración de la lista de fichero

Para activar este cuadro de diálogo seleccione la orden "Configuración…" del Menú Opciones y haga clic en "Lista de fichero". A continuación, se describe el contenido del cuadro de diálogo.

Tipo de lista (Ver la lista o Detalles)

Seleccione Ver la lista (varias columnas y sólo aparecen en pantalla los iconos de los ficheros) o Detalles (una única columna y proporciona información adicional de cada fichero sobre el tamaño, la fecha y el tipo). El modo predeterminado es Detalles.

Estilo de la lista / Mostrar con cuadrícula

Muestra cuadrículas en la lista de fichero.

Estilo de la lista / Seleccionar toda la fila

Utiliza el cursor de línea completa.

Ficheros / Mostrar primero los archivos

Muestra los archivos de la lista de fichero antes que el resto de ficheros independientemente del modo de clasificación seleccionado.

Ficheros / Permitir nombres con mayúsculas

Por defecto, WinRAR muestra en pantalla todos los nombres de fichero escritos con mayúsculas en minúscula. La activación de esta opción obliga a WinRAR a mostrar todos los nombres con el tipo original de letra.

Ficheros / Mostrar ficheros NTFS cifrados o comprimidos en color

Si esta activa esta opción WinRAR mostrará los ficheros con atributos NTFS ‘Comprimido’ o ‘Cifrado’ usando el mismo color que el Explorador de Windows. Por defecto estos colores son azul para ‘Comprimido’ y verde para ‘Cifrado’

Ficheros / Fusionar el contenido de los volúmenes

Si se ha activado esta opción y usted abre el primer volumen, WinRAR también intenta leer y mostrar en pantalla el contenido del resto de volúmenes disponibles en la misma carpeta que el primero. De este modo, en lugar de mirar sólo los ficheros del primer volumen, verá los que están incluidos en el primero y en los volúmenes siguientes.

Ficheros / Mostrar segundos

Muestra los segundos en las fechas de los ficheros. Sin esta opción activada WinRAR muestra las fechas con una precisión de un minuto.

Ficheros / Establecer el tipo de letra…

Selecciona el tipo de letra para la lista de fichero.

Selección

Aquí puede establecer estilos diferentes de selección con el ratón en la lista. Active "Un solo clic para abrir un objeto" si desea el estilo de selección de los buscadores de Internet. En este modo, también puede escoger si necesita subrayar los nombres de fichero. El modo predeterminado en WinRAR es "Doble clic para abrir un objeto"


Configuración del visor

Cuadro de diálogo Configuración del visor

Para activar este cuadro de diálogo seleccione la orden "Configuración…" del Menú Opciones y haga clic en "Visor". A continuación, se describe el contenido del cuadro de diálogo.

Tipo de visor

Selecciona la acción predeterminada cuando el usuario pulsa Intro sobre un fichero. Las acciones posibles son:

Visor interno | Usa el visor interno de WinRAR
Visor externo | Usa un visor externo. Deberá definir el nombre en el campo "Nombre del visor externo"
Programa asociado | Usa el visor de Windows predeterminado para el tipo de fichero
Preguntar | Pregunta al usuario qué tipo de visor desea cada vez tras pulsar Intro

Tenga en cuenta que esta configuración es ignorada para algunos tipos de ficheros. En el modo de gestión de ficheros se ignoran para archivos y ejecutables. Al pulsar Intro, WinRAR siempre intenta abrir los archivos y ejecutar los ficheros ejecutables. En el modo de gestión de archivo se ignoran para los tipos de ficheros especificados en la opción "Descomprimir todo para" en la ventana de configuración del visor. Al pulsar Intro sobre un fichero de este tipo, WinRAR extrae todo el contenido del archivo en una carpeta temporal, ejecuta el fichero, espera hasta que termine, actualiza el archivo fuente si es necesario y entonces elimina la carpeta temporal y todo su contenido. Esto proporciona el método práctico de instalar aplicaciones directamente desde archivos.

A diferencia de Intro, la orden Ver el fichero siempre abre un fichero en el visor interno de WinRAR.

Visor interno / Usar la codificación de DOS

Si el visor interno detecta que el contenido del fichero como Unicode UTF-8 o UTF-16 en formato little endian, entonces selecciona esta codificación automáticamente. Para el resto de ficheros no detectados como Unicode, la página de código actual se establece como texto de Windows si "Usar la codificación de DOS" esta desactivada y como texto de DOS si esta activada. También se puede modificar el código de página del fichero abierto en ese momento utilizando las órdenes "Ver como…" del menú "Ver" del visor interno.

Visor interno / Reutilizar la ventana existente

Si esta opción está desactivada, WinRAR crea una ventana separada de visor interno para cada fichero que se va a visualizar. Cuando la opción está activada, se reutiliza la ventana ya existente de modo que sólo se abre un ejemplo del visor.

Visor interno / Ajuste de línea

Cambia entre los modos de ajustar líneas demasiado largas y la visualización normal en el visor interno. Esta opción sólo afecta las nuevas ventanas del visor y no a las ya existentes.

Descomprimir todo para

Aquí puede definir mascaras de ficheros que requieren que se descomprima todo el contenido del archivo para poderse ver o ejecutar cuando el usuario pulsa Enter o hace doble click sobre uno de los ficheros que coincidan con estas mascaras. Por ejemplo, si este campo contiene "*.exe *.htm *.html", WinRAR descomprimirá todo el archivo antes de abrir un fichero ejecutable o un fichero HTML. Esta opción es necesaria para aquellos tipos de ficheros que necesitan acceso a otros ficheros contenidos en el archivo para poderse ejecutar o visualizar correctamente.

WinRAR ignorará la configuración "Tipo de Visor" para los ficheros definidos en "Descomprimir todo para " y siempre los abrirá usando el programa asociado.

Ignorar modificaciones para

Por defecto, WinRAR propone actualizar un archivo si el visor ha modificado un fichero abierto o ha creado nuevos ficheros, pero es posible desactivar este comportamiento. Puede especificar una o mas máscaras de fichero separadas por espacios en esta casilla y WinRAR no le preguntará si quiere actualizar el archivo si los ficheros creados o modificados por el visor coincide con alguna de estas máscaras.

En esta opción las máscaras pueden tener una sintaxis mas compleja, combinando máscaras de archivo y de fichero separadas por dos barras invertidas: mascarch\\mascfich. LAs máscaras pueden incluir la ruta limitando así los archivos y ficheros a carpetas especificas y a sus subcarpetas. Puede usar también variables de entorno en las rutas. Se permite omitir algunos de los componentes 'mascarch\\' o 'mascfich' se desea especificar todos los archivos o todos los ficheros.

Por ejemplo *.rar\\*.txt significa todos los ficheros .txt en todos los archivos .rar, *\\temp\* o solo temp\* significa todos los ficheros en carpetas 'temp' y %temp%\*\\* o %temp%\*\\ significa no actualizar ningún archivo en el directorio temporal de Windows.

Nombre del visor externo

Usted puede introducir aquí el nombre del programa que se utilizará como visor si establece la opción "Ejecutar el visor externo al pulsar Intro". Se pasará a este programa como parámetro único un nombre del fichero que se va a ver.


Opciones de seguridad

Cuadro de diálogo Opciones de Seguridad

Para activar este cuadro de diálogo seleccione “Configuración …” en el Menú Opciones y haga clic en la pestaña “Seguridad”. Las opciones de este cuadro de diálogo se describen a continuación.

Tipos de fichero a excluir de la extracción

Si activa esta opción, puede especificar una lista de ficheros potencialmente peligrosos. Puede especificar la lista de ficheros usando varias mascaras de fichero separadas por espacios. WinRAR omitirá cualquier fichero que coincida con alguna de las mascaras especificadas..

Esta opción puede ayudarle a protegerse de ficheros adjuntos infectados. Por ejemplo, si especifica:

*.scr *.pif *.exe

en este campo, no será posible extraer, ver o ejecutar ficheros .scr, .pif y .exe a través de WinRAR.

Limpiar ficheros temporales

Este grupo de opciones controla el modo de borrado de los ficheros temporales en la carpeta temporal de WinRAR generados al procesar archivos ya existentes. Esta involucrada en la operaciones del visor interno y externo, al ejecutar ficheros comprimidos o al descomprimir usando la función arrastrar y soltar.

Limpiar ficheros temporales/Nunca

Si selecciona "Nunca", los ficheros temporales se eliminan usando las funciones estandar de borrado del sistema y es posible que puedan ser recuperados con programas especiales. Esta es la forma más rápida pero menos segura de tratar los ficheros temporales.

Limpiar ficheros temporales/Siempre

Si selecciona "Siempre" antes de eliminar estos ficheros WinRAR los sobreescribirá con datos nulos para prevenir su posible recuperación. Es mucho mas seguro pero también notablemente mas lento.

Limpiar ficheros temporales/Solo encriptados

Si selecciona "Solo encriptados" los ficheros temporales se eliminan usando el método seguro y lento solo si WinRAR detecta un archivo que contenga estos ficheros protegidos con contraseña. En el caso contrario son eliminados de la forma rápida.

Notas para la opción "Limpiar ficheros temporales"

  • La operación de borrado seguro esta diseñada para discos duros normales y puede no sobreescribir correctamente los datos originales en discos de estado sólido como resultado del uso de la tecnologia SSD wear leveling y otras técnicas de direccionamiento de datos mas complejas.
  • Tenga en cuenta que si los ficheros temporales están todavia en uso, WinRAR no los eliminará inmediatamente. Cuando ejecute WinRAR de nuevo, todos los ficheros temporales no usados durante la última hora serán eliminados o limpiados.
  • Esta opción solo funciona con los ficheros temporales creados después de operaciones de extracción y puede no funcionar con otros tipos de ficheros temporales como los creados al modificar un archivo. Este tipo de ficheros siempre se eliminan usando el modo estandard de borrado rápido.

Preguntar por un programa antivirus

Esta opción modifica el comportamiento de la orden Buscar virus en el archivo. Por defecto esta activada, de forma que WinRAR pide siempre que seleccione un programa antivirus cuando esta activada la opción de búsqueda de virus. Si usted usa solo un antivirus, es posible omitir esta pregunta desactivando esta opción.


Configuración de la integración

Cuadro de diálogo Configuración de la integración

Para activar este cuadro de diálogo en WinRAR seleccione la orden "Configuración…" del Menú Opciones y haga clic en "Integración". El mismo conjunto de opciones también está disponible al instalar WinRAR, por tanto, se pueden cambiar las opciones descritas a continuación tanto durante la instalación como más tarde en la configuración de WinRAR.

Asociar WinRAR con (RAR, ZIP, CAB, ARJ, LZH, etc.)

Aquí puede seleccionar para qué tipo de formatos de archivo se registrará WinRAR como el visor predeterminado. Es una buena idea dejar estas opciones seleccionadas ya que le permitirá abrir los archivos en WinRAR con tan sólo pulsar Intro sobre un nombre de archivo o sobre un icono situado en el Explorador o en el Escritorio. Puede pulsar el botón “Seleccionar todos” para seleccionar rápidamente todos los formatos.

Extensiones definidas por el usuario

Aquí puede especificar extensiones de fichero adicionales para formatos soportados por WinRAR. Por ejemplo, si tiene ficheros en formato RAR con la extensión “.001”, puede introducir “001” en este campo para asociar WinRAR con estos ficheros y añadir las opciones de extracción al menú contextual que muestra Windows para los ficheros "001". Si necesita añadir mas de una extensión, sepárelas con espacios.

Interfaz / Incluir WinRAR en el Escritorio

Coloca el icono de WinRAR en el Escritorio.

Interfaz / Incluir WinRAR en el Menú Inicio

Añade el icono de WinRAR al Menú Inicio.

Esta opción añade el icono de WinRAR al primer nivel del Menú de Inicio clásico de Windows XP. Desde Windows Vista los programas no pueden añadirse ellos mismos al menú de Inicio, de forma que esta opción añade el icono de WinRAR a la lista "Todos los programas". puede usar la orden de Windows "Adjuntar al menú de Inicio" para añadir el icono al Menú de Inicio de Windows Vista o posterior.

Interfaz / Crear un grupo de programas WinRAR

Crea un grupo de programa WinRAR en el Menú Inicio/ Programas

Integración con Windows /Integrar WinRAR con el Explorador de Windows

Permite la utilización de menús contextuales y de la función "arrastrar y colocar" para manejar archivos WinRAR.

Integración con Windows/ Menús contextuales en cascada

Sitúa todos los elementos agregados por WinRAR a los menús contextuales de fichero o de archivo en un submenú.

Integración con Windows/ Iconos en los menús contextuales

Agrega iconos pequeños a los elementos añadidos por WinRAR a los menús contextuales de ficheros y de archivo.

Integración con Windows/Elementos del menú contextual

Permite escoger los elementos a mostrar en los menús contextuales del Explorador de Windows.


Perfiles de compresión

El perfil de compresión es un conjunto de distintas opciones de compresión que se pueden recuperar rápidamente antes de comenzar una operación de compresión. En lugar de especificar un tipo de archivo, un tamaño de volumen, un método de compresión y otras opciones cada vez que necesita hacer un nuevo archivo, puede crear varios perfiles almacenando opciones para sus operaciones habituales de compresión. Posteriormente puede seleccionar en el menú un perfil requerido para restablecer todas las opciones.

Los perfiles de compresión tienen nombre y éste aparece en la lista de perfiles. Es recomendable conferir nombres acertados a los perfiles, simplifica su uso posterior. Puede seleccionar un perfil en el cuadro de diálogo Nombre de archivo y parámetros. Tan sólo haga clic en "Perfiles", escoja un elemento que necesite en la lista desplegable y se restablecerán todas las opciones guardadas en el perfil. WinRAR proporciona algunos perfiles predefinidos, por ejemplo, para crear un fichero adjunto para correo y para realizar copias de seguridad de ficheros; sin embargo, usted puede eliminarlos si lo desea.

Existen dos formas de crear un perfil nuevo. Usted puede abrir el cuadro de diálogo "Nombre de archivo y parámetros", establecer las opciones deseadas, hacer clic en "Perfiles" y seleccionar el objeto de menú "Guardar la configuración actual en un nuevo perfil". El cuadro de diálogo Parámetros del perfil que aparece contiene el campo "nombre del perfil", donde usted deberá introducir un nombre para el nuevo perfil. En este cuadro de diálogo, también se puede acceder a algunas opciones de perfil. La opción más importante es "Establecer el perfil como predeterminado". Si la establece, se seleccionará automáticamente el perfil antes de cada operación de compresión y en otras operaciones que modifican archivos. Otras opciones permiten guardar los nombres de archivo y de fichero, crear un acceso directo en el Escritorio y ejecutar la compresión inmediatamente después de seleccionar un perfil. Consulte la descripción del cuadro de diálogo Parámetros de perfil para una información más detallada de estas opciones.

Otro método para crear un perfil nuevo consiste en hacer clic en "Crear predeterminado" del cuadro de diálogo Configuración de la compresión. En este caso, sólo necesitará establecer las opciones de compresión deseadas en el cuadro de diálogo que aparece y hacer clic en "Aceptar". El nuevo perfil creado con este método se convierte en el perfil predeterminado con el nombre "Perfil predeterminado". A diferencia del primero, este método no permite acceder a parámetros avanzados del perfil como almacenamiento de nombres de archivo y de fichero o creación de un acceso directo. Es cómodo para crear el perfil predeterminado sin preguntas adicionales. No obstante, utilice el primer método si necesita una mayor flexibilidad.

No puede modificar las opciones de compresión almacenadas en un perfil, pero sí puede cambiar los parámetros del perfil como, por ejemplo, su nombre o su estatus predeterminado. Para corregir los parámetros del perfil o para eliminar perfiles existentes, utilice la orden Organizar perfiles a la que puede acceder tanto desde el menú de perfiles del cuadro de diálogo "Nombre de archivo y parámetros" como desde el cuadro de diálogo "Configuración de la compresión". Puede designar un nuevo perfil como predeterminado o eliminar el estatus predeterminado de todos los perfiles utilizando esta orden.


Variable de entorno RAR

Los parámetros predeterminados se pueden agregar a la variable de entorno, RAR, utilizando la orden SET (establecer). Muchos de los parámetros especificados en esta variable sólo se utilizan al ejecutar WinRAR en el modo de línea de órdenes. Los parámetros -cl, -cu, -tk, -tl, -p se utilizan tanto en el modo de intérprete de órdenes como en el de línea de órdenes.

Ejemplo

La orden

SET RAR=-s -m5 -md1024

obligará a WinRAR a crear archivos sólidos utilizando la mejor compresión y un diccionario de 1024 KB al ejecutarlo en el modo de línea de órdenes.


Entradas del registro

En un entorno multi-usuario puede ser conveniente desactivar el acceso a ciertas funcionalidades de WinRAR por motivos de seguridad. Si necesita hacerlo deberá crear esta entrada en el registro de Windows:

HKEY_LOCAL_MACHINE\Software\WinRAR\Policy

o

HKEY_CURRENT_USER\Software\WinRAR\Policy

La entrada en HKEY_LOCAL_MACHINE tiene mayor prioridad que la entrada en HKEY_CURRENT_USER.

Esta entrada puede contener los siguientes valores:

Nombre | Tipo | Descripción
Menu | DWORD | Si es 0, desactiva el menú principal de WinRAR.
Settings | DWORD | Si es 0, desactiva el cuadro de diálogo "Opciones", y los botones y opciones del menú "Importar/Exportar configuración".
Password | DWORD | Si es 0, desactiva la posibilidad de cambiar la contraseña de compresión. Puede ser útil para evitar cifrar datos importantes.
OrgPasswords | DWORD | Si es 0, se desactiva el acceso a "Organizar contraseñas". No desactiva el acceso a las contraseñas previamente almacenadas usando esta ventana. Si quiere restringir el acceso a estas contraseñas debverá eliminarlas antes de establecer esta variable a cero.
Shutdown | DWORD | Si es 0, desactiva la opción "Apagar el PC al terminar" de forma que el usuario no pueda apagar el ordenador.

Tenga en cuanta que estas entradas no afectan a la versión de consola RAR (el ejecutable rar.exe), de forma que para mayor seguridad en un entorno multi-usuario puede ser útil eliminar rar.exe y dejar solo winrar.exe.

También puede cambiar la ubicación de la carpeta %APPDATA%\WinRAR especificando una nueva ruta a los ficheros adicionales de WinRAR modificando el valor "AppData" de la clave HKEY_CURRENT_USER\Software\WinRAR\Paths del Registro de Windows.


RARFILES.LST - establecer el orden de fichero en los archivos sólidos

Los ficheros de un archivo sólido se clasifican normalmente según su extensión. Se puede establecer un orden de fichero alterno utilizando un fichero especial, rarfiles.lst (deberá ubicarse en la misma carpeta que Winrar.exe on en la carpeta %APPDATA%\WinRAR). Ya se proporciona en el programa de distribución WinRAR, pero se puede personalizar para el conjunto de ficheros del usuario. Es un fichero de texto sin formato que define el orden de los ficheros cuando se crea un archivo sólido. El fichero rarfiles.lst puede contener nombres de fichero, caracteres comodín y una entrada especial: $default ($predeterminado). La entrada predeterminada define la colocación de los ficheros que no corresponden a otras entradas de rarfiles.lst en la lista de clasificación.

Trucos para mejorar la compresión y la velocidad de operación:

- Agrupe los ficheros similares si es posible;

- Coloque al principio los ficheros a los que acceda con frecuencia.

Normalmente las especificaciones de fichero colocadas al principio de la lista tiene mayor prioridad pero hay una excepción a esta norma. Si rarfiles.lst contiene dos especificaciones de forma que una englobe a la otra, la especificación mas restrictiva tendrá prioridad mas alta independientemente de su lugar el la lista. Por ejemplo, si la lista contiene *.cpp y f*.cpp (*.cpp engloba a f*.cpp, pero f*.cpp es mas restrictiva) entonces f*.cpp tendrá mayor prioridad que *.cpp.

Ejemplo:

este es un ejemplo simple de rarfiles.lst

file_id.diz

readme.*

*.doc

*.txt

*.hlp

*.inf

*.exe

*.dll

$default

*.rar


Módulos gráficos RAR y ZIP (Default.SFX y Zip.SFX)

Módulos gráficos auto extraíbles RAR y ZIP (Default.SFX y Zip.SFX)

Utilizando estos dos módulos, usted puede crear archivos auto extraíbles GUI (modo gráfico) para Windows.

Utilice el módulo Default.SFX para archivos RAR y Zip.SFX, para archivos ZIP.

WinRAR x64 también incluye WinCon64.SFX, que es una versiónde 64 bits de este módulo autoextraïble. Por defecto WinRAR x64 usara la versión de 32 bits pero puede seleccionar el módulo de 64 bits explicitamente en la ventana Opciones SFX: Módulo. El archivo SFX de 64 bits resultante solo funcionará en Windows x64.

Ambos modos son compatibles con órdenes simples de instalación. Tiene información detallada sobre su uso en los siguientes temas:

  • Módulos SFX gráficos: programación;
  • Módulos SFX gráficos: opciones de la linea de órdenes.

Notas

  1. Está permitido corregir recursos de Windows contenidos dentro de módulos auto extraíbles para adaptarlos a sus necesidades. Por ejemplo, puede que usted desee cambiar el tamaño de la ventana de inicio o añadirle alguna imagen. WinRAR no proporciona herramientas ni documentación para modificar recursos. Es un proceso bastante complicado y, si desea llevarlo a cabo, deberá poseer un editor de recursos y conocer su funcionamiento. No obstante, no necesitará corregir recursos si el diálogo de inicio del auto extraíble estándar le resulta adecuado. Si solo desea cambiar la imagen o el icono del auto-extraíble puede usar la pestaña "Texto e icono" de las Opciones SFX avanzadas dialog.
  2. Por defecto los códigos de retorno devueltos por el módulo autoextraíble son los mismos que los códigos de retorno de WinRAR. Es posible modificar este comportamiento on la orden SetupCode de forma que también devuelva el código de retorno del programa de instalación.


Módulos SFX gráficos: programación

Los módulos SFX gráficos de WinRAR soportan órdenes básicas de programación. Puede incluir estas órdenes en el comentario de archivo. Las órdenes soportadas se listan a continuación, puede hacer click en el nombre de la orden para ver su descripción detallada.

Delete | Eliminar un fichero antes de la extracción
License | Mostrar la licencia del programa
Overwrite | Especificar el modo de sobreescritura
Path | Establecer la cartpeta de extracción
Presetup | Ejecutar programa después de la extracción
SavePath | Recordar la carpeta de extracción
Setup | Ejecutar programa después de la extracción correcta de los ficheros
SetupCode | Esperar la finalización del programa de instalación y devolver su código de retorno
Shortcut | Crear un acceso directo a un fichero recien extraído
Silent | No mostrar la ventana de inicio
TempMode | Descomprimir en una carpeta temporal
Text | Añadir texto a la ventana de extracción
Title | Establecer el título del auto-extraíble
Update | Seleccionar el modo de actualización de ficheros

Aquí puede ver un ejemplo simple de una programación para un archivo auto-extraíble.


Módulos SFX gráficos: opciones de la linea de órdenes

Los Módulos SFX gráficos WinRAR soportan las distintas opciones de la linea de órdenes listadas a continuación.

Opción | Descripción
-d<trayectoria> | Establecer la carpeta de destino para los ficheros decomprimidos.
-p<pwd> | Especificar la contraseña para descifrar el archivo SFX.
-s, -s1, -s2 | Modo silencioso. El modificador -s es una abreviación de -s1. Tanto -s como -s1 ocultan la ventanta de inicio del módulo SFX y la ventana con el progreso de la descompresión. -s1 también oculta la ventana de la licencia. -s2 oculta la ventanta de inicio del módulo SFX pero no la ventana con el progreso de la descompresión.
-sp<par> | Define parámetros para pasar a la aplicación especificada en la orden Setup del módulo SFX.

Si necesita insertar unas comillas en algún parámetro use dos comillas consecutivas.


Módulo RAR para consola (WinCon.SFX)

Módulo auto extraíble RAR para consola (WinCon.SFX)

Utilizando este módulo, puede crear archivos auto extraíbles que se pueden extraer en modo texto en el símbolo de sistema de Windows. Este módulo no se puede ejecutar en MS-DOS.

WinRAR x64 también incluye WinCon64.SFX, que es una versiónde 64 bits de este módulo autoextraïble. Por defecto WinRAR x64 usara la versión de 32 bits pero puede seleccionar el módulo de 64 bits explicitamente en la ventana Opciones SFX: Módulo. El archivo SFX de 64 bits resultante solo funcionará en Windows x64.

Este módulo soporta los siguientes parámetros en la línea de órdenes:

-e Extraer del archivo (acción predeterminada)

-t Comprobar los ficheros de archivo

-v Listar detalladamente el contenido del archivo

-? Mostrar la ayuda

Los códigos de retorno devueltos por el módulo autoextraíble son los mismos que los códigos de retorno de WinRAR.


Preguntas más frecuentes

Preguntas listadas en estas FAQ (siglas en inglés para Preguntas más frecuentes)

P: Todavía no consigo entender cómo puedo utilizar WinRAR para extraer ficheros.

P: RAR incorpora varios "métodos" distintos de compresión. ¿Cuáles son las ventajas y las desventajas de cada uno y cuál recomendaría usted para el uso diario?

P: He oído hablar mucho sobre los archivos "sólidos". ¿Qué son y cómo puedo utilizarlos?

P: ¿Cómo puede extraer ficheros de un archivo RAR un usuario de mi sitio (sistema de correo electrónico, servidor FTP, etc.) si RAR es shareware y es necesario registrarse tras un periodo de evaluación de 40 días?

P: ¿Dónde puedo conseguir las últimas versiones de WinRAR?

P: Me apareció el mensaje de "error en la suma de control" mientras estaba extrayendo. ¿Qué significa?

P: Fui incapaz de extraer ficheros de un archivo sólido RAR multivolumen porque un volumen de archivo estaba dañado ¡Ayuda!

P: Olvidé mi contraseña, ¡ayúdenme, por favor!

P: ¿ Por qué WinRAR no elimina sus ficheros temporales en el directorio temporal de Windows ?

P: ¿ Por qué no usa WinRAR un diccionario de 4096 K para mi archivo ?

Preguntas y respuestas

P: Todavía no consigo entender cómo puedo utilizar WinRAR para extraer ficheros.

R: Consulte el tema Modos intérprete de órdenes y línea de órdenes. Contiene indicadores con las descripciones de varias formas diferentes de extraer ficheros.

P: RAR incorpora varios "métodos" distintos de compresión. ¿Cuáles son las ventajas y las desventajas de cada uno y cuál recomendaría usted para el uso diario?

R: Intenté responder a esta pregunta en el tema Cómo escoger la configuración óptima de compresión.

P: He oído hablar mucho sobre los archivos "sólidos". ¿Qué son y cómo puedo utilizarlos?

R: Por favor, consulte el tema Archivos sólidos

P: ¿Cómo puede extraer ficheros de un archivo RAR un usuario de mi sitio (sistema de correo electrónico, servidor FTP, etc.) si RAR es shareware y es necesario registrarse tras un periodo de evaluación de 40 días?

R: El archivo RAR de distribución contiene un servicio UnRAR gratuito, UnRAR.EXE, con el que todo aquel que lo desee puede extraer archivos creados por RAR sin necesidad de pagar una cuota de licencia. Como VENTAJA adicional, el código fuente de un UnRAR adaptable está disponible en http://www.winrar.es. Tenga en cuenta que el algoritmo RAR está patentado y no debe utilizar los recursos UnRAR para aplicar ningún método de ingeniería inversa.

P: Dónde puedo conseguir las últimas versiones de WinRAR

R: Visite la página oficial de WinRAR.

P: Me apareció el mensaje de "error en la suma de control" mientras estaba extrayendo. ¿Qué significa?

R: El fichero extraído está dañado bien debido a daños en el archivo bien a problemas con el disco duro. Si un archivo está dañado, pero incluye un registro de recuperación, puedes intentar repararlo, si no, será imposible restaurar los datos dañados. Ten en cuenta que, en el caso de un archivo sólido , se perderán todos los ficheros situados detrás de un fichero dañado.

P: Fui incapaz de extraer ficheros de un archivo sólido RAR multivolumen porque un volumen de archivo estaba dañado ¡Ayuda!

R: Si dispone de volumenes de recuperación para su archivo, pongalos en la misma carpeta que los volumnes RAR y haga doble click en el primer volumen de recuperación (extensión/fichero REV) para iniciar el proceso de recuperación.
Si no dispone de volumenes de recupración o si no le han sido de ayuda trate de usar la funcionalidad de Repara en el volumen dañado. Luego renombre el volumen recuperado fixed.nombrevolumen.rar (o rebuilt.nombrevolumen.rar si no se encontro el registro de recuperación) al nombre actual del volumen y trate de iniciar de nuevo el proceso de descompresión empezando desde el primer volumen.
Si quiere aumentar las posibilidades de que sus archivos multivolumen RAR se pueden recuperar en caso de sufrir daños, use el registro de recuperación y volumenes de recuperación al crearlos y tarte de no usar compresión sólida, incluso cuando hacerlo pueda proporcionar una razón de compresión menor.

Si tienes un volumen dañado de archivo sólido, intenta repararlo. Ayuda el haber utilizado la recuperación RAR al crear el archivo. Puedes comprobar la existencia de un registro de recuperación en el archivo utilizando la orden Mostrar información. Renombra el volumen recuperado, *.nombrearc (si no se utilizó la recuperación, WinRAR sólo construye _reconst.rar) como el nombre del volumen actual e intenta descomprimir tu archivo de nuevo comenzando por el primer volumen.

P: Olvidé mi contraseña, ¡ayúdenme, por favor!

R: La codificación WinRAR no tiene ninguna salida de escape. Incluso si yo me olvido de la contraseña de cualquiera de mis archivos, no podré restaurarlos. Así que, por favor, no me pidáis ayuda en esos casos.

P: ¿ Por qué WinRAR no elimina sus ficheros temporales en el directorio temporal de Windows ?

R: Esto sucede cuando usted usa arrastrar y soltar para extraer ficheros o abrirlos con un visor externo. En estos casos es posible que estos ficheros estén en uso al cerrar WinRAR y lo que es peor, WinRAR no puede determinar si el programa externo aun necesita dichos ficheros. Es por este motivo que WinRAR no elimina los ficheros temporales inmediatamente. La próxima vez que use WinRAR los ficheros temporales extraídos no usados durante más de una hora serán eliminados.

Si no desea usar el directorio temporal cuando descomprima ficheros, use o bien la opción “Extraer a” de entorno del WinRAR o del menú contextual en vez de usar arrastrar y soltar.

P: ¿ Por qué WinRAR no usa el diccionario de 4096 K en mi archivo ?

R: Aunque haya seleccionado un tamaño de diccionario de 4096 K en las opciones de compresión, WinRAR puede disminuir automáticamente este valor cuando crea un nuevo archivo si el tamaño total de los datos a comprimir es como mínimo dos veces inferior al tamaño del diccionario. Esta característica no afecta a la compresión y permite reducir el uso de la memoria.


Consejos

Cómo instalar una aplicación desde un archivo

Puede instalar o ejecutar una aplicación directamente desde el archivo. Simplemente entre en un archivo y pulse Intro sobre el programa setup.exe o el install.exe. Al pulsar Intro sobre un fichero comprimido con extensión .exe, WinRAR extrae todo el contenido del archivo en una carpeta temporal y entonces ejecuta el fichero ejecutable. Cuando el ejecutable ha terminado, WinRAR comprueba la hora de modificación de los ficheros extraídos y si resultaron modificados algunos ficheros o si se crearon ficheros nuevos. En caso de que eso sucediese, se ofrece para actualizar el archivo y entonces elimina la carpeta temporal y su contenido.

Si usted quiere utilizar WinRAR para manejar archivos, pero un programa externo modificó las asociaciones de archivo

Algunos programas pueden registrarse a sÍ mismos como visor de archivo predeterminado incluso sin pedir confirmación. Si esto ocurre y usted desea volver a registrar WinRAR, seleccione el objeto "Configuración…" del menú Opciones, active el Cuadro de diálogo Configuración de la integración, seleccione los formatos de archivo que quiere asociar con WinRAR y pulse Intro.

Cómo instalar WinRAR en modo oculto

Si necesita instalar WinRAR en un gran número de ordenadores, responder a las preguntas de instalación una y otra vez puede resultar aburrido. En ese caso, puede ejecutar la instalación de WinRAR con el parámetro -s para omitir todas las preguntas y utilizar la configuración predeterminada.


ACUERDO DE LICENCIA DE USUARIO FINAL

El siguiente acuerdo de licencia es una traducción del acuerdo original, escrito en inglés en incluido en la versión inglesa de WinRAR. En caso de errores o ambigüedades en la traducción prevalecerán siempre los términos originales de la versión inglesa.

El siguiente acuerdo acerca de el compresor RAR (y su versión para Windows - WinRAR) - en adelante el "programa" - se establece entre win.rar GmbH - en adelante el "licenciador" - y cualquiera que instale, acceda o de alguna otra forma use el programa - en adelante el "usuario".

  1. El autor y propietario de los derechos de copia del programa es Alexander L. Roshal. El licenciador y como tal el emisor de la licencia y titular de los derechos de uso a nivel mundial, incluyendo los derechos de reproducir, distribuir y hacer que el programa este disponible al público en cualquier forma es win.rar GmbH, Schumannstr. 17, 10117 Berlín, Alemania.

  2. El programa se distribuye bajo el sistema pruebe antes de comprar. Esto significa que cualquiera puede usar el programa durante un período de prueba máximo de 40 días sin coste alguno. Al finalizar este período de prueba, el usuario DEBE comprar una licencia para continuar usando el programa.

  3. La versión de prueba puede ser distribuida libremente, a excepción de los siguientes casos, siempre que el paquete de distribución original no sea modificado en forma alguna.

    1. Nadie puede distribuir partes separadas del paquete original, a excepción de los componentes de UnRAR, sin autorización previa por escrito.

    2. La versión de prueba no licenciada no puede distribuirse dentro de ningún paquete de distribución de otro programa sin autorización previa por escrito. El programa debe permanecer en su fichero de instalación original sin modificar para descarga sin ningún tipo de impedimento ni condiciones para el usuario final como pagos por la descarga o hacer que la descarga sea condicionada a la entrega por parte del usuario de sus datos de contacto.

    3. El fichero de instalación no modificado de WinRAR se ha de proporcionar original e independiente. Cualquier inclusión en otro paquete está prohibida. En particular el uso de programas de instalación o descarga que proporcione cualquier tipo de descargas conjuntas esta prohibido si no esta autorizado por escrito por win.rar GmbH.

    4. El distribuidor de la versión de prueba no puede incluir, indicar o referir ningún tipo de hacks, cracks, llaves o generadores de llaves.

    5. En caso de violación de las condiciones anteriores el permiso para su distribución finaliza inmediatamente y de forma automática.

  4. La versión de prueba del programa puede mostrar una ventana de recordatorio de registro. Dependiendo de la versión y configuración del programa esta ventana puede contener tanto un texto predefinido y enlaces cargados localmente o bien una página web cargada desde Internet. Dicha página web puede contener instrucciones de registro u otros materiales de acuerdo con las preferencias del licenciador, incluyendo publicidad. Al abrir una página web el programa transfiere solo aquellos parámetros que se requieren técnicamente por el protocolo HTTP para abrir correctamente una página web en un navegador.

  5. El programa se distribuye "tal como es". No se expresa ni implica ninguna garantía. Lo utiliza bajo su propia responsabilidad. Ni el autor ni el licenciador se hacen responsables de perdidas de datos, daños, perdida de beneficios o cualquier otro tipo de pérdida derivada del uso correcto o incorrecto de este programa.

  6. Existen dos tipos básicos de licencia para el programa, que son:

    1. Licencia de uso para un sólo ordenador. El usuario compra una licencia para usar el programa en un SOLO ordenador.

      Los usuarios domésticos pueden usar su licencia de uso en todos los ordenadores y dispositivos móviles que sean de su propiedad.

      Los usuarios profesionales necesitan una licencia por cada ordenador o dispositivo móvil donde tengan instalado el programa.
    2. Licencia de uso múltiple. El usuario compra un número de licencias de uso para su propio uso o el de sus empleados, en el mismo número de ordenadores o dispositivos móviles (discos USB, discos duros externos, etc.) que sean propiedad del propietario de la licencia.

      En un entorno de red (servidor/cliente) debe adquirir una licencia para cada cliente individual (estación de trabajo) en que se instale, use o acceda al programa. Se necesita una copia individual de la licencia en cada cliente (estación de trabajo) independientemente de si los clientes (estaciones de trabajo) pueden usar el programa simultáneamente o en periodos de tiempo diferentes. Si tiene, por ejemplo, 9 clientes diferentes (estaciones de trabajo) en su red con acceso al programa, tiene que comprar 9 licencias.

    El usuario que ha comprado una licencia obtiene el derecho no exclusivo para usar el programa en tantos ordenadores como permita los términos expresados anteriormente según las licencias compradas, para cualquier uso legal.

  7. No hay ningún tipo de coste adicional, excepto el coste de compra de la licencia, asociado con la creación y distribución de archivos RAR, volúmenes, archivos auto extraíbles o volúmenes auto extraíbles. Los propietarios de una licencia pueden usar sus copias del programa para crear archivos y archivos auto extraíbles y para distribuir estos archivos sin ningún tipo de gasto o licencia adicional.

  8. El programa registrado no puede ser alquilado ni dejado a terceros pero puede ser transferido total y permanentemente siempre que la persona que lo reciba esté de acuerdo con los términos de esta licencia.

  9. Para comprar una licencia, por favor, lea el fichero order.htm proporcionado con el programa para más detalles.

  10. Usted no puede usar, copiar, emular, clonar, alquilar, dejar, vender, modificar, descompilar, desensamblar, aplicar ningún método de ingeniería inversa o transferir el programa con licencia o cualquier parte de él, excepto en lo previsto por esta licencia. Cualquiera de estos usos no autorizados resultará en la revocación inmediata y automática de esta licencia y puede conllevar la interposición de una acción judicial o penal.

    No se permite usar ni aplicar ningún método de ingeniería inversa sobre el código binario de RAR, el código binario de WinRAR, el código binario de UnRAR ni sobre el código fuente de UnRAR con el fin de recrear el algoritmo de compresión RAR, que está patentado, sin el permiso por escrito del autor.

    El programa puede usar componentes desarrollados o cuyos derechos de autor pertenecen a terceros. Por favor, lea el tema de ayuda "Agradecimientos" de WinRAR o el fichero de texto acknow.txt incluido en las otras versiones de RAR para más detalles.

  11. Este acuerdo de licencia se interpreta única y exclusivamente bajo la legislación alemana. Si es usted un comercio, los juzgados y la oficina registrada de win.rar GmbH en Berlín/Alemania tienen jurisdicción exclusiva para todas y cualquiera de las disputas que puedan derivarse con este Acuerdo de Licencia o su validez.

  12. Instalar y usar el programa significa aceptar los términos de esta licencia. Si usted no está de acuerdo con los términos de esta licencia, está obligado a borrar los ficheros que componen el programa de todos sus dispositivos de almacenamiento y dejar de usar este producto.


Información de compra

Al comprar WinRAR y como usuario registrado:

  1. Nos anima a continuar desarrollando y mejorando WinRAR, haciendo posible la publicación de nuevas versiones de WinRAR;
  2. Puede utilizar WinRAR en entornos comerciales;
  3. Accede a la ayuda y a la asistencia en cualquier parte del mundo, vía correo electrónico y las páginas de asistencia de WinRAR;

    4. Lo que necesita para realizar la compra

    Si desea convertirse en un usuario registrado de WinRAR, todo lo que tiene que hacer es efectuar un pago al autor a través de uno de los centros de venta regionales enumerados aquí. El centro de registro en castellano es On-Line Services 2000, S.L. y puede realizar el registro en línea mediante transferencia, tarjeta de crédito, Pyapal y otras formas de pago en la página oficial WinRAR,

    Por favor, consulte el fichero order.htm que encontrará en el programa de distribución WinRAR para informarse sobre más detalles y el precio.

    Procedimiento de compra

    Después de rellenar el formulario de registro y realizar el pago de su licencia recibirá un fichero con su llave de registro.

    Al recibir su llave de registro, deberá situarlo en la carpeta WinRAR o en la carpeta %APPDATA%\WinRAR. Si la clave está comprimida en un fichero .RAR, extraiga la clave del archivo para registrar su copia de WinRAR.

    Dependiendo de los recursos de los que disponga su centro local de registro, es posible que reciba su llave a través del correo electrónico o en un disquete a través de correo postal.


Crear acceso directo

Aquí puede especificar los parámetros del nuevo acceso directo que será creado por el modulo auto extraíble después de descomprimirse. Este dialogo contiene los siguientes campos:

Crear en

Escoja donde crear el acceso directo.

Fichero origen

Nombre del archivo al que apuntará el acceso directo.

Carpeta de destino

Carpeta donde crear el acceso directo, si no existe se creará.

Descripción del acceso directo

Texto que describe el acceso directo.

Nombre del acceso directo

Nombre del fichero .lnk creado por el módulo auto extraíble.

Icono del acceso directo

Nombre del fichero de iconos asociado al acceso directo. Si lo deja en blanco se usará el icono predeterminado. Si el nombre del fichero no contiene la trayectoria completa, el módulo SFX buscará el icono en la carpeta que contiene los ficheros descomprimidos.

Solo los parámetros "Crear en" y "Fichero origen" son obligatorios, el resto son opcionales.


%APPDATA%\WinRAR folder

Carpeta %APPDATA%\WinRAR

Las versiones anteriores de WinRAR almacenaban los ficheros suplementarios como la llave de registro, el fichero de exportación de configuración settings.reg, los temas o el fichero de registro en la misma carpeta que el ejecutable del WinRAR. En Windows Vista y en las futuras versiones de Windows esta practica no esta recomendada, incluso es probable que sea imposible hacerlo. La carpeta recomendada para almacenar los datos del programa debe estar bajo la carpeta del sistema %APPDATA%.

La trayectoria real de la carpeta %APPDATA% depende de la versión de Windows. Para abrir la carpeta %APPDATA% haga lo siguiente: ejecute el Explorador de Windows o abra "Mi PC" y teclee %APPDATA% en la barra de direcciones y pulse Enter. WinRAR almacena sus ficheros en la subcarpeta WinRAR dentro de %APPDATA%. Puede especificar %APPDATA%\WinRAR directamente en la barra de direcciones del Explorador de Windows para acceder directamente a esta carpeta.

Son pocas las situaciones en las que puede necesitar acceder manualmente a la carpeta %APPDATA%\WinRAR, como por ejemplo, cuando necesite copiar el fichero settings.reg a otro ordenador o cuando necesite examinar el fichero de registro con alguna utilidad externa.

Recuerde que WinRAR intenta buscar la llave de registro y el fichero settings.reg tanto en %APPDATA%\WinRAR como en la carpeta de instalación del WinRAR, teniendo siempre %APPDATA%\WinRAR preferencia.

Si necesita cambiar la trayectoria de la carpeta %APPDATA\WinRAR% puede establecer establecer el valor de "AppData" en la clave del Registro HKEY_CURRENT_USER\Software\WinRAR\Paths con la trayectoria que desee.


Tipos de archivo

  • RAR contra ZIP
  • Formato de archivos RAR 5.0
  • Compatible con otros formatos de archivo
  • Archivos sólidos
  • Archivos auto extraíbles(SFX)
  • División de archivos (multivolumen)
  • Volúmenes de recuperación
  • Cifrado
  • Comentario de archivo
  • Protección de archivos contra daños
  • Bloqueo de archivos
  • Cómo escoger la configuración óptima de compresión


Compresión con contraseña

En este cuadro de diálogo, puede introducir una contraseña que se utilizará en el archivo que va a crear ahora. La contraseña introducida sólo permanecerá activa durante una operación de compresión. En cambio, si lo que necesita es una contraseña global, puede introducirla con la orden "Establecer contraseña" del Menú Fichero

Si la opción "Mostrar la contraseña" está desactivada, se le pedirá que escriba la contraseña dos veces para asegurar su exactitud.

Si activa la opción "Codificar nombres de fichero" , WinRAR no sólo codificará los datos, si no que también codificará todas las demás áreas sensibles del archivo como los nombres de fichero, tamaños, atributos, los comentarios y otros bloques de información para proporcionar un nivel mas alto de seguridad. Sin la contraseña es imposible ni siquiera ver la lista de ficheros comprimidos en un archivo con este tipo de codificación. Esta opción sólo esta disponible cuando se usa el formato RAR , no esta soportada en el formato ZIP.

Si ya ha guardado alguna contraseña, puede acceder a ellas tanto usando la lista desplegable asociada a la entrada de la contraseña o usando la función de autocompletado. Pulse el botón Organizar contraseñas para acceder a la ventana para "Organizar contraseñas", donde puede guardar y gestionar las contraseñas que usa frecuentemente.


Cuadro de diálogo "Opciones de compresión"

Esta ventana le permite cambiar el estado de la opción “Apagar el PC al finalizar” sin tener que interrumpir la operación de compresión, descompresión o verificación.

Para las operaciones de compresión es posible también seleccionar niveles diferentes de compresión pero no es posible cambiar a o desde el método “Almacenar”.


Órden "Imprimir fichero"

Esta órden permite imprimir el fichero seleccionado y esta accesible tanto desde el modo de manejo de ficheros como desde el modo de manejo de archivo. Para ejecutar esta órden puede usar tanto el menú de Órdenes como el acelerador del teclado Ctrl+I.


Parámetros avanzados de compresión

Normalmente no es necesario cambiar ninguna opción en este diálogo y es mejor dejar que WinRAR selecciones los valores óptimos automáticamente. Por favor, tenga en cuenta que el uso inadecuado de estas opciones puede resultar en una degradación importante tanto en la velocidad como en la razón de compresión, así que procure cambiar estos valores solo si tiene claro que es lo que esta haciendo.

La mayoría de estas opciones solo están soportdas para el formato de archivos RAR 4.x. Ninguna de estas opciones están disponibles para el formato ZIP. Solo la compresión delta y la compresión de ejecutables de 32 bits están disponibles para los archivos RAR 5.0.

Este diálogo contiene las siguientes opciones.

Compresión de texto/(Auto/Forzar/Desactivar)

La compresión de texto permite mejorar el ratio de compresión para datos en texto plano, pero su velocidad de compresión y descompresión así como su capacidad para usar varios núcleos es mucho peor que la del algoritmo general de compresión. Su estado por defecto es "Desactivar". Puede cambiarlo a "Auto" para permitir que WinRAR seleccione este algoritmo automáticamente cuando encuntre datos apropiados. "Forzar" aplica el algoritmo de compresión de texto a todos los datos, tenga en cuenta que esto hara que las operaciones de compresión y descompresión sean muy lentas.

Compresión de texto/Orden de predicción

Establece el orden de predicción del algoritmo PPM (el núcleo de la compresión de texto de RAR). Los valores permitidos van de 2 a 63. Normalmente los valores más altos aumentan ligeramente la razón de compresión de datos redundantes, pero solo si hay suficiente memoria disponible para el algoritmo PPM. Si no hay suficiente memoria el resultado puede ser negativo. Igualmente, los valores más altos también reducen la velocidad de compresión y descompresión. Si establece este valor a cero, WinRAR escogerá automáticamente el valor mas apropiado.

Compresión de texto/Memoria a usar, MB

Memoria en megabytes reservada para PPM (puede ser 1-128). Los valores mas altos pueden incrementar la razón de compresión, pero tenga en cuanta que el algoritmo PPM usa la misma cantidad de memoria para comprimir que para descomprimir, así que si reserva mucha memoria al crear el archivo y lo descomprime en un ordenador con menos memoria instalada puede tener problemas. Si deja este valor a cero, WinRAR escogerá el tamaño de la memoria automáticamente.

Compresión de audio/(Auto/Forzar/Desactivar)

En modo "Auto" WinRAR decidirá cuando usar la compresión de audio dependiendo de los datos de origen y solo si ha escogido el método de compresión "Normal", "Buena" o "Mejor”. "Forzar" usará el algoritmo de compresión de para comprimir todos los datos. Solo tiene sentido si esta completamente seguro que todos los ficheros que va a comprimir son de ficheros de audio. "Desactivar" prohíbe el uso del algoritmo de compresión de audio.

La compresión de sonido esta diseñada para procesar ficheros de sonido sin comprimir como por ejemplo, ficheros WAV. El algoritmo no aumentará la compresión de ficheros de sonido ya comprimidos como pueden ser los ficheros MP3.

Compresión de sonido/Canales

Número de canales de un byte (puede ser 1 - 31).

WinRAR divide los canales multibyte en canales de un byte, por ejemplo, dos canales de sonido de 16 bits son procesados por WinRAR como cuatro canales de un byte cada uno. Si este valor es cero, WinRAR escogerá automáticamente el número de canales.

Compresión de color real/(Auto/Forzar/Desactivar)

En modo "Auto" WinRAR decidirá cuando usar la compresión de color real dependiendo de los datos a comprimir y solo cuando haya especificado el método de compresión "Normal", "Buena" o "Mejor". "Forzar" aplica la compresión de color real a todos los datos a comprimir. Solo tiene sentido si esta completamente seguro que todos los datos a comprimir son imágenes de color real (RGB). "Desactivar" prohíbe el uso del algoritmo de compresión de color real.

El algoritmo de compresión de color real esta diseñado para procesar imágenes de color RGB sin comprimir como por ejemplo ficheros BMP de 24 bits. No aumenta la compresión de imágenes ya comprimidas como pueden ser las imágenes JPG.

Activar compresión de ejecutables de 32 bits (Pentium)

Permite a WinRAR aumentar la compresión de ejecutables Intel de 32 bits usando un algoritmo especial para este tipo de datos.

Activar compresión de ejecutables de 64 bits (Itanium)

Permite a WinRAR aumentar la compresión de ejecutables Intel de 64 bits usando un algoritmo especial para este tipo de datos.

Activar compresión delta

Permite a WinRAR aumentar la compresión de tablas de datos usando un algoritmo especial para este tipo de datos.

Botón Predeterminado

Restaura los valores predeterminados para todas las opciones.


Elementos del menú contextual

La opción Elementos del menú contextual" le permite seleccionar los elementos que aparecerán en el menú contextual del Explorador de Windows, que se muestra al hacer click en un fichero o en su icono con el botón derecho en el Explorador o el Escritorio.

La opción "Donde buscar archivos SFX" controla el proceso de archivos autoextríbles en los menús contextuales. Comprobar el contenido de un archivo ejecutable y detectar si es un archivo auto-extraíble (SFX) puede tomar cierto tiempo e introduce un retardo cada vez que se abre el menú contextual sobre un fichero ".exe" ya que WinRAR tiene que leer y analizar los datos del fichero para saber si es o no un archivo SFX. Aunque este retardo es inapreciable para discos duros locales, puede ser notablemente lento en discos de red. Este grupo de opciones permite activar o desactivar este proceso para disco locales, discos de red u otros tipos de discos como CD-ROM y USB de forma separada. Si desactiva estas opciones no verá los elementos del menú contextual asociados a los archivos SFX al hacer click con el botón derecho sobre un archivo SFX. Desactive estas opciones solo si experimenta retardos molestos al hacer click con el botón derecho sobre ficheros ".exe".


Cuadro de diálogo "Definir tamaños de volumen”

Cuadro de diálogo "Definir tamaños de volumen"

Este cuadro de dialogo permite personalizar la lista de tamaños predefinidos asociados al campo “Partir en volúmenes, tamaño” del cuadro de dialogo Nombre de archivo y parámetros.

Use la opción "Tamaños predefinidos" para seleccionar los tamaños de disco para mostrar en la lista. Si necesita incluir algún valor que no está en “Tamaños predefinidos” puede especificar hasta cuatro tamaños adicionales en “Tamaños definidos por el usuario”. Solo tiene que entrar el nombre y el tamaño. El nombre puede ser cualquier texto corto y el tamaño ha de ser un valor numérico expresado en bytes. Puede omitir el nombre si lo desea.

La opción "incluir "Auto detectar"" en "Otras opciones" controla la presencia de la opción "Auto detectar" en la lista. Si nunca usa la opción de auto detección del tamaño de volumen al comprimir en medios extraíbles, puede desactivar esta opción para hacer la lista mas corta.

La opción "Historial" define el número de tamaños entrados previamente por el usuario que se muestran al principio de la lista. Puede ponerlo a cero si no desea mantener el historial de tamaños especificados manualmente.


Establecer contraseña predeterminada

En este cuadro de diálogo, puede introducir una contraseña predeterminada que será utilizada en las operaciones de agregación, extracción, comprobación y visualización.

Si la opción "Mostrar la contraseña" está desactivada y se requiere una contraseña para la compresión se le pedirá que escriba la contraseña dos veces para asegurar su exactitud.

Si activa la opción “codificar nombres de fichero” WinRAR además de codificar los datos también codificará otras áreas sensitivas como nombres de fichero, tamaños, atributos, comentarios y otros bloques para proporcionar un grado superior de seguridad. Sin la contraseña es totalmente imposible ni siquiera ver el contenido del archivo cifrado con esta opción. Esta opción solo tiene sentido al comprimir usando el formato RAR , se ignorará cuando se use la contraseña por defecto para descomprimir o al comprimir usando el formato ZIP.

Si activo la opción "Usar para todos los archivos" y uso una contraseña vacía, las operaciones de extracción y verificación omitirám todos los ficheros cifrados. Todos los intentos de abrir fichero y archivos cifrados serán también bloqueados hasta que esta opción se desactive. Esto puede ser conveniente si va a descomprimir un grupo de archivos en modo no atendido y quiere omitir las preguntas de contraseña. "Usar para todos los archivos" no esta disponible para contraseñas no vacías, porque las contraseñas no vacías se aplican a todos los archivos de forma automática.

Si ya ha guardado alguna contraseña, puede acceder a ellas tanto usando la lista desplegable asociada a la entrada de la contraseña o usando la función de autocompletado. Pulse el botón Organizar contraseñas para acceder a la ventana para "Organizar contraseñas", donde puede guardar y gestionar las contraseñas que usa frecuentemente.


Ejecución de la operación de compresión

Se está ejecutando una operación de compresión. Espere hasta que termine o haga clic en "Cancelar" para interrumpirla inmediatamente. Mientras comprime o extrae, también puede hacer clic en "Segundo plano" para minimizar WinRAR en la barra de tareas, que se restablecerá automáticamente tras finalizar la operación en curso, usted también puede restablecerlo haciendo clic en el icono de WinRAR situado en la barra de tareas. El botón "Pausa" detiene la operación en curso, para reanudar su ejecución debe pulsar el botón "Continuar".

Tanto al comprimir como al extraer, la barra de progreso situada en la parte superior de ventana de mandos indica el proceso del fichero actual.

Durante la operación de compresión, se muestra una barra de progreso adicional en la parte inferior de la ventana de mandos. Su apariencia depende del la opción "Barra de progreso estandard" en la ventana Opciones generales. Si esta opción esta desactivada y WinRAR esta comprimiendo ficheros, la barra de progreso que muestra el total de la operación usará 3 colores. La parte amarilla representa los datos ya comprimidos y la gris claro, los ya procesados, de forma que comprando la aprte amarilla y la gris puede tener una representación visual de la razón de compresión conseguida. Si la opción "Barra de progreso estandard" esta activada solo se usarán dos colores aunque en ambos casos la razón de compresión también se muestra en otra línea de esta ventana.

Durante la operación de compresión, descompresión y verificación también puede usar el botón "Modo…" que le permite cambiar el estado de la opción "Apagar el PC al finalizar" sobre la marcha. Para las operaciones de compresión también puede usarlo para cambiar el método de comrpesión, aunque WinRAR no puede cambiar de esta forma de y al método "Alamcenar".


Cuadro de diálogo Ruta y opciones de extracción: opciones avanzadas

Aquí puede especificar las siguientes opciones:

Fecha y hora del fichero

Establecer fecha de modificación/creación/último acceso

Los sistemas Windows guardan tres fechas diferentes para cada fichero: última modificación, creación y último acceso. Por defecto WinRAR solo guarda la fecha de la última modificación pero puede hacer que WinRAR guarde también la fecha de creación y del último acceso desde las opciones de compresión Fecha y Hora. Aunque estas fechas estén definidas en el archivo es necesario activar la opción de extracción correspondiente para que WinRAR las restaure al descomprimir. Esta característica solo esta soportada en archivos RAR y ZIP, en los demás formatos, WinRAR siempre restaura solo la fecha de la última modificación.

Atributos

Desactivar atributo “Archivado"

Desactiva el atributo "Archivado" en los ficheros extraídos. Esta opción es para usarla en copias de seguridad.

Establecer seguridad

Esta opción solo tiene significado para sistemas de ficheros NTFS y permite restaurar la información acerca del propietario, grupo, control de acceso e información de auditoria si fue previamente almacenada en el archivo. Es necesario especificar la opción "Guardar información de seguridad" en el cuadro de diálogo de compresión Avanzada para que WinRAR preserve esta información al comprimir. Además necesitará los privilegios necesarios para poder usar esta característica. El proceso de la información de seguridad puede disminuir la velocidad de compresión, de forma que use esta opción solo si sabe lo que hace y realmente lo necesita. En la mayoría de los casos esto no es necesario para usuarios normales.

Esta característica solo esta soportada en archivos RAR.

Establecer el atributo “Comprimido"

Esta opción permite restaurar el atributo “Comprimido” de NTFS al extraer ficheros. WinRAR guarda este atributo al crear el archivo pero no lo restaura a menos que se haya activado esta opción.

Esta característica solo esta soportada en archivos RAR.

Rutas

Extrarer rutas relativas

Este es el modo activado por defecto. Si navega por una subcarpeta de un archivo comprimido usando WinRAR la parte inicial de la ruta incluyendo la carpeta actual se eliminará de la ruta de extracción. Por ejemplo, si esta dentro de la carpeta "Backup\MisDatos" y descomprime la carpeta "Imagenes" se descomprimirá como "Imagenes" en la carpeta de extracción y no como "Backup\MisDatos\Imagenes".

Si esta dentro de la carpeta raíz o inicia la descompresión desde el menú contextual, este modo funciona exactamente igual que la opción Extraer rutas completas.

Extraer rutas completas

WinRAR descomprime el contenido del archivo incluyendo las rutas en la carpeta de destino. Al contrario que el modo Extrarer rutas relativas la información de las rutas de descoprime en su totalidad independientemente de que carpeta este visualizando en el archivo.

No extraer rutas

Si esta opción esta activada los ficheros seleccionados de la raíz del archivo y de las subcarpetas seleccionadas serán extraídos en la carpeta de destino, ignorando la estructura de carpetas almacenada en el archivo comprimido.

Extraer rutas absolutas

Si el archivo fue creado con la opción “Almacenar rutas completas incluyendo la letra de la unidad” activada en la sección Ficheros del cuadro de diálogo de compresión y tiene la opción “Extraer rutas completas” activada, WinRAR creará los ficheros descomprimidos en sus discos y carpetas originales. Tenga cuidado y no active esta opción a no ser que este muy seguro que el archivo no contiene ficheros maliciosos. Puede leer mas acerca de los beneficios y peligros de esta opción en la descripción del modificador -ep3, que es la opción equivalente de la línea de órdenes. Esta característica esta solo soportada en archivos RAR y ZIP.

Eliminar archivo

Nunca

No eliminar nunca un archivos descomprimido.

Pedir confirmación

Pedir confirmación al usuario antes de eliminar un archivo descomprimido.

Siempre

Eliminar los archivos descomprimidos sin pedir confirmación.

WinRAR elimina un archivo solo si ha sido descomprimido sin errores y si todos sus ficheros fueron seleccionados para descomprimirse. Si descomprime un archivo multi-volumen, todos sus volúmenes serán eliminados.

Puede guardar el estado por defecto de esta opción con el botón “Guardar opciones” de la pestaña General del cuadro de diálogo de extracción, lo que también afectará a la operaciones desde la línea de órdenes y a las órdenes de extracción del menú contextual. Debe usar los modos “Pedir confirmación” y especialmente “Siempre” con precaución. Eliminar archivos puede causar perdida de datos si se utiliza de forma inadecuada.

Miscelánea

Extracción en segundo plano

Minimizar WinRAR en la bandeja de Windows al iniciar el proceso de extracción.

Esperar si otras instancias de WinRAR están activas

Esperar en la cola si otras instancias de WinRAR están creando, modificando o descomprimiendo un archivo e iniciar la operación solo cuando las otras instancias de WinRAR finalicen sus operaciones. Si va a realizar varias operaciones de compresión o descompresión, esta ejecución secuencial puede ayudar a reducir la cantidad de accesos a disco y mejorar la velocidad global de las operaciones.

Puede desactivar esta opción para la operación en curso pulsando el botón "Continuar" en la ventana de progreso de la operación. Al pulsar "Continuar" WinRAR deja de esperar independientemente de lo que esten haciendo las otras instancias de WinRAR.


Cuadro de diálogo Ruta de extracción y opciones

Este cuadro de diálogo le permite seleccionar la carpeta de destino de los ficheros extraídos y establecer algunas opciones generales. Por defecto, esta carpeta es la misma que la del nombre de archivo y está ubicada en la carpeta actual. No obstante, puede cambiar este valor predeterminado utilizando el cuadro de diálogo Configuración de la compresión. Puede introducir la ruta nueva (si todavía no existe, se creará) en el campo "Ruta de destino" o seleccionar una carpeta existente en el panel del árbol de carpetas.

A medida que usted introduzca la carpeta de destino, después de un pequeño retardo (cerca de medio segundo) y siempre que la ruta entrada empiece por una especificación de una unidad, el dialogo intentará ubicar la ruta en el panel del árbol de carpetas. Si la carpeta introducida no existe se seleccionará o bien su carpeta padre o bien la carpeta mas parecida. También puede forzar a que el dialogo busque la carpeta introducida inmediatamente pulsado el botón Mostrar lo que puede serle de utilidad cuando la ruta no ha sido introducida por usted pero sugerida por defecto al abrir este cuadro de dialogo.

Puede crear una nueva carpeta usando el botón Nueva carpeta. La carpeta será añadida dentro de la carpeta seleccionada en el árbol de carpetas o dentro de la carpeta especificada como "Carpeta de destino", dependiendo de cual de ellas haya modificado en último lugar. Use la tecla F2 para renombrar carpetas dentro del árbol de carpetas, Supr para eliminarlas o F5 para refrescar el contenido del árbol.

Puede cambiar el tamaño de esta ventana arrastrando con el ratón su borde hasta conseguir el tamaño deseado de forma que tenga mas espacio para el panel con la lista de carpetas. WinRAR recordará los cambios de tamaño para usarlos la próxima vez que acceda a esta ventana.

Este cuadro de diálogo también proporciona varias opciones adicionales:

Modo de actualización

Extraer y reemplazar (predeterminado)

Extrae todos los ficheros seleccionados.

Extraer y actualizar

Extrae aquellos ficheros seleccionados cuyas copias no existen en la carpeta de destino o son anteriores a los ficheros que se extraen.

Solo actualizar

Sólo extrae aquellos ficheros seleccionados que existen en la carpeta de destino y que son anteriores al fichero correspondiente del archivo. Se omitirán todos aquellos ficheros que no existen en el disco.

Modo de sobrescritura

Confirmar sobrescritura (predeterminado)

Aparece un indicador del sistema antes de sobrescribir un fichero.

Sobrescribir sin solicitar confirmación

Se sobrescriben los ficheros sin que aparezca ningún indicador del sistema.

Omitir los ficheros existentes

No se sobrescriben los ficheros que están presentes.

Varios

Extraer archivos en subcarpetas

Esta opción solo está disponible cuando se ha seleccionado más de un archivo a descomprimir. Al activarla cada archivo será descomprimido en una subcarpeta diferente cuyo nombre será generado basándose en el nombre del archivo.

No extraer los nombres de las rutas

Si se activa esta opción, se extraerán en la carpeta de destino los ficheros seleccionados en la carpeta raíz del archivo y en las subcarpetas seleccionadas. Se ignora la información sobre la ruta.

Borrar el atributo "Archivo"

Borra el atributo "Archivo" incluido en los ficheros extraídos. El propósito para el que se diseñó esta opción es el de realizar copias de seguridad.

Conservar los ficheros dañados

WinRAR no eliminará los ficheros que no se hayan extraído correctamente, por ejemplo, cuando el archivo resulte dañado (por defecto, WinRAR elimina esos ficheros). Puede intentar recuperar parte de la información contenida en el fichero estropeado.

Mostrar ficheros en el Explorador

Después de la extracción WinRAR abrirá una ventana del Explorador para mostrar el contenido de la carpeta de destino.

Guardar opciones

Pulse el botón "Guardar opciones" si desea guardar el estado actual de ambas partes (General y Avanzada) de las opciones de extracción. El estado así guardado será restaurado como valores por defecto cuando active este cuadro de diálogo al próxima vez. WinRAR guarda todas las opciones excepto la carpeta de destino. Si desea especificar la carpeta de destino por defecto use el cuadro de diálogo Opciones de compresión .


Introduzca la contraseña del fichero extraído

Está intentando ver un archivo codificado o intentando extraer un fichero codificado. Introduzca la contraseña o cancele la extracción.

Si descomprime varios archivos a la vez puede activar "Usar para todos los archivos" para aplicar la contraseña a todos los archivos. Esta opción no esta disponible si se ha seleccionado un archivo solo. Otra posible aplicación para esta opción es omitir los archivos cifrados, para ello, solo tiene que entrar una contraseña vacía y activar "Usar para todos los archivos".

Si ya ha guardado alguna contraseña, puede acceder a ellas tanto usando la lista desplegable asociada a la entrada de la contraseña o usando la función de autocompletado. Pulse el botón Organizar contraseñas para acceder a la ventana para "Organizar contraseñas", donde puede guardar y gestionar las contraseñas que usa frecuentemente.


Cuadro Nombre de archivo y parámetros: opciones avanzadas

Cuadro de diálogo Nombre de archivo y parámetros: opciones avanzadas

Guardar la información de seguridad del fichero

Esta opción sólo tienen sentido para el sistema de archivos NTFS y permite guardar información sobre el propietario de fichero, el grupo, el control de acceso y el rastreo. Necesita poseer los privilegios necesarios para utilizar esta prestación. El proceso de la información de seguridad puede disminuir la velocidad en la operación de compresión, por tanto, sólo active esta opción si comprende su significado y realmente la necesita. En la mayoría de los casos, los usuarios domésticos no lo suelen necesitar.

Esta opción sólo esta soportada en archivos RAR.

Guardar los flujos del fichero

Este modificador sólo tienen sentido para el sistema de archivos NTFS y permite guardar flujos de datos alternativos asociados con un fichero. Puede necesitar usar este modificador al comprimir si usa algún programa que guarde datos en flujos alternativos y desee preservar estos flujos de datos. Los flujos de datos no se guardan para ficheros NTFS cifrados.

Sólo los archivos RAR permiten esta opción.

Guardar enlaces simbólicos como enlaces

Almacena los enlaces simbólicos NTFS y los puntos de reanálisis de forma que el contenido del fichero no es almacenado. Estas entradas de fichero se restauran como enlaces simbólicos o puntos de reanálisis al extraer. Quiza necesite ejecutar WinRAR como administrador para crear enlaces simbólicos al extraer. Solo está soportado para el formato de archivo RAR 5.0.

Guardar enlaces fuertes como enlaces

Si los ficheros a comprimir incluyen varios enlaces fuertes NTFS, almacena el primer enlace fuerte como fichero normal y almacena como enlaces al primero el resto de enlaces fuertes de mismo conjunto. Al extraer este tipo de ficheros, WinRAR creará enlaces fuertes en vez de ficheros normales.

No debe eliminar o renombrar el primer enlace fuerte del archivo una vez ha creado el archivo porque haría imposible la extracción de los siguientes enlaces. Si modifica este primer enlace todos los enlaces siguientes también tendrán el contenido modificado cuando se descompriman. El proceso de extracción requiere el primer enlace fuerte para poder crear los siguientes enlaces correctamente. Solo está soportado para el formato de archivo RAR 5.0.

Pausa después de cada volumen

Por defecto WinRAR pide confirmación antes de crear o descomprimir el siguiente volumen solo para los discos removibles. Esta opción fuerza a WinRAR a pedir dicha confirmación siempre. Puede ser útil si el espacio en disco es limitado y usted quiere copiar cada volumen en otro medio inmediatamente después de crearlo.

Sólo los archivos RAR permiten esta opción.

Nombres de volumen en formato antiguo

Por defecto los volúmenes WinRAR tienen nombres del tipo 'nombrevol.parteNNN.rar', donde NNN es el número del volumen. Para elf ormato de archivo RAR 4.x activando esta opción es posible usar el formato antiguo basado en las extensiones de los archivos, donde el primer volumen tiene la extensión .rar y los volúmenes siguientes están numerados desde el .r00 al .r99. El formato de archivo RAR 5.0 no soporta esta opción ni los nombres basados en extensión.

Volúmenes de recuperación

Esta opción solo está disponible cuando usted esta creando un archivo multivolumen RAR, en este caso sólo debe seleccionar el número de volúmenes de recuperación a crear. También puede añadir el carácter de porcentaje al final de este parámetro, en dicho caso el número de ficheros .rev creados será igual a este porcentaje respecto al número total de volúmenes RAR. Cada volumen de recuperación permite reconstruir un volumen perdido. Puede obtener más información sobre esta característica aquí.

Compresión en segundo plano

Minimiza WinRAR en la bandeja de Windows al comenzar el proceso de compresión.

Opción “Apagar el PC al finalizar

Apaga el PC después de completar la operación. Su PC debe soportar esta función.

Esperar si hay otras instancias de WinRAR activas"

Esperar en la cola si hay otras instancias de WinRAR que estén creando, modificando o descomprimiendo e iniciar la operación cuando las otras instancias de WinRAR finalicen sus operaciones. Si va a realizar varias operaciones de compresión o descompresión, este tipo de ejecución secuencial puede ayudar a reducir el número de accesos a disco y mejorar la velocidad global de las operaciones..

Puede desactivar esta opción para la operación en curso pulsando el botón "Continuar" en la ventana de progreso de la operación. Al pulsar "Continuar" WinRAR deja de esperar independientemente de lo que esten haciendo las otras instancias de WinRAR.

Registro de recuperación

Establece en porcentaje el tamaño del registro de recuperación para el tamaño total del archivo. Los registros de recuperación más grandes permiten la recuperación de daños más graves, pero, al mismo tiempo, aumentan el tamaño del archivo. Por tanto, probablemente 3 - 10% es el valor óptimo. Este campo de entrada sólo está disponible si activa la opción "Incluir el registro de recuperación" en las Opciones generales de este cuadro de diálogo.

Compresión…

Abre el dialogo Parámetros avanzados de compresión, donde puede configurar diferentes módulos del algoritmo de compresión del WinRAR. La configuración incorrecta de dichos parámetros puede degradar seriamente la velocidad de compresión, así que uselo con cuidado.

Opciones SFX

Seleccione un módulo auto extraíble y establezca una serie de parámetros opcionales SFX como una carpeta de destino o un título de ventana. Tenga en cuenta que los parámetros sólo se aplican al módulo GUI (gráfico) Windows y no son compatibles con consolas o con auto extraíbles que no pertenezcan a Windows. El botón "Opciones SFX" sólo está disponible si activó la opción "Crear un archivo auto extraíble" de las Opciones generales de este cuadro de diálogo.

Se pueden almacenar opciones SFX seleccionadas en un perfil de compresión. WinRAR incluye órdenes que describen los parámetros SFX en el comentario de archivo.


Cuadro Nombre de archivo y parámetros: opciones de seguridad

Cuadro de diálogo Nombre de archivo y parámetros: opciones de seguridad

- Opción "Borrar el contenido del disco de destino antes de comprimir"

Se borrarán todos los ficheros y las carpetas del disco de destino antes de comenzar la operación de compresión. Si crea volúmenes, el borrado se efectuará antes de la creación de cada volumen, dándole la oportunidad de comprimir en discos extraíbles que no estén vacíos. No obstante, debe asegurarse de que los discos no contienen ninguna información útil. La opción sólo se puede utilizar en soportes extraíbles. No se puede borrar un disco duro con esta función.

- Opción "Agregar sólo ficheros con conjunto de atributo "Archivo""

Sólo se agregarán aquellos ficheros que incluyan conjunto de atributo "Archivo". El propósito para el que se diseñó esta opción es el de realizar copias de seguridad.

- Opción "Borrar el atributo "Archivo" tras la compresión"

Borra el atributo "Archivo" de los ficheros comprimidos correctamente. El propósito para el que se diseñó esta opción es el de realizar copias de seguridad.

- Opción "Abrir los ficheros compartidos"

Permite procesar ficheros abiertos por otras aplicaciones para escribir. Esta opción puede ser peligrosa porque permite comprimir un fichero que puede estar siendo modificado en ese momento por otra aplicación. Tenga cuidado.

- Opción "Generar un nombre de archivo mediante máscara"

Añade una cadena de caracteres con la fecha actual al nombre de un archivo cuando éste se está creando. Útil para las copias de seguridad diarias. El formato de la cadena de la fecha viene dado por la máscara especificada. Consulte el parámetro -ag para leer información detallada sobre el formato de máscara.

- Opción "Guardar versiones anteriores"

Fuerza a WinRAR a guardar las versiones anteriores de cada fichero al actualizar ficheros que ya existen en el archivo. Las versiones anteriores se renombran a 'fichero;n', donde 'n' es el numero de versión. Solo está disponible para en archivos RAR.


Cuadro Nombre de archivo y parámetros: comentario

Cuadro de diálogo Nombre de archivo y parámetros: comentario

Aquí puede especificar un comentario de archivo para agregarlo a un archivo nuevo o actualizado. Puede introducir el nombre de un fichero que contenga un comentario en el campo "Cargar el comentario del fichero" o escribir un comentario en la ventana "Introduzca manualmente un comentario".


Cuadro Nombre de archivo y parámetros: ficheros

Cuadro de diálogo Nombre de archivo y parámetros: ficheros

Ficheros a añadir

Nombres de los ficheros y las carpetas que se van a comprimir. Este campo se llena automáticamente con los nombres de los ficheros seleccionados, pero puede corregirlos manualmente o hacer clic en "Adjuntar" para añadir más ficheros a la lista si es necesario.

Aquí se permite introducir máscaras comodín. En este caso, WinRAR buscará los ficheros que se ajusten a la máscara en la carpeta actual y en todas las subcarpetas. Si necesita especificar varias mascaras separelas por espacios. Si la mascara contiene espacios, encierrelos entre comillas. Por ejemplo, puede introducir:

*.txt *.doc "juego 1.*"

para comprimir todos los ficheros .txt y .doc.

Ficheros a excluir

Máscaras y nombres de ficheros que se van a excluir de la operación de compresión. Soporta comodines tanto en la parte de la ruta como del nombre de fichero. Si necesita especificar varias mascaras separelas con espacios. Si la mascara contiene espacios encierrelar entre comillas. Por ejemplo, puede introducir:

c:\temp\info.txt *.bak *.tmp *\temp\"

para omitir los ficheros c:\temp\info.txt .bak , .tmp y todos las carpetas temporales y todos los ficheros de las carpetas temporales. Puede entrar los ficheros manualmente o pulsar el botón “Añadir” para buscar los ficheros a excluir.

Puede consultar información mas detallada sobre el uso de mascaras de exclusión en la descripción del modificador -x que usa el mismo formato de mascaras de exclusión que el campo "Ficheros a excluir".

Ficheros a almacenar sin comprimir

Máscaras y nombres de ficheros que se van a almacenar sin comprimir. Esta opción puede usarse para almacenar ficheros que ya están comprimidos, lo que ayuda a aumentar la velocidad de compresión sin una disminución notable en el ratio de compresión. Por ejemplo, puede introducir:

*.rar *.zip *.jpg

para almacenar sin comprimir todos los archivos RAR y ZIP y las imágenes JPG.

Rutas de fichero

Selecciona el método para almacenar las rutas en el archivo. WinRAR puede almacenar las rutas relacionadas con la carpeta actual (predeterminado), sólo los nombres de fichero sin la ruta, las rutas de fichero completas exceptuando una letra de unidad y la barra invertida inicial y las rutas de fichero completas incluyendo la letra de la unidad.

Si usa la opción "No almacenar rutas" puede crear un archivo que contenga varios ficheros con el mismo nombre, por tanto, tenga cuidado al utilizar esta opción.

Si almacena las rutas completas incluyendo la letra de la unidad, WinRAR substituirá los separadores de unidad (dos puntos) por signos de subrayado. WinRAR es capaz de restaurarlos y crear los ficheros en su ubicación y disco original si activa la opción “Extraer rutas completas” en las opciones "Avanzadas" del cuadro de diálogo de extracción. Puede leer mas acerca de los beneficios potenciales y los peligros de usar la opción “Guardar rutas completas incluyendo la letra de unidad” en la descripción del modificador -ep3, que es la opción equivalente de la línea de órdenes.

Colocar cada fichero en un archivo separado

Coloca cada fichero o carpeta seleccionada en archivos separados. Si activa esta opción, el nombre de archivo introducido se interpreta como la carpeta de destino de los archivos generados (si no es el nombre de una carpeta se ignora la parte del nombre) y los nombres de archivo se generan basándose en los nombres de los ficheros.

Enviar archivo por email a [<dirección>] [y después eliminar]

Esta opción permite adjuntar el archivo creado a un correo electrónico. Para usar esta opción necesita tener instalado cualquier programa de correo electrónico compatible con MAPI (la mayoría de los programas modernos soportan MAPI). SI no especifica ahora la dirección de destino deberá introducirla en su programa de correo electrónico. Si activa la opción "y después eliminar" , el archivo será eliminado después de ser adjuntado con éxito al mensaje.

Si usa la opción Enviar archivo por email al crear un archivo multivolumen, cada volumen será adjuntado a un mensaje diferente.


Cuadro de diálogo Nombre de archivo y parámetros: opciones generales

El cuadro de diálogo está formado por los siguientes elementos:

Nombre del archivo de destino

Escriba el nombre o haga clic en "Examinar" para buscar el nombre del archivo. Puede escribir un nombre que contenga una letra de unidad o la ruta completa del archivo.

Perfiles

Abre el menú que permite crear, organizar y seleccionar los perfiles de compresión. Los perfiles de compresión le permiten restablecer rápidamente opciones de compresión ya guardadas o especificar las opciones predeterminadas para este cuadro de diálogo. WinRAR proporciona algunos perfiles predefinidos optimados para crear ficheros adjuntos para correo electrónico, ficheros de seguridad y para otras operaciones. Consulte el tema Perfiles de compresión para más información.

Formato de archivo (RAR, RAR5, ZIP)

Seleccione el formato del archivo que se va a crear. Puede especificar RAR para usar el formato compatible con RAR 4.x, RAR5 para el nuevo formato RAR 5.0 o ZIP para crear archivos ZIP. Dependiendo del formato de archivo seleccionado, algunas opciones avanzadas no soportadas para el formato de destino estarán desactivadas. Si actualiza un archivo existente esta opción se ignora y WinRAR usará el formato de archivo a actualizar.

método de compresión

Escoja entre "No comprimir", "Muy rápida", "Rápida", "Normal", "Buena" y "La mejor". "No comprimir" guarda los ficheros en el archivo a la máxima velocidad y sin compresión. Los demás métodos comprimen los datos proporcionando una razón de compresión cada vez mayor y una velocidad cada vez menor desde "Muy rápida" hasta "La mejor".

Tamaño del diccionario

Es el tamaño del área de memoria usada para buscar y comprimir patrones que se repiten en los datos. Tamaños mayores de diccionario a veces mejoran la razón de compresión en ficheros grandes, especialmente cuando se crean archivos sólidos. Sin embargo tamaños de diccionario mayores también disminuyen la velocidad de compresión e incrementan las necesidades de memoria. El proceso de compresión necesita cerca de 6 veces mas memoria que el tamaño del diccionario. El proceso de descompresión solo necesita poca mas memoria que el tamaño del diccionario. Si espera que un archivo RAR 5.0 pueda ser descomprimido en todo tipo de ordenadores, incluyendo aquellos con poca memoria intente evitar los tamaños mayores de diccionario y seleccione un tamaño intermedio como 32 o 64 MB.

El tamaño máximo de diccionario para archivos RAR 4.x es de 4 MB. El formato de archivo RAR 5.0 permite crear archivos con un tamaño de diccionariod e hasta 1 GB en la versión de 64 bits de WinRAR y de hasta 256 MB en la versión de WinRAR de 32 bits (hasta 128 MB en Windows XP x86). La descompresión necesita menos memoria que la compresión, así que tanto la versión de 32 como la de 64 bits de WinRAR pueden descomprimir archivos con todos los tamaños de diccionario incluyendo los de 1 GB siempre que el ordenador tenga mas de 1 GB de memoria disponible. El tamaño de diccionario para el formato ZIP es fijo y de 32 KB.

Tamaño de volumen en el campo Partir en volúmenes, tamaño

Si desea partir el archivo en volúmenes especifique el tamaño de volumen aquí. Puede seleccionar las unidades de tamaño en la lista desplegable a la derecha del campo donde se indica el tamaño. En esta lista "B" significa bytes, "KB" - kilobytes, "MB" - megabytes y "GB" - gigabytes.

Se permite introducir fracciones decimales usando como separador decimal el simbolo definido en la configuración regional de Windows.

También es posible seleccionar las unidades añadiendo uno o dos carácteres al tamaño del volumen. Una 'k' minúscula significa kilobytes, una 'K' mayúscula - miles de bytes, 'm' - megabytes, 'M' - millones de bytes, 'g' - gigabytes, 'G' - billones (millardos) de bytes. "KB", "MB" y "GB" siempre significan kilobytes, megabytes y gigabytes independientemente de las mayúsculas o minúsculas.

El campo de entrada del tamaño de volumen tiene asociada una lista despelegable que contiene valores entrados previamente, valores predeterminados y definidos por el usuario. Puede usar esta lista para seleccionar rápidamente cualquiera de los valores que contiene. Puede personalizar esta lista usando el cuadro de dialogo Definir tamaños de volumen . Para activarlo tiene que pulsar el botón "Definir tamaños de volumen…" en el cuadro de dialogo Opciones de compresión.

Tenga en cuenta que si está comprimiendo en un disco extraíble usando el formato RAR, puede seleccionar en la lista la opción "Detectar automáticamente" y WinRAR escogerá automáticamente el tamaño de volumen para cada volumen nuevo.

Modo de actualización:

  • Añadir y reemplazar (predeterminado) Reemplaza siempre los ficheros comprimidos que tengan el mismo nombre que los ficheros que se van a agregar. Siempre agrega aquellos ficheros que no existen en el archivo.
  • Añadir y actualizar Sólo reemplaza los ficheros comprimidos si los ficheros agregados son más recientes. Siempre agrega aquellos ficheros que no existen en el archivo.
  • Solo actualizar Sólo reemplaza los ficheros comprimidos si los ficheros agregados son más recientes. No agrega aquellos ficheros que no existen en el archivo.
  • Preguntar antes de sobreescribir Solicitar confirmación antes de sobreescribir ficheros comprimidos que tengan el mismo nombre que los ficheros que se han de añadir y añadir siempre los ficheros que no esten ya presentes en el archivo.
  • Omitir ficheros existentes No reemplazar ficheros comprimidos que tengan el mismo nombre que los ficheros que se han de añadir y añadir siempre los ficheros que no esten ya presentes en el archivo.
  • Sincronizar Sólo reemplaza los ficheros comprimidos si la versión en disco del mismo fichero es más reciente. Siempre añade aquellos ficheros que no existen en el archivo y elimina aquellos ficheros comprimidos que no existen en el disco. Se asemeja a crear un nuevo archivo, pero con una importante excepción: si no se modificó ningún fichero desde la última copia de seguridad, la operación se realiza mucho más rápido que al crear un archivo nuevo.

Eliminar los ficheros tras la compresión

Elimina los ficheros fuente comprimidos correctamente.

Crear un archivo auto extraíble

Crea un archivo auto extraíble (fichero exe, ejecutable) que permite su descompresión sin necesidad de utilizar cualquier otro programa. Puede seleccionar el tipo de módulo auto extraíble y establecer otros parámetros como la carpeta de destino en las Opciones avanzadas de este cuadro de diálogo.

Crear un archivo sólido

Crea un archivo sólido. Normalmente proporciona razones de compresión altas, pero impone algunas restricciones. Consulte la descripción de archivos sólidos para más detalles.

Añadir registro de recuperación"

Agrega el registro de recuperación, que puede ayudar a restablecer un archivo dañado. Puede especificar el tamaño del registro de recuperación en las Opciones avanzadas de este cuadro de diálogo. El valor predeterminado es un 3% del tamaño total del archivo.

Verificar ficheros comprimidos

Verifica los ficheros después de comprimir. Esta opción es especialmente útil si también tiene activada la opción "Eliminar los ficheros tras la compresión". En dicho caso los ficheros solo serán eliminados si se han verificado correctamente.

Bloquear el archivo

WinRAR no puede modificar un archivo bloqueado. Usted puede bloquear archivos importantes para evitar su modificación por accidente.

Establecer contraseña

Establece una contraseña para los ficheros comprimidos codificados. Sólo es válida durante una sola operación de compresión y anula la contraseña predeterminada introducida en el Menú Fichero. Si existe la contraseña predeterminada, se restablecerá una vez que la operación de compresión haya finalizado. Si no existía contraseña predeterminada antes de comenzar la compresión, tampoco existirá una vez se haya terminado la operación.


Cuadro de diálogo Nombre de archivo y parámetros

Este cuadro de diálogo aparece en pantalla al ejecutar la orden Agregar al archivo antes de agregar el fichero a un archivo.

Las opciones incluidas en este cuadro de diálogo se dividen en varios grupos separados. Seleccione uno de los siguientes elementos para consultar una descripción detallada del grupo:

  • General
  • Avanzado
  • Opciones
  • Ficheros
  • Copia de seguridad
  • Fecha y hora
  • Comentario


Cuadro de diálogo Nombre de archivo y parámetros: opciones

Modo de borrado

Las siguientes opciones modifican el comportamiento de la opción Eliminar ficheros depués de comprimir de la Opciones generales. Solo surten efecto si la opción Eliminar ficheros depués de comprimir esta activada. Puede activar cualquiera de estas opciones en el Perfil de compresión predeterminado para modificar el comportamiento de la opción Eliminar ficheros depués de comprimir.

Eliminar ficheros

Eliminar ficheros de forma normal. Los ficheros son eliminados de forma permanente pero no segura, de forma que a veces es posible recuperarlos usando programas especializados.

Mover ficheros a la Papelera

Los ficheros eliminados son enviados a la Papelera de Reciclaje.

Limpiar ficheros

Antes de ser eliminados los datos de los ficheros son sobreescritos con ceros para impedir que puedan ser recuperados incluso con programas especializados.

Por favor, tenga en cuenta que esta técnica esta diseñada para discos duros normales y puede no sobreescribir los datos del fichero original en discos de estado sólido como resultado del uso en estos discos de la tecnologia SSD wear leveling y otros sistemas de direccionamiento de datos mas complejos.

Limpiar ficheros protegidos con contraseña

Se esta opción esta activada y se comprimen ficheros protegidos con contraseña se activa el modo "Limpiar ficheros" independientemente de la configuración de las otras opciones en "Modo de borrado".

No tiene mucho sentido activarla directamente en la ventana de compresión porque puede sencillamente activar la opción "Limpiar ficheros". Esta opción esta pensada especificamente para usarla en los perfiles de compresión. Si prefiere eliminar siempre de forma segura los ficheros protegidos con contraseña puede activar esta opción en el perfil predeterminado de compresión.

Características del Archivo

Usar suma de control BLAKE2

Almacenar suma de control de fichros BLAKE2. Disponible solo para el formato de archivo RAR 5.0.

La integridad de los datos de los ficheros en archivos RAR esta protegida por sumas de control calculadas y almacenadas para cada fichero almacenado. Por defecto, WinRAR usa el algoritmo CRC32 para calcular la suma de control. El formato de compresión RAR 5.0 también permite seleccionar el algoritmo BLAKE2 además del CRC32.

El tamaño de la suma CRC32 es de 32 bits. Mientras que las propiedades del CRC32 son adecuadas para detectar la mayoría de los errores unintencionados, no es suficientemente confiable como para verificar la identidad de un fichero. En otras palabras, si dos ficheros tienen el mismo CRC32, esto no garantiza que el contenido de los dos ficheros sea identico.

El tamaño de la suma BLAKE2 es de 256 bits. Siendo un algoritmo criptograficamente mas fuerte practicamente garantiza que si dos ficheros tienen la misma suma BLAKE2, su contenido es el mismo. La faceta de detección de errores de BLAKEsp es además mucho mas confiable que la del CRC32.

Debido a que el tamaño del valor BLAKE2 es mayor, el tamaño resultante del archivo también es ligeramente mayor al usar esta opción.

Si las cabeceras de archivo no estan cifradas (no activa la opción Cifrar nombres de fichero) las sumas de control en ficheros cifrados RAR 5.0 se modifican usando un algortitmo que depende de la contraseña para hacer imposible que se pueda adivinar el contenido del fichero basandose en la suma de control. No espere que estas sumas de control cifradas se parezcan a los valores habituales del cRC32 y BLAKE2.

Guardar ficheros idénticos como referencias

Si se especifica esta opción, WinRAR analiza el contenido de los ficheros antes de iniciar la compresión. Si se encuentran varios ficheros idénticos, el primer fichero se almacena como un fichero normal y el resto de ficheros se alamacenan como referencias al primero. Esto permite reducir el tamaño del archivo pero requiere algunas restricciones sobre el archivo resultante. No debe eliminar o renombrar el primer fichero identico en el archivo una vez el archivo ha sido creado porque esto haría imposible la extracción de los siguiente archivos que lo usan como referencia. Si modifica el primer fichero los ficheros siguientes también verán su contenido modificado una vez extraídos. El proceso de extracción requiere el primer fichero para poder crear los siguientes correctamente.

Se recomienda usar esta opción solo si está comprimiendo muchos ficheros idénticos en un archivo que no va a modificar posteriormente y que va a extraer en su totalidad ni necesitar extraer descomprimir o omitir ficheros individuales. Si todos los ficheros idénticos son lo suficientemente pequeños para caber en el diccionario de compresión la compresión sólida puede proporcionar una solución mas flexible que esta opción.

Disponible solo para el formato de archivo RAR 5.0.

Información de acceso rápido

Los archivos RAR almacenan una cabecera para cada fichero que continene información como el nombre del fichero, la fecha, su tamaño y sus atributos inmediatamente antes de los datos del fichero descrito. Esta técnica es mas resistente a daños que almacenar todas las cabeceras de ficheros en un solo bloque continuo, que si es dañado o truncado destruye el contenido entero del archivo. Pero aunque son mas confiables, estas cabaceras de fichero esparcidas por todo el archivo son mas lentas de acceder si necesita tener abrir rapidamente el contenido del archivo en un entorno como la interface gráfica de WinRAR.

Para mejorar la velocidad al abrir archivos y evitar que el archivo entero sea vulnerable a un solo bloque dañado, los archivos RAR 5.0 pueden incluir un registro opcional de acceso rápido. Este registro se añade al final del archivo y contiene copia de los nombres de ficheros y otra información almacenada en un solo bloque continuo adicional a las otras cabeceras dentro del archivo. Al ser este bloque continuo su contenido puede leerse rapidamente sin la necesidad de efectuar una gran cantidad de operaciones de búsqueda en el disco. Si RAR detecta que esta información de acceso rápido esta dañada podrá acceder a leer las cabeceras individuales dentro del archivo de forma que la resistencia contra daños no se merma.

El registro de acceso rápido contiene una copia exacta de la cabecera de cada fichero, que puede llegar a ser de varias decenas o centenares de bytes por fichero, lo que incrementa el tamaño del archivo en la misma medida. Este aumento de tamaño se nota mas cuando hay muchos ficheros pequeños cuyo tamaño es comparable al tamaño de la cabecera. Así que por defecto, en el modo "Añadir para ficheros grandes", WinRAR almacena copias de las cabeceras solo para ficheros relativamente largos y continua usando cabaceras locales para ficheros perqueños. El tamaño límite puede depender de la versión de WinRAR. Esta técnica proporciona un balance razonable entre la velocidad de acceso y el tamaño del archivo. Si nprefiere obtener la máxima velocidad de acceso y no le importa el tamaño del archivo puede usar la opción "Añadir para todos los ficheros" para almacenar copia de todas las cabeceras de fichero. Si necesita tener el menor tamaño de archivo posible y no le importa la velocidad de acceso puede especificar la opción "No añadir" para excluir la información de acceso rápido completamente.

Si quiere medir el efecto de este modificador en la velocidad asegurese que el contenido del archivo no se almacene en la caché de disco. Si el archivo esta en la caché no se realizan búsquedas en disco reales, haciendo que el acceso a las cabeceras de fichero sean rápidas incluso sin el registro de acceso rápido.


Cuadro de diálogo Nombre de archivo y parámetros: opciones de fecha y hora

Opción "Fecha de modificación de alta precisión"

Si esta opción esta desactivada la fecha de modificación se almacena con una precisión de dos segundos. Esto es suficiente para sistemas de archivos FAT pero no para sistemas NTFS. Al activar esta opción aumenta ligeramente el tamaño del archivo, pero permite a WinRAR preservar la fecha del fichero con una precisión de 0.0000001 segundos.

En archivos ZIP la fecha de modificación de alta precisión se almacena en la misma estructura de datos que las fechas de creación y último acceso. De esta forma al activar esta opción al comprimir en archivos ZIP, WinRAR escribirá las tres fechas al archivo resultante. Incluso en este caso también podrá seleccionar las fechas a extraer en la pestaña "Advanzada" de las opciones de extracción. RAR alamacena estas fechas por separado.

Opciones "Guardar fecha de creación" y "Guardar fecha del último acceso "

Los sistemas Windows guardan tres fechas diferentes para cada fichero: última modificación, creación y último acceso. Por defecto WinRAR solo guarda la fecha de la última modificación, pero usando estas opciones puede hacer que WinRAR guarde las fechas de creación y último acceso. Puede ser de utilidad al realizar copias de seguridad. Esta característica solo esta soportada en archivos RAR. Los archivos ZIP siempre preservan estas fechas si se ha activado la opción "Fecha de modificación de alta precisión".

Tenga en cuanta que además necesitará activar las opciones "Establecer fecha de creación" y "Establecer fecha del último acceso " en la sección "Avanzada" del cuadro de diálogo de extracción para restaurar estas fechas al extraer ficheros.

Opción "Incluir ficheros: de cualquier fecha/ anteriores a/ posteriores a/modificados antes de/modificados después de"

El valor predeterminado de esta opción es "de cualquier fecha", de modo que WinRAR comprimirá todos los ficheros seleccionados independientemente de su fecha. Sin embargo, el cambiarlo a "anteriores a" o "posteriores a" obliga a WinRAR a comprimir sólo aquellos ficheros que se han modificado antes o después de un número de días, horas y minutos especificado. Por ejemplo, puede ser útil si sólo desea comprimir los ficheros modificados en los últimos 3 días. Usando "modificado antes" o "modificado después" puede escoger los archivos que se han modificado antes o después de la fecha especificada.

- Opción "Fijar la hora de archivo en: hora actual del sistema/ hora del archivo original/ hora del último fichero"

El valor predeterminado de esta opción es "hora actual del sistema", de modo que se le adjunta a cada archivo nuevo o modificado la hora actual del sistema como su fecha de modificación. No obstante, también puede seleccionar en esta opción "hora del archivo original" para impedir que la hora del archivo sea modificada o "hora del último fichero" para fijar como su fecha de modificación la del fichero más reciente del archivo.


Implementación AES de Brian Gladman

Brian Gladman's AES implementation

Las rutinas de cifrado de WinRAR usan partes del código fuente AES de Brian Gladman, el cual esta licenciado bajo las siguientes condiciones:

 ---------------------------------------------------------------------------
 Copyright (c) 2002, Dr Brian Gladman <                 >, Worcester, UK.
 Todos los derechos reservados.

 TERMINOS DE LA LICENCIA

 Se autoriza la distribución y el uso gratuitos del código fuente como de
 la forma binaria del software de AES (con o sin cambios) siempre que se
 cumplan las siguientes condiciones:

   1. Toda distribución del código fuente de AES debe incluir el aviso sobre
      derechos de autor anterior, esta lista de condiciones y la siguiente
      renuncia de responsabilidad;

   2. Toda distribución de la forma binaria debe incluir el aviso sobre
      derechos de autor anterior, esta lista de condiciones y la siguiente
      renuncia de responsabilidad en la documentación y/o otros materiales
      suministrados con la distribución;

   3. El nombre del propietario del copyright no debe usarse para promocionar
      productos construidos con el software de AES sin autorización expresa
      por escrito.

 ALTERNATIVAMENTE, y siempre que se publiquen estas condiciones completas,
 este producto puede distribuirse bajo los términos de la Licencia Pública
 General GNU (GPL), en cuyo caso se aplicarán las condiciones de la licencia
 GPL en SUBSTITUCION de estas.

 RENUNCIA DE RESPONSABILIDAD

 El software de AES se suministra 'tal cual', sin garantías explícitas ni tácitas
 con respecto a sus propiedades, incluidas a título enunciativo pero no limitativo,
 las garantías de exactitud e idoneidad para un determinado fin.
 ---------------------------------------------------------------------------

El código fuente de este paquete y otros enlaces de projectos de computación y tecnologia de cifrado pueden encontrarse en la página web de Brian Gladman's.


Cuadro de diálogo Opciones de archivo

Este cuadro de diálogo combina las órdenes siguientes: Proteger el archivo, crear volúmenes de recuperación , Bloquear el archivo. Sólo el formato de archivo RAR admite el uso de todas ellas.

Proteger un archivo puede ayudar a repararlo posteriormente en caso de pequeños daños físicos en la información del archivo. Si desea proteger un archivo de daños, necesita especificar un tamaño de registro de recuperación en porcentaje para el tamaño total del archivo. El valor máximo permitido es 100%. Si establece este campo como 0, el registro de recuperación no se agregará. Los registros de recuperación más grandes permiten la recuperación de daños más graves, pero, al mismo tiempo, aumentan el tamaño del archivo. Por tanto, probablemente 3 - 5% es el valor óptimo.

Un caso especial de protección de archivos es generar volúmenes de recuperación. Sólo es posible cuando el archivo abierto es el primero de una secuencia multivolumen , en este caso solo tiene que escoger el número de ficheros .rev a crear. También puede añadir un signo de porcentaje a este parámetro de forma que el número de ficheros .rev creados será igual a dicho porcentaje aplicado al número total de volúmenes RAR. Cada volumen de recuperación permite reconstruir un volumen perdido. Puede aprender más sobre esta característica aquí.

Si activa la opción "Desactivar las modificaciones de archivo", bloqueará el archivo. Esto quiere decir que WinRAR no podrá modificar ese archivo en el futuro. Puede bloquear archivos importantes para evitar que WinRAR los modifique accidentalmente.


Código fuente Info-ZIP

WinRAR incorpora el código fuente del grupo Info-ZIP, que es usado para manejar los ficheros ZIP. El código fuente original Info-ZIP esta disponible de forma gratuita en ftp://ftp.info-zip.org/pub/infozip/ y www.info-zip.org.

Licencia Info-Zip

This is version 2009-Jan-02 of the Info-ZIP license. The definitive version of this document should be available at ftp://ftp.info-zip.org/pub/infozip/license.html indefinitely and a copy at http://www.info-zip.org/pub/infozip/license.html.

Copyright (c) 1990-2009 Info-ZIP. All rights reserved.

For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White.

This software is provided "as is," without warranty of any kind, express or implied. In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the above disclaimer and the following restrictions:

  1. Redistributions of source code (in whole or in part) must retain the above copyright notice, definition, disclaimer, and this list of conditions.

  2. Redistributions in binary form (compiled executables and libraries) must reproduce the above copyright notice, definition, disclaimer, and this list of conditions in documentation and/or other materials provided with the distribution. Additional documentation is not needed for executables where a command line license option provides these and a note regarding this option is in the executable's startup banner. The sole exception to this condition is redistribution of a standard UnZipSFX binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this license, as long as the normal SFX banner has not been removed from the binary or disabled.

  3. Altered versions--including, but not limited to, ports to new operating systems, existing ports with new graphical interfaces, versions with modified or added functionality, and dynamic, shared, or static library versions not from Info-ZIP--must be plainly marked as such and must not be misrepresented as being the original source or, if binaries, compiled from the original source. Such altered versions also must not be misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP. Such altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or the Info-ZIP URL(s), such as to imply Info-ZIP will provide support for the altered versions.

  4. Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "UnZipSFX," "WiZ," "Pocket UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.


Algoritmo Intel Slicing-by-8 CRC32

WinRAR calcula el CRC32 usando una variación del algoritmo Intel Slicing-by-8.

El código fuente del algoritmo original Intel Slicing-by-8 esta disponible en sourceforge.net/projects/slicing-by-8 y esta licenciado bajo licencia BSD disponible en http://www.opensource.org/licenses/bsd-license.html y cuyo texto original se proporciona a continuación:

Copyright (c) 2004-2006 Intel Corporation.
All Rights Reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Licencia e información de compra

Seleccione uno de los siguientes temas:

  • Licencia WinRAR
  • Información de compra


Cuadro de diálogo "Organizar perfiles"

En este cuadro de diálogo, usted puede corregir algunos parámetros de perfiles de compresión existentes o eliminarlos. Aquí no puede crear un perfil nuevo. Los métodos para crear un perfil nuevo se describen en el tema Perfiles de compresión.

Para corregir los parámetros del perfil, necesita colocar el cursor en un nombre de perfil, hacer clic en "Editar" y establecer los parámetros en el cuadro de diálogo Parámetros de perfil según los valores deseados. Tenga en cuenta que no se pueden modificar las opciones de compresión almacenadas en el perfil, sólo puede modificar algunos de los parámetros relacionados con el perfil como su nombre y su estatus predeterminado. Si necesita modificar las opciones de compresión, deberá crear un perfil nuevo que posea el mismo nombre que el perfil existente.

Para eliminar un perfil, coloque el cursor en su nombre y haga clic en "Eliminar".

Use los botones "Mover arriba" y "Mover abajo" para cambiar la posición del perfil seleccionado en la lista

Puede encontrar fácilmente el perfil predeterminado en la lista de perfiles de este cuadro de diálogo, tienen el pequeño icono de WinRAR ("libros") a la izquierda de su nombre.


Diálogo "Organizar temas"

Este cuadro de diálogo permite organizar los temas de WinRAR.

Pulse "Seleccionar" para activar el tema bajo el cursor. Use “Añadir” para instalar un nuevo tema. “Eliminar” elimina el tema y todos los ficheros relacionados del disco de forma que dejará de estar disponible.

La opción "Aplicar a iconos de archivo " es global para todos los temas. Si se desactiva, los temas solo modificarán los gráficos de WinRAR pero no cambiarán los iconos de los archivos RAR, ZIP y de los otros formatos soportados. Si se activa, además de los gráficos de WinRAR, también se modificarán los iconos de los archivos soportados. A diferencia de las otras órdenes de este cuadro de diálogo, es necesario pulsar “Aceptar” para aplicar los cambios de esta opción.


Organize passwords

Organizar contraseñas

La ventana "Organizar contraseñas" proporciona una forma de almacenar las contarseñas usadas mas frecuentemente y poder acceder a ellas rapidamente. Contiene la lista de contraseñas guardadas por el usuario. Normalmente se muestran en esta lista las etiquetas de las contraseñas y las mascaras de fichero, pero si no se ha definido ninguna etiqueta, se muestra la contraseña en la columna "etiqueta".

Puede abrir la ventana "Organizar contraseñas" desde la ventana que pide la contraseña pulsando el botón "Organizar contarseñas ..." cuando entra la contraseña predeterminada o cuando WinRAR le pide la contraseña para acceder a un archivo cifrado.

Por favor tenga en cuenta que las contraseñas se almacenan en el Registro de Windows en texto plano sin cifrar de forma que cualquier persona con acceso a su ordenador puede verlas. Aunque este organizador de contraseñas puede hacer mas facil trabajar con contraseñas tiene que considerar seriamente los riesgos de seguridad que implica. Si la información que esta cifrando es sensitiva y confidencial intente evitar usar esta característica o usela solo si su ordenador esta protegido convenientemente contra accesos no autorizados.

Pulse el botón "Añadir" para añadir una nueva contraseña a la lista en la posición posterior al cursor. Esto abrirá el Cuadro de diálogo información de contraseña donde podrá especificar la contraseña, su etiqueta y la mascara de archivos. Lea la información sobre el Cuadro de diálogo información de contraseña para mas detalles sobre estas opciones.

El botón "Eliminar" elimina todas las contraseñas seleccionadas. Use el botón "Editar" para modificar los parámetros de la contraseña seleccionada con el cursor en el Cuadro de diálogo información de contraseña. "Mover arriba" y "Mover abajo" cambian la posición de todas las contraseñas seleccionadas.

La opción "Activar autocompletado" permite activar la función de autocompletado en la ventana de contraseñas. Cuando esta activada es suficiente con entrar las primeras letras de la contraseña o de su etiqueta para que WinRAR sugiera automaticamente las contraseñas coincidentes. La función de autocompletado funciona solamente si esta activada la opción "Mostrar contraseña" en la ventana de contraseña. Si las contraseñas esta ocultas la función de autocompletado se desactiva automaticamente. Si se ha definido una etiqueta para las contraseñas almacendas la función de autocompletado solo funcionara para las etiquetas y no para las contraseñas.

Cuando haya acabado con las modificaciones en "Organizar contraseñas" necesitara pulsar el botón "OK" para guardar los cambios.

Puede acceder a las contraseñas guardadas usando la lista desplegable asociada a "Entrar contraseña" o usando la función de autocompletado.


Confirmar la sobrescritura de fichero

El fichero ya existe. Puede sobrescribirlo ( botón Sí), omitirlo (botón No), Renombrar, Renombrar todos los ficheros, sobrescribir todos los ficheros (botón Sí a todo), omitir todos los ficheros existentes (botón No a todo ) o Cancelar la operación actual.

Si selecciona el modo Renombrar todos los ficheros, los ficheros renombrados tendrán nombres del tipo 'fichero(N).txt', donde 'fichero.txt' es el nombre original y 'N' es un número.


Cuadro de diálogo "Parámetros del perfil"

En este cuadro de diálogo, usted puede describir un perfil de compresión nuevo o corregir los parámetros de un perfil existente. Contiene los siguientes elementos:

Nombre del perfil

El nombre del perfil es una cadena de texto que describe el perfil. Puede estar formado por caracteres de espacio. Por ejemplo, el nombre "Crear un fichero adjunto para correo" es válido. Es recomendable conferir nombres acertados a los perfiles, simplifica su identificación y su manejo. Este campo es necesario y no se puede dejar vacío.

Guardar el nombre del archivo

Si esta opción está activada, se guarda en el perfil el nombre de archivo especificado en el campo que se sitúa debajo y se restablecerá al seleccionar este perfil. Si la opción está desactivada, WinRAR propondrá un nombre de archivo como de costumbre.

Guardar los nombres de ficheros seleccionados

Si esta opción está activada, los nombres de fichero especificados en el campo situado debajo se guardan en el perfil. De modo que, si usted selecciona el perfil más tarde, WinRAR comprimirá los ficheros guardados en el perfil en vez de los seleccionados antes de activar el perfil.

En un principio, este campo contiene los nombres de los ficheros seleccionados en ese momento en la lista de fichero WinRAR; sin embargo, usted puede corregirlos o introducir nombres nuevos. Se permiten nombres de carpeta y caracteres comodín. Por ejemplo, puede crear un perfil que contenga "C:\" como el nombre de fichero seleccionado para hacer la copia de seguridad de todo el disco C:

Si esta opción está desactivada, WinRAR comprimirá los ficheros seleccionados en ese momento.

Establecer el perfil como predeterminado

Si se marca un perfil como predeterminado, será seleccionado automáticamente al abrir el cuadro de diálogo Nombre de archivo y parámetros antes de cada operación de compresión. Es conveniente crear un perfil predeterminado con sus opciones favoritas de compresión de modo que no necesite establecerlas cada vez. Sólo se puede establecer un perfil como predeterminado. Si no hay ningún perfil marcado como predeterminado, el conjunto estándar de opciones de compresión iniciará el cuadro de diálogo de compresión.

Algunos de los parámetros del perfil de compresión predeterminado además de usarse al comprimir también se usan en otras operaciones que modifican archivos, como eliminar o renombrar ficheros. En este caso WinRAR lee solo los parámetros que son aplicables a cada caso. El proceso de extracción no usa ningún parámetro del perfil de comrpesión predeterminado.

Ejecución inmediata

Si selecciona un perfil con el parámetro Ejecución inmediata activado, la operación de compresión comenzará inmediatamente sin ninguna posibilidad de modificar la configuración de compresión o el nombre de archivo. Puede ser útil para las operaciones de compresión habituales porque no necesita hacer clic en "Aceptar" todas las veces una vez haya seleccionado ese perfil.

Crear acceso directo en el Escritorio

Esta opción sólo está disponible si antes se ha activado Guardar los nombres de fichero seleccionados. Si se ha seleccionado, WinRAR creará el icono con un nombre de perfil en el Escritorio de modo que usted podrá activar el perfil más tarde con tan solo hacer clic sobre dicho icono. Por ejemplo, usted puede crear un perfil para hacer una copia de seguridad de sus datos y colocar su icono en el Escritorio para simplificar esta operación.

Añadir al menú contextual

Si esta opción esta activada, el nombre del perfil se mostrará en los menús contextuales del explorador de Windows permitiendo activar el perfil para los elementos seleccionados. Si también activa la opción Ejecución inmediata la compresión se iniciará inmediatamente después de seleccionar un perfil en el menú contextual. Si Ejecución inmediata no esta activada, se mostrará primero la ventana Nombre de archivo y parámetros. Si la opción Guardar nombre de archivo esta activada, WinRAR usará el nombre de archivo guardado para el nuevo archivo. Si la opción Guardar los nombres de ficheros seleccionados esta activada tanto los ficheros sleccionados en el perfil como los que haya seleccionado en el Explorador se añadirán al archivo.


Cuadro de diálogo Información de contraseña

Se accede al Cuadro de diálogo "Información de contraseña" al pulsar "Añadir" o "Editar" desde la ventana "Organizar contraseñas". Sirve tanto para especificar la información de una nueva contraseña como para editar la información de una contraseña existente. Esta información incluye la propia contraseña, su etiqueta, la mascara de archivo en "Seleccionar archivos" y la opción "Aceptar sin confirmación".

El campo "Contraseña" es el unico obligatorio. debe contener la contarseña a almacenar.

Puede usar el campo "Etiqueta" si no quiere que la contraseña real sea visible en la ventana de contraseña. Puede especificar aquí una etiqueta para la contraseña y usar esta etiqueta en vez de la contraseña real cada vez que WinRAR le pida una contraseña. WinRAR usará la contraseña asociada en vez de la etiqueta de forma automática. WinRAR le informará cuando entre una etiqueta mostrando el mensaje "Etiqueta de contraseña" sobre el campo de entrada de la contraseña.

Por ejemplo, puede definir Fhtfl34Shu como la contraseña y casa como su etiqueta. Despues de esto podrá usar casa en vez de Fhtfl34Shu. Esta substitución solo funciona al entrar contraseñas desde el entorno gráfico y no afecta a la opción -p[pwd] en el modo de línea de ordenes.

Las etiquetas deben ser únicas. No pueden ser iguales que ninguna otra etiqueta ni que ninguna otra contraseña. Las etiquetas no son sensibles a mayúsculas y minúsculas, de forma que casa y Casa se consideran la misma etiqueta.

Si define ambas cosas, contraseña y etiqueta, la etiqueta se mostrará en la columna "Etiqueta" de la lista de contraseñas en "Organizar contraseñas". Si solo define la contraseña, se mostrará en vez de la etiqueta en esta lista.

En el campo "Seleccionar archivos" puede incluir uno o varios nombres de archivo o mascaras (solo para el nombre, sin la ruta) separadas por espacios. Si el nombre de archivo contiene espacios tendrá que encerrarlo con comillas. Si al descomprimir el nombre del archivo cifrado coincide con alguna de estas mascaras, WinRAR seleccionará esta contraseña automaticamente. Si la opción "Aceptar sin confirmación" esta desactivada esta contraseña se usará como la contraseña predeterminada pero el usuario tendrá la posibilidad de cambiarla. Si esta opción esta activada la contraseña se usará inmediatamente.

Por ejemplo, si especifica MailDGWT58 como contraseña y mymail*.rar mymail*.zip en "Seleccionar archivos", MailDGWT58 se seleccionará automaticamente como la contraseña al descomprimir archivos mymail*.rar y mymail*.zip. Esta opción solo funciona solo para descomprimir y no para comprimir.

Por favor tenga en cuenta que las contraseñas se almacenan en el Registro de Windows en texto plano sin cifrar de forma que cualquier persona con acceso a su ordenador puede verlas. Aunque este organizador de contraseñas puede hacer mas facil trabajar con contraseñas tiene que considerar seriamente los riesgos de seguridad que implica. Si la información que esta cifrando es sensitiva y confidencial intente evitar usar esta característica o usela solo si su ordenador esta protegido convenientemente contra accesos no autorizados.


"Resultados de la búsqueda"

Este diálogo contiene los elementos encontrados por la orden Buscar ficheros. Puede seleccionar uno o varios ficheros y luego pulsar el botón “Extraer en” para descomprimirlos. También puede pulsar el botón “Ver” para ver el fichero seleccionado o “Localizar” para posicionar el cursor en este fichero en la ventana principal de WinRAR.

Debido a limitaciones técnicas las operaciones con los ficheros encontrados se inician con cierto retraso si la búsqueda continua aun activa. WinRAR ejecutará la orden solo cuando el archivo en proceso actualmente esté cerrado.


Cuadro de diálogo "Opciones avanzadas SFX"

Cuadro "Opciones avanzadas SFX"

Este cuadro de diálogo se puede activar con la orden Convertir archivo en SFX haciendo clic en "Opciones avanzadas SFX…". Permite especificar una serie de parámetros de archivo autoextraíble como la ruta de destino predeterminada, el título de ventana y el texto. Genera automáticamente un guión utilizando las órdenes descritas en el tema dedicado a los módulos SFX para Windows. De este modo, usted no necesita aprender este tipo de lenguaje ni introducir manualmente las órdenes, tan sólo tendrá que establecer las opciones deseadas.

Tenga en cuenta que el uso de los parámetros SFX sólo se permite en el módulo GUI (gráfico) Windows y que no son compatibles con consola o con SFX que no pertenezcan a Windows.

Los parámetros SFX de este cuadro de diálogo se combinan con algunos subdiálogos descritos a continuación:

  • Opciones SFX: General
  • SFX options: Instalación
  • Opciones SFX: Modos
  • Opciones SFX: Avanzado
  • Opciones SFX: Actualizar
  • Opciones SFX: Texto e icono
  • Opciones SFX: Licencia
  • Opciones SFX: Módulo


Órdenes SFX: Delete

Delete=<nombre de fichero>

Elimina el fichero especificado en la carpeta de destino antes de la extracción. Se permiten varias órdenes Delete.

Si un fichero especificado en la orden Delete está bloqueado y no se puede eliminar, el módulo auto extraíble intentará renombrarlo con un nombre temporal antes de realizar la extracción y eliminarlo tras reiniciar Windows. El éxito de esta operación depende de la versión de Windows.

Ejemplo:

Delete=winrar95.exe

Delete=rarlng.dll


Órdenes SFX: License

License=<título del cuadro de diálogo de licencia>

{

texto de licencia1

texto de licencia2

…

}

Muestra en pantalla la licencia del software al iniciar el auto extraíble. El usuario puede aceptarla y continuar la extracción o rechazarla y salir.

El texto de la licencia puede ser texto normal o HTML. El módulo auto extraíble fusiona y vuelve a dar formato a la cadena de texto especificada para que se ajuste perfectamente al cuadro de diálogo. Por tanto, necesita colocar la cadena vacía antes del párrafo si desea comenzar uno nuevo.

En el texto de salida, se reconocen y se procesan algunas etiquetas HTML. La especificación de la sintaxis HTML esta disponible en la página web del The World Wide Web Consortium. Puede usar cualquier editor de páginas web para preparar el texto.

Si el texto consiste en varias líneas, el modulo auto extraíble considera el carácter ‘}’ como el marcador del final del texto, de forma que no debe usarlo en la primera posición de ninguna línea de texto. Si necesita usar este carácter al principio de alguna línea de texto, por favor, inserte un espacio al principio

Ejemplo:

License=Poner fin al acuerdo de licencia del usuario

{

Todos los derechos de autor de RAR son de propiedad exclusiva del autor.

Este programa es shareware. Todo aquel que lo desee puede utilizar este software durante un periodo de prueba.

Tras ese periodo de prueba, DEBERÁ registrarse.

}


Opciones SFX: Avanzado

Este cuadro es una parte del cuadro "Opciones avanzadas SFX" e incluye la siguiente configuración:

Ficheros para eliminar de la carpeta de destino

SFX intentará eliminar el fichero o los ficheros especificados en la carpeta de destino antes de la extracción. Aquí puede introducir más de un fichero, en ese caso, los nombres de fichero deben ir separados por espacios.

Si un fichero especificado aquí está bloqueado y no se puede eliminar, el módulo SFX intentará renombrarlo con un nombre temporal antes de la extracción y eliminarlo tras reiniciar Windows. El éxito de esta operación depende de la versión de Windows.

Orden SFX correspondiente: Delete

Accesos directos

Permite crear accesos directos a ficheros comprimidos después de su extracción. Pulse "Añadir acceso directo" para describir un nuevo acceso directo. Los parámetros de los accesos directos ya entrados se almacenan en la lista bajo el botón en el mismo formato descrito en la orden Shortcut. Si lo desea también puede editarlos aquí manualmente.

Orden SFX correspondiente: Shortcut

Solicitar acceso como administrador

Active esta opción si quiere crear un archivo auto-extraíble que solicite acceso como administrador cuando se ejecute en Windows Vista o versiones posteriores de Windows. Esta opción no tiene nin gún efecto cuando el auto-extraíble se ejecuta en versiones anteriores de Windows.

La opción equivalente de la línea de órdenes es -iadm.


Opciones SFX: General

Este cuadro de diálogo es una parte del cuadro de diálogo "Opciones avanzadas SFX" e incluye la siguiente configuración:

Ruta de extracción

Establece la ruta de destino predeterminada para los ficheros descomprimidos. Puede escoger entre crearla en la carpeta de usuario "Ficheros de programa", crearla en la carpeta actual o especificar aquí una ruta completa. En los dos primeros casos, la ruta introducida no debe incluir la letra de la unidad ni la barra invertida inicial. En el tercero, debe tener una de ellas.

Orden SFX correspondiente: Path

Ruta de extracción/Guardar y restaurar rutas

Esta opción permite al modulo SFX almacenar la ruta de destino especificada por el usuario en el Registro de Windows y luego restaurarla cuando se ejecute otro archivo SFX con la misma ruta en la opción Ruta de extracción. La ruta original se añade a la lista asociada con el campo de entrada de la ruta de destino de forma que el usuario pueda escoger entre la ruta recuperada del registro y la definida en el módulo SFX.

Esta característica es útil para instalar nuevas versiones o actualizaciones del mismo programa en la misma carpeta ya que permite cambiar la ruta propuesta a la deseada sólo una vez y no tener que teclearla cada vez.

Sólo puede usarse en combinación con una ruta no vacía en la opción Ruta de extracción.

Orden SFX correspondiente - SavePath

Guardar esta configuración como predeterminada

Guarda las configuraciones introducidas en todas las secciones del cuadro de diálogo "Opciones SFX avanzadas", incluso la de esta sección y, más tarde, las utiliza como predeterminadas cada vez que crea un archivo autoextraíble.


Opciones SFX: Licencia

Este cuadro es una parte del cuadro "Opciones avanzadas SFX" e incluye la siguiente configuración:

- Título de la ventana de licencia

Establece como un título de la ventana de licencia el texto especificado.

Orden SFX correspondiente: License

- Texto de la licencia

Muestra en pantalla el texto especificado como si fuese una licencia de software al iniciar SFX. El usuario puede aceptarla y continuar la extracción o rechazarla y salir.

El texto puede ser texto normal o HTML. En el último caso el módulo SFX fusiona y vuelve a dar formato a la cadena de texto especificada para que se ajuste perfectamente al cuadro de diálogo. Por tanto, necesita situar la cadena vacía antes del párrafo si desea comenzar uno nuevo.

En el texto de salida, se reconocen y se procesan algunas etiquetas HTML. La especificación de la sintaxis HTML esta disponible en la página web del The World Wide Web Consortium. Puede usar cualquier editor de páginas web para preparar el texto.

Orden SFX correspondiente: License


Opciones SFX: Modos

Este cuadro es una parte del cuadro "Opciones avanzadas SFX" e incluye la siguiente configuración:

Modo temporal/Descomprimir en una carpeta temporal

Esta opción obliga al módulo SFX a crear una carpeta temporal, extraer todos los ficheros en ella, iniciar el programa especificado en el campo Programa de Instalación/ Ejecutar tras la extracción y a eliminar la carpeta temporal y todo su contenido una vez completado el programa de instalación. El SFX usa automáticamente el modo oculto (descrito a continuación) cuando realiza estas operaciones pero puede desactivarlo especificando el modo silencioso "Ocular todo". La carpeta temporal con los ficheros extraídos se establece como la carpeta actual para el programa de instalación.

También puede establecer dos parámetros opcionales, que definen la pregunta y el título de pregunta que aparece en pantalla después de la extracción. En esos casos, sólo se inicia la extracción si el usuario hace clic en "Sí".

Si la opción "Descomprimir en una carpeta temporal" está activada, también deberá especificar el programa de Instalación y no utilizar el campo Ruta de extracción en este modo.

Esta opción puede fallar con programas de instalación que finalizan antes que sus procesos hijos. Por favor, lea la descripción de la orden TempMode para mas detalles.

Orden SFX correspondiente: TempMode

Mostrar

Por defecto, el módulo SFX pide confirmación al iniciar la extracción y permite al usuario cambiar la carpeta de destino. Si cambia la opción "Mostrar" por "Ocultar el diálogo de inicio", se omitirá esa confirmación. Seleccione "Ocultar todo" si también desea ocultar la ventana de la licencia y el progreso de la extracción.

Orden SFX correspondiente: Silent


Opciones SFX: Modulo

Este dialogo es parte del dialogo "Opciones Avanzadas" y permite escoger el modulo auto-extraíble. No todos los módulos soportan opciones avanzadas, solo están soportadas por los módulos gráficos RAR y ZIP (Default.SFX y Zip.SFX), pero no por el modulo RAR para consola (WinCon.SFX).


Opciones SFX: Instalación

Este dialogo es parte de la ventana "Opciones SFX avanzadas" e incluye las siguientes opciones:

Programa de instalación/Ejecutar tras la extracción

SFX intentará ejecutar el programa especificado después de una extracción correcta. Antes de ejecutar el programa, se establece como carpeta actual la que contiene los ficheros extraídos. Si el nombre del programa contiene espacios deberá encerrarse con comillas.

Se permite especificar aquí varios programas de instalación, uno por línea. Si no desea ejecutarlos todos simultaneamente active la opción "Esperar y devolver código de retorno".

Lea las notas sobre el tema Setup para conocer detalles adicionales.

Orden SFX correspondiente: Setup

Programa de instalación del programa/Ejecutar antes de la extracción

SFX intentará ejecutar el programa especificado antes de comenzar la extracción, de forma que este programa debe existir previamente en el disco. Antes de ejecutar el programa, se establece como carpeta actual la de destino. Si el nombre del programa contiene espacios deberá encerrarse con comillas. Puede utilizar esta orden, por ejemplo, para eliminar una versión anterior de un programa al instalar una nueva versión encima de la antigua.

Se permite especificar aquí varios programas de instalación, uno por línea. Si no desea ejecutarlos todos simultaneamente active la opción "Esperar y devolver código de retorno".

Orden SFX correspondiente: Presetup

Programa de instalación/Esperar y devolver código de retorno

Si esta opción esta activada, el SFX espera la finalización del programa de instalación y devuelve el códigod e retorno del programa de instalación incrementado en 1000 como código de retorno del propio SFX.

Si el SFX falla al ejecutar el programa de instalación debido a algún error, devuelve su propio código de error, que son los mismos códigos de error de WinRAR que siempre son menores que 1000. Puede leer el tema de ayuda SetupCode para obtener mas información.

Orden SFX correspondiente - SetupCode


Opciones SFX: Texto

Opciones SFX: Texto e Icono

Este cuadro es una parte del cuadro "Opciones avanzadas SFX" e incluye la siguiente configuración:

Título de la ventana SFX

Establece como un título de la ventana SFX el texto especificado.

Orden SFX correspondiente: Title

Texto a mostrar en la ventana SFX

Muestra el texto especificado en la ventana SFX.

El módulo SFX fusiona y vuelve a dar formato a la cadena de texto especificada para que se ajuste perfectamente al cuadro de diálogo. Por tanto, necesita situar la cadena vacía antes del párrafo si desea comenzar uno nuevo.

En el texto de salida, se reconocen y se procesan algunas etiquetas HTML. La especificación de la sintaxis HTML esta disponible en la página web del The World Wide Web Consortium. Puede usar cualquier editor de páginas web para preparar el texto.

Orden SFX correspondiente: Texto

Cargar logotipo SFX desde fichero

Permite especificar una imagen de mapa de bits (*.bmp) para mostrar como logotipo en los archivos SFX creados o modificados.

El tamaño del logotipo por defecto es de 93x302 pixels. Se recomienda usar imágenes del mismo tamaño o inferior.

No debe comprimir el modulo SFX usando ningún tipo de compresor de ejecutables si va a usar esta opción.

La orden correspondiente en modo de línea de órdenes es -iimg.

Cargar icono SFX desde fichero

Cambia el icono estándar del archivo autoextraíble por el contenido en el fichero .ico. No debe comprimir el modulo SFX usando ningún tipo de compresor de ejecutables si va a usar est opción.

La orden correspondiente en modo de línea de órdenes es -iicono.


Opciones SFX: Actualizar

Esta pestaña es parte de la ventana "Opciones SFX avanzadas" e incluye las siguientes opciones:

Modo de actualización/Extraer y reemplazar ficheros

Extraer absolutamente todos los ficheros.

Modo de actualización/Extraer y actualizar ficheros

Extraer solo aquellos ficheros que no esten ya presentes en la carpeta de destino o que sean mas nuevos que los existentes.

Corresponde a la órden de script SFX - Update=U

Modo de actualización/Refrescar solo ficheros existentes

Extraer solo aquellos ficheros que existan en la carpeta de destino y sean mas nuevos que los existentes. Si algún fichero no esta ya presente en la carpeta de destino no será procesado.

Corresponde a la órden de script SFX - Update=F

Modo de sobreescritura/Preguntar antes de sobreescribir (por defecto)

Preguntar antes de sobreescribir algún fichero.

Modo de sobreescritura/Sobreescribir todos los ficheros

Los ficheros que ya existen en la carpeta de destino son sobreescritos sin preguntar.

Corresponde a la órden de script SFX - Overwrite=1

Modo de sobreescritura/Omitir ficheros existentes

No sobreescribir ficheros que ya existan en la carpeta de destino.

Corresponde a la órden de script SFX - Overwrite=2


Órdenes SFX: Overwrite

Overwrite=[n]

Si 'n' es 0, se le preguntará al usuario antes de sobrescribir ficheros existentes. Es el funcionamiento predeterminado y no es necesario especificar la orden Overwrite para ello. Si no existe 'n' o es igual a '1', todos los ficheros se sobrescriben sin pedir confirmación. Si 'n' es igual a '2', no se sobrescribirá ninguno de los ficheros existentes.

Ejemplo:

Overwrite=1


Órdenes SFX: Path

Path=<ruta de acceso>

Establece la ruta de destino predeterminada para los ficheros descomprimidos. Las rutas completas que empiezan por '<letra de la unidad>:'se utilizan sin ningún cambio. Si <ruta de acceso> sólo contiene un nombre, se agregará a la ruta de la carpeta de "Ficheros de programa". Si usted desea desactivar este funcionamiento y crear la carpeta especificada en la carpeta actual, inicie la definición de <ruta de acceso> por los caracteres '.\'.

Ejemplos:

a) Establezca la ruta predeterminada para "Ficheros de programa\ Calc 3,05"

Path=Calc 3,05

b) Establezca la ruta predeterminada para "C:\Calc":

Path=C:\Calc

c) Establezca la carpeta "Calc" sin ningún tipo de texto que le preceda como ruta predeterminada:

Path=.\Calc


Órdenes SFX: Presetup

Presetup=<programa>

El auto extraíble intentará ejecutar <programa> antes de iniciar la extracción y es necesario que este programa ya exista en el disco antes de la extracción. La carpeta de destino se establece como carpeta actual antes de ejecutar <programa>. Por ejemplo, puede utilizar esta orden para eliminar una versión anterior de un programa al instalar una nueva versión encima de la antigua. Si el nombre del programa contiene espacios debe estar encerrado por dobles comillas.

Ejemplo:

Presetup=uninstall.exe /clean

Notas

  1. El módulo autoextraíble muestra el botón "Extraer" en vez de "Instalar" si no se especifica ninguna orden Setup o Presetup en el comentario de archivo. Si prefiere que se muestre el botón "Instalar" puede añadir la orden Setup sin parámetros.


Órdenes SFX: ejemplo

El siguiente guión establece el título de cuadro de diálogo como "Calculator 3,05", modifica el texto mostrado en el cuadro de diálogo, establece la ruta de extracción predeterminada en "Ficheros de programa\ Calculator", activa la sobrescritura de los ficheros existentes y ejecuta setup.exe tras extraer todos los ficheros.

Title=Calculator 3,05

Text

{

Calculator es shareware. Todo aquel que lo desee puede utilizar este

software durante un periodo de prueba de 40 días.

Al finalizar este periodo, si desea

continuar utilizando Calculator, DEBERÁ registrarse.

}

Path=Calculator

Overwrite=1

Setup=setup.exe


Orden SFX: SavePath

Órdenes SFX: SavePath

SavePath

Esta orden permite al módulo SFX guardar la ruta de destino especificada por el usuario en el Registro de Windows y luego restaurarla cuando otro archivo SFX con el mismo valor en la orden Path sea ejecutado. El valor original de la orden Path se añade a la lista asociada al campo para la ruta de destino de forma que el usuario pueda escoger entre el valor que especifico anteriormente o el original definido en el modulo SFX.

Esta característica es útil para instalar nuevas versiones o actualizaciones de un programa en la misma carpeta ya que permite cambiar la carpeta propuesta por la deseada solo una vez sin tenerla que teclear de nuevo.

La orden SavePath solo puede usarse en combinación con la orden Path.

Ejemplo:

Path=Calc 3.05

SavePath


Órdenes SFX: Setup

Setup=<programa>

El auto extraíble intentará ejecutar <programa> tras realizar la extracción correctamente. Se establece como carpeta actual antes de ejecutar <programa> la que contiene los ficheros extraídos. Si el nombre del programa contiene espacios entonces debe estar encerrado por dobles comillas.

Ejemplo:

Setup=setup.exe

Notas

  1. Si tiene problemas al ejecutar el setup.exe de InstallShield, intente ejecutar "setup.exe /SMS" en lugar de usar simplemente "setup.exe". Este parámetro permite que el módulo auto extraíble detecte el cese del programa de instalación de InstallShield.
  2. Puede usar el parámetro SFX de la línea de órdenes -sp<par> para pasar parámetros opcionales al programa para la orden Setup=<program>
  3. El módulo autoextraíble establece la variable de entorno sfxname y sfxcmd antes de ejecutar el programa de instalación. La variable sfxname contiene el nombre del archivo auto extraíble y la variable sfxcmd contiene la línea de órdenes completa recibida por el módulo auto-extraíble. El primer parámetro de esta orden es el nombre del m´doluo SFX. El programa de instalación pueda leer esta información si le es necesario.
  4. El módulo autoextraíble muestra el botón "Extraer" en vez de "Instalar" si no se especifica ninguna orden Setup o Presetup en el comentario de archivo. Si prefiere que se muestre el botón "Instalar" puede añadir la orden Setup=<> o si lo esta configurando desde la ventana de Opciones SFX, especifique <> como nombre del programa de instalación. El módulo SFX no intentará ejecutar ningún programa con este nombre pero mostrará el botón "Instalar".


Ordenes SFX: SetupCode

SetupCode

Si esta orden esta presente, el módulo SFX archive espera hasta que el programa especificado en Setup o Presetup haya finalizado y utiliza su código de retorno incrementado en 1000 para el código de retorno del archivo SFX.

Si el SFX falla al ejecutar el programa de instalación debido a algún error, devuelve sus propios códigos de error, que son los mismos que los códigos de retorno de WinRAR. Por ejemplo, si la ejecución del SFX falla debido a un error en la suma de control, el proceso SFS devuelve un 3. Si el SFX inicia con éxito la aplicación de instalación y esta finaliza con el código cero, el SFX devolverá 1000. Si el programa de instalaciñon devuelve 10, el SFX devuelve 1010.

De esta forma si ha especificado SetupCode y el código de retorno del SFX es menor de 1000 es que algo ha ido mal y el programa de instalación nisiquiera llegó a iniciarse. Si el programa de instalación usa el código de retorno 0 para indicar la finalización correcta entonces el SFX devuelve 1000 indicando la finalización correcta y cualquier otro valor indica algún fallo.

Si se usan varias ordenes Setup y Presetup y SetupCode esta presente, el SFX esperará a que todos las órdenes Setup y Presetup finalizen y devolverá el código de retorno más alto devuelto entre todas las aplicaciones.

Ejemplo

Setup=instalar.exe

SetupCode


Órdenes SFX: Shortcut

Shortcut=<Tipo>,<Origen>,<Carpeta>,<Descripción>,<Nombre>,<Icono>

Crea un acceso directo a un fichero descomprimido.

Tipo es un carácter que puede tener los siguientes valores:

D | Crear el acceso directo en el Escritorio
P | Crear el acceso directo en el Menú de Inicio/Programas
T | Crear el acceso directo en la carpeta de Inicio

Origen es el nombre del fichero comprimido al que apuntará el acceso directo.

Carpeta es el nombre de la carpeta donde crear el acceso directo, si no existe será creada.

Descripción es el texto que describe el acceso directo.

Nombre es el nombre del fichero .lnk creado por el modulo auto extraíble.

Icono es el nombre del fichero .ico asociado al acceso directo. Si omite este parámetro se usará el icono predeterminado. Si el nombre del fichero no contiene la trayectoria completa el módulo SFX buscará el icono en la carpeta en la que se han descomprimido los ficheros.

Los parámetros se separan por comas. Si necesita poner el carácter coma dentro de algún parámetro debe encerrar el parámetro entero con comillas. Solo Tipo y Origen son obligatorios, los demás parámetros son opcionales.

Ejemplo

Crear un acceso directo en el Escritorio en la carpeta WinRAR al fichero comprimido WinRAR.exe con la descripción "fichero ejecutable WinRAR" , llamado "El compresor WinRAR" y con el icono winrar.ico:

Shortcut=D, winrar.exe, WinRAR, "fichero ejecutable WinRAR", "El compresor WinRAR", winrar.ico


Órdenes SFX: Silent

Silent[=Parám]

Inicia la extracción sin mostrar en pantalla el diálogo de inicio.

Parám puede ser 1 o 2.

Si Parám es 1, el diálogo de inicio está completamente oculto, incluyendo la barra de progreso y los nombres de fichero. En este modo el módulo SFX tampoco muestra la venta de la licencia.

Si Parám no se especifica o es 2, se omite la confirmación para comenzar la extracción; sin embargo, los usuarios pueden ver aún así el transcurso de la descompresión del archivo.

Ejemplo

Silent=2


Órdenes SFX: TempMode

TempMode=[Pregunta],[Título]

Esta orden obliga al módulo auto extraíble a crear una carpeta temporal, a extraer todos los ficheros en ella, a iniciar el programa especificado en la orden Setup y a eliminar la carpeta temporal con su contenido una vez completado el programa Setup. El módulo auto extraíble establece automáticamente el modo oculto para omitir el diálogo de inicio al realizar estas operaciones pero puede cambiarlo usando la orden Silent con otro valor. La carpeta temporal con los ficheros extraídos se establece como carpeta actual para el programa de instalación.

La orden TempMode puede tener el parámetro opcional de texto que se utiliza para definir una pregunta y el título de la pregunta mostrada en pantalla antes de la extracción. En ese caso, la extracción sólo se inicia si el usuario hace clic en "Sí".

Si la orden TempMode está presente, también deberá incluir la orden Setup. La orden Path se ignora en este modo.

Con TempMode el SFX necesita detectar la finalización del programa de instalación para poder eliminar los ficheros temporales. Esta funcionalidad funciona bien si el programa de instalación no finaliza antes de haber completado la instalación. A veces el programa de instalación crea un proceso hijo para completar la instalación, en estos casos el SFX elimina los ficheros temporales inmediatamente despues de detectar que el programa principal de instalación ha finalizado resultando en un malfuncionamiento del proceso hijo. Así TempMode solo funciona bien en los casos en los que el programa de instalación no inicia procesos hijos o como mínimo si no finaliza hasta haber completado la instalación.

Ejemplos:

a) TempMode

b) TempMode=¿Desea continuar la instalación de Calculator 3,05?,Instalación de Calculator


Órdenes SFX: Text

Esta orden es compatible con dos versiones de sintaxis:

a)

Text=<cadena de texto>

b)

Text

{

cadena de texto1

cadena de texto2

…

}

Agrega a la ventana de salida de texto del módulo auto extraíble las cadenas de texto especificadas. La primera vez que el módulo auto extraíble encuentra la orden Text, reinicia el contenido predeterminado de esta ventana antes de agregar <cadena de texto>. Las órdenes que le siguen añaden <cadena de texto> al texto ya existente.

Según la sintaxis utilizada, esta orden puede agregar bien una única cadena de texto bien varias a la vez.

Cuando se utiliza la segunda versión de la sintaxis, el módulo auto extraíble fusiona y vuelve a dar formato a la cadena de texto especificada para que se ajuste perfectamente al cuadro de diálogo. Por tanto, necesita situar la cadena vacía antes del párrafo si desea comenzar uno nuevo.

En el texto de salida, se reconocen y se procesan algunas etiquetas HTML. La especificación de la sintaxis HTML esta disponible en la página web del The World Wide Web Consortium. Puede usar cualquier editor de páginas web para preparar el texto.

Si el texto consiste en varias líneas, el modulo auto extraíble considera el carácter ‘}’ como el marcador del final del texto, de forma que no debe usarlo en la primera posición de ninguna línea de texto. Si necesita usar este carácter al principio de alguna línea de texto, por favor, inserte un espacio al principio.

Ejemplos:

a) Agregue una sola cadena de texto a la ventana del cuadro de diálogo

Text=Aquí está mi nuevo programa

b) Agregue el texto especificado a la ventana del cuadro de diálogo

Text

{

Algunas de las características más importantes de este programa son:

- compatibilidad con el portapapeles de Windows;

- procesamiento de ficheros con tamaño no superior a 10KB cada uno;

}


Órdenes SFX: Title

Title=<título>

Establece un título en la ventana.

Ejemplo:

Title=Calculator, versión 3,05


Órdenes SFX: Update

Update=<c>

El parámetro <c> puede ser el carácter U o F.

Si <c> es U, el módulo SFX extraerá los ficheros que no esten ya presentes en la carpeta de destino o que sean mas nuevos que los que ya esten en la cerpeta de destino.

Si <c> es F, el módulo SFX solo estraerá los ficheros que sean mas nuevos que los presentes en la carpeta de destino. Si no existe ninguna copia de un determinado fichero en la carpeta de destino no sera extraído.

Ejemplo

Update=U


Seleccionar los botones de la barra de herramientas

En este cuadro de diálogo, puede especificar qué botones de la barra de herramientas aparecerán en pantalla al examinar una carpeta del disco (grupo de opciones "Mostrar fuera de los archivos") o al ver el contenido de los archivos (opciones "Mostrar dentro de los archivos"). Es posible cambiar el orden de los botones sólo seleccionando los botones que desea mover y pulsando “Mover arriba” o “Mover abajo” para cambiar sus posiciones. Si desea volver a la configuración por defecto de la barra de herramientas pulse el botón “Predeterminado”.

El botón “Separador” inserta una línea de separación justo después del botón seleccionado. Si necesita eliminar un separador puede desactivar su casilla de verificación o bien ponerse encima suyo y presionar el botón “Separador”.

También puede arrastrar y colocar los botones directamente mientras mantiene pulsada la tecla Alt.